1 Reply Latest reply: Oct 21, 2011 8:53 AM by RonFairfaxVA
Newnham Level 1 Level 1 (0 points)

If you keep getting the message CIJScannerRegister.app, after you have upgraded to Lion, and use has I do a Cannon Inkjet printer (MX885), and all your updates, are up to date. The printer is connected to my broadband router.

 

Then I have blocked it in the Firewall settings, this did not seem to work. So I tryed to block this site, in my Netgear DG834G router.

 

Under BLOCK SITES, after you have log into the router, in the section TYPR KEYWORD OR DOMAIN NAME HERE. Type CIJScannerRegister.app, then apply it, logout of the router.

 

Shutdown the Mac and the router, and the printer if it is turned on. Leave OFF for one minute, then turn back ON, first the router followed by the Mac and printer.

 

This seems to solve the problem

  • RonFairfaxVA Level 1 Level 1 (0 points)

    Hi Newnham,

    For me, the solution was with a setting in the firewall Advanced Settings.  The app "CIJScannerRegister" was set as "Allow incoming connections", but there was another item that was blocked: "canonijnetwork.bundle". 

     

    I set the "canonijnetwork.bundle" to "Allow incoming connections", and now all is well.

     

    One thing... my iMac is quite new and does not have any legacy apps.  Also, shortly after I bought it I upgraded to Lion.  I don't know if that makes a difference for anyone else.