4 Replies Latest reply: Jan 6, 2014 11:39 AM by mjrmajor
lislewis Level 1 (0 points)

I'm trying to use lion recovery disk assistant to create an external recovery disk.  but after I accept the terms of use and it starts looking for external drives, it just hangs (the spinning gear). I have a 2 TB external drive that I've partitioned into four. Is that the problem. Or should I re download the assistant?

iMac, Mac OS X (10.7.1)
  • keg55 Level 5 (7,265 points)

    I think most use a USB thumb drive with Lion Recovery Assistant. but the web page says it can be used on an external drive too. Are you sure your current install of Lion has the Recovery HD present and it's not corrupted?


    The Lion Recovery Assistant needs to have the built-in Recovery HD partition available. Open Utilities/Terminal and type diskutil list. Check to be sure the Apple_Recovery HD partition (~650mb) is there. If it's not or it's corrupted, you will need to recreate it by reinstalling Lion on top of itself then reapply the 10.7.1 update.

  • lislewis Level 1 (0 points)

    Thank you. I looked in Terminal and the boot partition is there. I also started up from it (command-R) and it worked. But the assistant still hangs and doesn't see my partitioned external hard drive. Disk Utility does.

  • keg55 Level 5 (7,265 points)

    Make sure the partition you're trying to use with the assistant is GUID partition table and Mac OS Extended (Journaled). It needs to be formated - bootable. If it is, I guess I would try re-downloading the assistant, uninstall the prior assistant, install the freshly downloaded one and try again. Four partitions shouldn't matter as long as you're using one of them for the Lion Recovery Assistant. Preferably the first partition.


    I have a 4GB USB thumb drive with 2 partitions. The 1st partition is 700mb GUID - Mac OS Extended (Journaled) and the 2nd is the rest of the space with the same format as the first. I used the Lion Recovery Assistant and pointed it to the 1st partition and it worked fine.

  • mjrmajor Level 1 (0 points)

    I was having the same issue, but then I read the OS X Recovery Assitant requirements. The partition you're using must have at least 1 TB of space free. If you've partitioned a 2TB drive into four pieces, then a single partition probably doesn't have enough space. You might want to try another drive with more avaialble, unpartitioned space.