8 Replies Latest reply: May 8, 2014 2:15 PM by scubachild
skbanks262 Level 1 (0 points)

I purchased an O2 surfstick here in Germany. I downloaded the software with no problems but when I try to connect to the internet I get an error that says "The connection has failed. Please verify your settings and try again." I don't know what settings need to be verified. I have tried everything I can think of. HELP!

MacBook Pro, Mac OS X (10.5.8), Huawei E1750 Device
  • D0GG Level 3 (945 points)

    You might want to contact 02. They would most likely be able to offer better support for their product.

  • skbanks262 Level 1 (0 points)

    Yeah. I was trying to avoid that because I wanted to figure it out in english. Deutsch it is then I guess

  • giovanni_74 Level 1 (0 points)

    Hi All!

    I bought an O2 stick in Germany. I have the same issue since I installed the security upgrade 2011-006 for Snow Loepard. That said, I cannot say if there is a relation between the two events. Although, I might think so...


    Anyway, it seems that randommly I can connect. I tried the followings:

    - Connecting the stick on both ports

    - Re-installing the software

    - Rebooting the computer


    I can do those actions in any order and randomly happens that it works and I start surfing like I am doing now.


    If anyone has an idea please let it post...


    I will try to inform myself next weekend in an O2 shop and I will let you know...




  • mamckinn Level 1 (0 points)

    I have also had the same problems with 02. I asked the salesman and he told me it was a problem with my computer and the internet stick worked fine with his computer. I finally get tired of installing, uninstalling, restarting, etc. so I broke down and bought a stick for vodaphone. The same problem occured with the vodaphone stick as with the 02 stick. Did anyone figure out the problem? I would appreciate to know because from all of this I have spent much more money on internet than necessary.


    I currently have Telekom which actually works, but it costs 5€ per day so I am looking for a cheaper option.

  • Molinalu Level 1 (0 points)

    Same situation here. I went back to the O2 store where I got my contract (btw this was a gift from the store since our home Internet would be set in about 3 weeks, so they gave us the stick in the meantime). We tried the stick in his PC and worked fine...then I went to a Mac store here in Munich and they wouldn't even look at my computer. The guy at the store said that is a very common thing with O2 surfsticks...Vodafone and telecom work with out a glitch, then he went on and on about the relationship between O2 and apple, any way, bottomland, is that nobody knows what the solution is...so, if anyone finds what the magic trick is, please share!  Tired of using my android phone as a WLAN router...auf Wiedersehen ...

  • Eddy Wong Level 1 (0 points)

    Please try :


    1, open the setting of internet on the Mac.

    2, on the device , choose the surf stick

    3, click on Advance

    4, on the device, choose "General"in the manufacturer list and "3G/ GPRS device" in the device list

    5, in the APN field , type "internet"

    6, click apply and connect again


    I have tried and it works on my O2 surf stick, I hope it works for you too, good luck!

  • Flaminio75 Level 1 (0 points)

    I had a similar problem:


    I was able to connect, but not to insert the cahscode to refill my prepaid account. When ofening safari, I was addressed to a page where it was asked to me to register my sim card. oBut my card was alredy registered! A cul the sac...


    Anyway, I solved this problem in a very simple way: I took out the sim card from the o2 surfstick (Model MF190) and i put it in an universal stick (HuaweiE182E). Anyproblem was solved! When opening Safari, i was automatically routed to the right page, allowing me to re-charge my credit and selecting my surfing plan.

    teh problme is obvioulsy with the O2  surfstick and the connection manager software. Not compatible with the Mac...

  • scubachild Level 1 (0 points)

    Big Thanks Eddie Wong!  This worked for me.