1 Reply Latest reply: Dec 12, 2011 4:44 PM by Ray Davis1
BradPDX Level 1 Level 1 (65 points)

This MacBook had some of this issue with Snow Leopard, but the problem is worse after upgrading to Lion. I will note that I have 2 Macs running Lion, and only this one has the problem - it isn't a generic OS issue.

 

Problem is simple: Firewall is ON and individual applications are listed with "Allow Incoming Connections" selected. But this setting appears ignored for several (not all) apps, and the result is a firewall message (Deny or Allow incoming connections) at each launch. The culprits are applications that definitely connect via the network for services, such as iPhone remotes in Keynote, or iPhone syncing of various apps, etc.

 

I am aware of an older cure for this - remove and reinstall the offending application. But that does not appear to work for me, the popups persist. Not the end of the world, but annoying when everything else works great.

 

I have tried removing the apps from the Firewall list. They are added back after first launch, but the popups keep coming. The Firewall settings appear not to "stick".

 

I wish I knew a way to reset the Firewall database, but alas I do not. Any suggestions from this group?


iMac Intel Core 2 Duo, MacBook Intel Core 2 Duo, iPhone 3GS, iPad, Mac OS X (10.7.1)
  • Ray Davis1 Level 1 Level 1 (5 points)

    No one else has had this problem? I'm getting the same issue with Entourage 2008  on my wife's account. I can go into her firewall settings, set Entourage to allow incoming connections, but when I start Entourage i get the pop-up to allow connections, then another one that wants the admin login to chage firewall settings. Hit cancel on that, open up the firewall settings and Entourage has been set to deny incoming connections. Every time, so something about Entourage is reseting the connections.

     

    Any ideas?