Skip navigation

Lion NFS resharing

2759 Views 7 Replies Latest reply: May 4, 2012 7:48 AM by IngoRi RSS
stacywescom Calculating status...
Currently Being Moderated
Sep 7, 2011 11:43 AM

I am trying to get Lion to reshare folders from an NFS mount via AFP.


In 10.6 this was fairly straight forward. However in Lion I am running into all sorts of problems



Here is what I have done:


NFS share from FreeNAS, using LDAP to bring in Open Directory UIDs/GIDs.


NFS share is mounted on our Lion Mac Mini, and i can read/write files/folders from the mac mini.


In Server, in File Sharing, I have created several shares of folders in the NFS mount, and everything seems to go alright.


However, when I connect to the server from a client machine, I see shares from the local harddrive, but none of the shares from the NFS mount show up.


However from SMB, I can see the shares, but if I try to access them, it fails.


Any ideas? I have googled this for the last week, and no one seems to be posting about any issues like I am having, however, it may just be that resharing NFS with AFP isnt very popular.



Mac OS X (10.7.1)
  • DJEMiVT Calculating status...
    Currently Being Moderated
    Oct 6, 2011 5:33 PM (in response to stacywescom)

    I'm also experiencing this exact same issue. Anyone have any suggestions?



  • Peter Glock Calculating status...
    Currently Being Moderated
    Dec 5, 2011 1:18 PM (in response to stacywescom)

    Same issue for me. I can mount the NSF share using disk utility but it won't show up via arp, smb, or WebDAV.

  • Peter Glock Level 1 Level 1 (45 points)
    Currently Being Moderated
    Dec 6, 2011 2:47 AM (in response to Peter Glock)

    I deleted the share on both my ReadyNAS and on the LIon server then started again. This time I:


    1. On ReadyNAS - Created a share (testnfs)
    2. On ReadyNAS - shared testnfs via nfs, set root access to ip address of Lion server
    3. On Lion Server - Open Disk Utility and select 'File > NFS Mounts'
    4. On Lion Server - Mount nfs://url_of_ReadyNAS/testnfs as /Volumes/testnfs left all other options alone
    5. On Lion Server - in Finder, go to /Volumes and check testnfs has mounted with r/w permissions
    6. On Lion Server - in Server app, go to file sharing and share testnfs (I selected afp, smb and webdav)
    7. On Client - in Finder, connect to Lion server (i tried with afp://url_of_Lion_Server, smb://url_of_Lion_Server and https://url_of_Lion_Server/webdav and see the testnfs share as one of the options

    All good so far.


    The problem I'm no facing is that I can't rename the files on testnfs from the client. I can create/delete and open files and folders ok. I guess this is something to do with permissions.


    Any ideas?

  • Peter Glock Level 1 Level 1 (45 points)
    Currently Being Moderated
    Dec 6, 2011 7:08 AM (in response to Peter Glock)

    Did some more playing around this afternoon. It seems that the export from the ReadyNAS needs to be set as:


    "/testnfs" IP_address_of_Lion_Server(insecure,insecure_locks,rw,no_root_squash,async)


    I can do this by disabling default access and adding the Lion Server IP address both as a "write-enabled host" and a "root-privilege enabled" host. I guess the FreeNAS interface allows for the same settings.


    I can now rename, edit, delete, create to my hearts content. Even works from webdav.


    Final hint: you may need to change permissions for any files already in the nfs reshare.

  • Peter Glock Level 1 Level 1 (45 points)
    Currently Being Moderated
    Dec 6, 2011 9:35 AM (in response to Peter Glock)

    oh dear, spoke to soon. Permissions for files created on the share seem to be 744 i.e. only owner can change an existing file or folder. I need to work out how to make this 770 so I can create a group folder on the nfs share, accessible via webdav. Note: ACLs don't seem to work on my ReadyNAS so it will have to be done via POSIX permissions.

  • Peter Glock Level 1 Level 1 (45 points)
    Currently Being Moderated
    Dec 12, 2011 4:00 AM (in response to Peter Glock)

    The webdav problem is a known issue. There's a workaround here:

  • IngoRi Calculating status...
    Currently Being Moderated
    May 4, 2012 7:48 AM (in response to Peter Glock)



    No luck with the same try: NFS-Share from Linux System with

    /nfsexport LionServerIP(insecure,insecure_locks,rw,no_root_squash,async,nosubtree_check)


    mounted /nfsexport via DiskUtility to /Volumes/nfs


    used to share this volume - but I cannot access it.

    From Mac (AFP) I cannot "see" the share, via SMB I can see it, but get access denied.


    I don`t know how you managed this - maybe someone else has a hint how to reshare NFS via AFP with 10.7.3 Lion Server?


    Help appreciated




More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.