4 Replies Latest reply: Sep 7, 2011 8:27 PM by china_mike
Dumb User Level 1 (0 points)

Over the past week or so, my iTunes store has been so slow it actually never loads.  The libraries work fine.  My internet connection is fine.  I've uninstalled iTunes and reinstalled it (Version 10.4.1.10).  The iTunes diagnostics test indicated everything was fine.  I read in the forums that a couple years ago people had the same problem and it was an update on a virus program that caused the problems.  I use McAffee Virus Scan Plus.  This was not the offending brand from a couple years ago.  Has anybody else had similar issues recently or have a solution?   Thanks


iPad 2, Windows Vista
  • china_mike Level 1 (0 points)

    I have the same problem and when I run diagnostics it says unable to connect to a secure server.  If you go into the Help menu and click diagnostics, then uncheck all but the top option and run it; then click next after it runs ... you will get a diagnostics detail that can be copied to your clipboard and posted.  This is what people need to help you.

  • Dumb User Level 1 (0 points)

    Mike,

    Here is all the diagnostics program says.  No real detail other than it passed.    

     

  • Dumb User Level 1 (0 points)

    oops.  It didn't like the pasting of the screen shot.  In any case, all the things tested for were green with no problems.

  • china_mike Level 1 (0 points)

    OK, it is great that you ran the diagnostics and it passed.  Usually that means it is related to your internet connection and the traffic on the iTunes server then.  Usually a timeout error.