Previous 1 2 Next 17 Replies Latest reply: Mar 6, 2013 3:12 PM by codefish46
gilesgold Level 1 (0 points)

Hi there, for some reason my Imac is struggling to reconnect with its old backups on time capsule. I've tried various suggestions using Ponderini's excellent time machine site ( but I'm now concerned that the problem may be a tricky one to solve. I've tried to 'inherit' backup by reattaching the backup sparsebundle through the Terminal but the following error message is returned:


[giles-imac:~] giles% sudo tmutil inheritbackup /Volumes/Time\ Capsule/Giles\ Imac.sparsebundle

Attaching disk image...

2011-09-10 11:49:28.471 diskimages-helper[691:2703] Error loading /Library/Plug-ins/DiskImages/VirtualPCDiskImagePlugin.bundle/Contents/MacOS/Vir tualPCDiskImagePlugin:  dlopen(/Library/Plug-ins/DiskImages/VirtualPCDiskImagePlugin.bundle/Contents/Ma cOS/VirtualPCDiskImagePlugin, 262): no suitable image found.  Did find:

          /Library/Plug-ins/DiskImages/VirtualPCDiskImagePlugin.bundle/Contents/MacO S/VirtualPCDiskImagePlugin: mach-o, but wrong architecture

2011-09-10 11:49:28.472 diskimages-helper[691:2703] Cannot find function pointer MacDiskImagePluginFactory for factory 7F1FD83E-6684-11D8-968F-000A957703C0 in CFBundle/CFPlugIn 0x7fc0f3d1e750 </Library/Plug-ins/DiskImages/VirtualPCDiskImagePlugin.bundle> (bundle, not loaded)

/Volumes/Time Capsule/Giles Imac.sparsebundle: Attach failed: Failed to attach disk image. (error 35)

[giles-imac:~] giles% sudo tmutil associatedisk -a /


Many thanks for any suggestions you might be able to offer!

iMac, Mac OS X (10.7.1)
  • d2102 Level 1 (0 points)

    You probably solved this problem already, but I just had the same problem and it was because I needed to first disable time machine in the system prefs. 

  • arflyarf Level 1 (0 points)

    Hi and thanks for having this post up. 

    I'm experiencing a similar problem and would love your input.

    My time capsule was out of commision (overheated by power supply) for the entire summer and I was finally able to repair it after several months.  Although I made other backups along the way, I would like to go back and connect to the old history going back to 2009.  In the mean time, a friend spilled coffee on my macbookpro and I had to replace the logic board.  So now, when I connect to the time capsule, it begins to create a new sparsebundle called "[my computer] 1" with no history.  If I option click on the time machine in the menu bar, I can "browse other backup drives" and asign my computer to use the old backup volume. The entire history is there and comes up and seems to be working great. 

    here's the problem:  a few hours later, I'll notice that it's gone back to making a new backup that's not connected to the old history. 

    I've tried turning off time machine in Sys Prefs and then using terminal to delete (band by band) the unwanted new sparsebundle ( ).

    Then I use the pondini B6 instructions to "inherit" the old backup and here's what happens:


    pu:~ A$ sudo tmutil inheritbackup /Volumes/Data2TB/pu.sparsebundle


    Attaching disk image...

    /Volumes/Data2TB/pu.sparsebundle: Attach failed: Failed to attach disk image. (error 35)

    pu:~ A$ sudo tmutil associatedisk -a / /Volumes/Time\ Machine\ Backups/Backups.backupdb/pu/2012-07-14-124855/Lobster

    pu:~ A$ sudo tmutil inheritbackup /Volumes/Data2TB/pu.sparsebundle

    Attaching disk image...

    /Volumes/Data2TB/pu.sparsebundle: Attach failed: Failed to attach disk image. (error 35)

    pu:~ A$ sudo tmutil inheritbackup /Volumes/Data2TB/pu.sparsebundle


    Attaching disk image...

    /Volumes/Data2TB/pu.sparsebundle: Attach failed: Failed to attach disk image. (error 35)

    pu:~ A$


    Anyway, I can't seem to find out what error 35 means in this context. 

    Would appreciate any input or thoughts.


  • d2102 Level 1 (0 points)

    Did you "turn off" time machine in the preferences before running the inherit command?

  • arflyarf Level 1 (0 points)

    Thanks for responding d2102,


    Yes I did turn off the time machine.

    It went like this:

    1.  I turned off time machine in System Preferences

    2.  tried the inherit command.

              pu:~ A$ sudo tmutil inheritbackup /Volumes/Data2TB/pu.sparsebundle

          It said this: 

              The image "pu.sparsebundle" can't be inherited because it would conflict with "pu 1.sparsebundle".


    (pu is the computer name.  "pu 1" is the new sparsebundle that got created when the new logic board first connected to the time capsule. )


    3.  Because it said pu 1 was getting in the way, that's why I went to delete the bands in the sparsebundle using


    pu:~ A$ for i in {0..1000000}; do rm -rv /Volumes/Data2TB/pu\ 1.tmp.sparsebundle/bands/$(printf "%x" $i); done


    which I got from here


    (all this whole time time machine is still turned off in system preferences)


    4.  with the pu 1 sparsebundle gone, I ran the inherit command again. 

         that's when I got the result in my first post (printed again here)

    pu:~ A$ sudo tmutil inheritbackup /Volumes/Data2TB/pu.sparsebundle


    Attaching disk image...

    /Volumes/Data2TB/pu.sparsebundle: Attach failed: Failed to attach disk image. (error 35)

    pu:~ A$


    Would love to hear input from anyone who knows more about this. 



  • d2102 Level 1 (0 points)

    i am not an expert in time machine by any means, but here are some things to try:


    * if you hadn't already, in step (3) i would make sure to delete the whole sparese bundle including the plist e.g.

      rm -rvf /Volumes/Data2TB/pu\ 1.tmp.sparsebundle


    * try attaching the sparsebundle 'manually' using hdiutil, as in this post



    hdiutil attach -ignorebadchecksums -noverify -verbose -nomount -readwrite Quechua_0017f2cdc7fd.bad.sparsebundle


    maybe this would give you some more useful errors..  (possibly there are other command line options that are useful - don't know...) 

  • arflyarf Level 1 (0 points)


    I think I may have found the problem.

    My wife's computer also uses the same time capsule drive. 

    I thought that time machine on her computer was turned off.

    But then I was reading the articles in the links you sent me and the guy mentioned something about doing a disk repair and making sure that time machine is turned off because "We don’t want Time Machine trying to mount our image and back up to it until we’re done making all the repairs."

    Until I read that, i hadn't really thoought about the sparsebundle as a real image and I suddenly wondered if my wife's machine could interupt any kind of disk repair that I was trying to do to the sparsebundle disk image of my machine.  Turned off her time machine and ran the inherit command and it worked. 

    Now I'll just need to try it and see if it worked to actually solve the problem.

    Thanks again.

  • arflyarf Level 1 (0 points)

    well.  not so lucky yet.

    after turning time machine back on and choosing "backup now", a few minutes into it, I got this pop-up:

    "Time Machine couldn’t complete the backup to “[Time Capsule]”. The backup disk image “/Volumes/Data2TB-1/pu.sparsebundle” is already in use."


    Now I'm going to look into why the data drive got "-1" added to it's name. 

    I think that might be the next problem to solve.


  • d2102 Level 1 (0 points)

    i think the -1 gets added under certain conditions if the time capsule volume was previously mounted - i don't think that is a problem - it is just the mount point. 


    is your wife's machine named the same?  otherwise it should not interfere with the time capsule sparsebundle.  if you think it might, you should try turning it off while doing this.


    re your other message- yes the sparsebundle is a file system image, and it gets mounted using hdiutil under the covers, I believe.


    another thing to do is keep the "console" app open (monitoring the system log messages) and set a filter for 'backupd' -- you may see something useful there.


    BTW - what version of the OS are you using?  i had a problem with time machine under snow leopard that i could not fix, that persisted through an upgrade to Lion --  and I ended up reinstalling completely from scratch to fix it.  I never figured out what was wrong.  I am on mtn lion now and I kind of have the impression that time machine works better in the newer versions.

  • arflyarf Level 1 (0 points)

    thanks for the tip about the -1.

    my wife's machine is not named the same. And turning her time machine preference off was the only thing I changed between the (error -35) result on the  inherit command and the successful run of the inherit command.

    that just made me think it was connected.


    thanks for the console suggestion.

    I just went back and looked at all the backupd messages and there were a bunch like this right around the time when the backup failed and said time machine couldn't complete the backup because the sparsebundle was already in use.


    10/22/12 8:41:00.260 PM[506]: Failed to mount disk image: Error Code=31 "The operation couldn’t be completed. ( error 31.)" UserInfo=0x7fa2d2c52ae0 {MessageParameters=(



  • arflyarf Level 1 (0 points)

    just tried this -disk-already-in-use&more=1&c=1&tb=1&pb=1

    One time I tried it while leaving the "choose Time Machine Disk to Browse" window that comes up when you option-click on the time machine in the menu bar and then select "Browse Other Backup Disks"

    When I first open this "Disk Browser" there are three volumes listed, all different variations on "pu" on ____.

    Two of them are called   [   "pu" on "Time Machine Backup"  ] one has a regular volume icon with wifi symbol on it and the has a blue-green volume icon with three little people on it. But the third "disk" is the interesting one.

    It's called [ "pu" on ""    ]  (literally.  it's got empty quotes for its location)


    And here's the really interesting thing.   When I do the "disconnect all users" from the link above, I can see the other two voumes disappear.  But the "pu" on "" volume stays. 


    Now I'm wondering if I've got some kind of phantom version of the backup that is able to stay in my computer's system even when the time capsule is disconnected. 

    I just tried deleting the files from volume/Library/preferences and the phantom backup drive is still there.

  • d2102 Level 1 (0 points)

    the one with "" may be something like 'mobile backups' on mountain lion.. what version of the OS are you using?

    when i do this on mountain lion with no time capsule nearby i get


    ".RecoverySets" on ""

    ".RecoverySets" on ""

    ".spotlight_temp" on ""


    have you tried mounting it manually?

  • arflyarf Level 1 (0 points)

    Hi, sorry it's been a while.  I live in New Jersey and we had a little bad weather .


    So I tried attaching it manually and then running

    fsck_hfs -rf /dev/disk1s2


    it ran forever and then finished with

    ". . . ** The volume Time Machine Backups appears to be OK."


    after that I had trouble getting to enter the time machine. (which had worked before).

    the error message was a four digit number which I can't recall -8654 or something like that.


    and then I ran the sudo inherit backup again and it started working again. 

    But when I try to start a new backup, now I'm getting the message that


    'Time Machine couldn't complete the backup to "CrUsTaCeAn".

    The backup disk image "/Volumes/Data2TB-1/pu.sparsebundle" is already in use.'


    huh.  any thoughts.

  • arflyarf Level 1 (0 points)

    the error code was -6584 

    I just got it again.

  • d2102 Level 1 (0 points)

    Glad you are safe after the hurricane!  Unfortunately, though, I don't have any great ideas about time machine

    I've found it to work well when it works, but when it doesn't sometimes the cause is very hard to determine.

Previous 1 2 Next