Previous 1 2 3 4 Next 49 Replies Latest reply: Mar 23, 2015 11:33 PM by iamkappa
softwater Level 5 Level 5

I recently had to restore my system from TM Backup. After the restore, there's an old backup TM file in the trash which I can't remove. The principle reason I can't remove it is there's boot.efi file in there which is locked. Here's what I've tried

 

1. Changing the permission to read & write in the Get Info window.

This has no effect because the Locked option remains greyed out even after unlocking the permissions.

 

2. I've tried the advice given here: http://support.apple.com/kb/TS1402

The commands aren't accepted in Lion

 

3. sudo rm -rf ~/.Trash

Doesn't have any effect

 

4. From an earlier (2008) post about this problem, it was suggesed by Kappy to try advice from this site: http://www.thexlab.com/faqs/trash.html

Their advice basically ends up advising one of the first three things I tried.

 

Any other suggestions? Ten points for the winning postcard..


MacBook Pro 2.53GHz Intel Core 2 Duo, Mac OS X (10.7), 4GB 1067 MHz DDR3
Solved by softwater on Sep 11, 2011 3:08 AM Solved

Hold down the option key when you click 'Empty'.

 

Lord knows why this works when all sorts of 'power user' terminal tips don't. But there you go!

 

empty.png

Reply by Larry McJunkin on Mar 3, 2013 7:37 PM Helpful

Shameless plug?  I don't have a clue who it's developer is, but I just now searched for reviews on it and came up with over 4.5 of 5 stars everywhere I looked. Nowhere did I see where anyone had a problem with it. It's a free app with no ads and is highly reviewed everywhere I checked. I've personally used it several times now and have nothing but praise for it.

 

Pardon me for offering a suggestion that works...when the usual guidance for fixing this problem didn't work. And do not imply that I have anything to do with this app merely because of my suggestion to use it.

All replies

  • softwater Level 5 Level 5

    Yikes...things are getting scary. Now there's two copies of Finder in the Force Quit menu — I thought that was impossible — and neither of them seem to want to go anywhere.

     

    Terminal: killall Finder

    didn't work either.

     

    OK, I'm going to reboot again and see what happens, but what the **** is going on?

     

    FinderFreeze.png

  • softwater Level 5 Level 5

    Rebooting seemed to have solved the scary Finder problem but not the trash problem.

     

    I've now figured out that the undeletable files are stored on the TM backup disk, since my trash can appears empty when TM is not connected, and not empty when it is. Also, navigating to this through Finder tree shows the offending folders and files.

     

    Any idea how I can delete this Trash folder from the TM backup disk?

     

    TmTrash.png

     

     

    I can't delete these manually. I get the error message:

     

    Trash errormsg.png

     

    Any thoughts?

  • softwater Level 5 Level 5

    Hold down the option key when you click 'Empty'.

     

    Lord knows why this works when all sorts of 'power user' terminal tips don't. But there you go!

     

    empty.png

  • techkenb Level 1 Level 1

    Thanks! That worked for me.

  • gwilanne Level 1 Level 1

    I have been trying to delete mine for hours and the option key doesn't work, I can't delete or move the file from my trash

  • softwater Level 5 Level 5

    I suspect that the file is in the .Trash folder of your Time Machine (TM) or some other disk (see my screenshot above), and so you don't have the permissions.

     

    To find out if that's so, follow this procedure:

     

    1. Open Terminal.app, copy and paste the following command into the Terminal window

     

    defaults write com.apple.finder AppleShowAllFiles TRUE

     

    Then press 'Return'. Then copy and paste this command:

     

    killall Finder

     

    Then press 'Return'.

     

    2. Open a Finder window. Navigate to the TM disk starting from its icon in  the left hand column. You should see some greyed out folders called .Trash and .Trashes. Click on these and have a look for the boot.efi file that we're hunting down. If you can't open these folders (if they have a red 'no entry' icon on them), post back here.

     

     

    To remove the boot.efi file from the hidden trash, try the following:

     

    3. Go back to Terminal and copy and paste the following:

     

    sudo rm -rf

     

    Do NOT press 'Return'. Instead, press the Spacebar once, then use your cursor to drag the boot.efi file from the hidden folder in Step 2 and drop it in the Terminal window. Now press 'Return'. You will be asked for an administrator password and given a warning which you can ignore. Type in your password, but notice that your typing will be invisible, so type carefully. Press 'Return'.

     

    4. If you typed your password incorrectly, repeat step 3. If you typed it correctly, hopefully, your Trash is empty! If not, post back here with any messages from Terminal.

     

    5. Last thing is to hide all the hidden files again, copy and paste this:

     

    defaults write com.apple.finder AppleShowAllFiles FALSE

     

    Then press 'Return'. Then copy and paste this command:


     

    killall Finder

     

    You can close Terminal now.

     

     

    Good luck!

  • henrique.correia Level 1 Level 1

    This works very fine. Best answer on the net.

  • ilivethebrand Level 1 Level 1

    Thanks for that option and empty button click. This seems to have worked for me. I have been fighting these files for a few weeks now and I like to use forums only after I have tried everything.

     

     

     

     

     

     

     

    Thanks,

     

    Fredric Gant

    Macs are my life

    Life Coach / Cert. Herbal Nutritionist

    www.ilivethebrand.com

  • kingsx Level 1 Level 1

    Thanks! This did the trick!

  • AldinhoRufus Level 1 Level 1

    Excelent solution!!

  • Run4Jesus Level 1 Level 1

    softwater - You are awesome! Thanks so very much! I was working on that for hours.

  • zpearl Level 1 Level 1

    Worked for me like a charm.... Thanks

  • ragtacker Level 1 Level 1

    After hours of searching It worked like magic !!!   thank you

  • Daniel-Elek-Diamanta Level 1 Level 1

    Wow! Been scratching my head for DAYS! Deleted with the terminal method. At one point I thought I had deleted everything from my external, including my job... remounted the drive and they appeared again. PHEW! Nearly died! lol. THANKS!!

Previous 1 2 3 4 Next