Previous 1 2 Next 15 Replies Latest reply: Oct 24, 2011 3:38 AM by SLSerdikoff
Brian Gavin Level 1 Level 1 (50 points)

Like so many others my Mac Book Pro is without the use of my built in iSight camera, but here is where it gets weird.  If I unplug my external hard drives it works.  If I plug the drives back in Time Machine stops working, but my other drive (identical drives by the way) works fine.  Its just Time Machine and iSight that don't work.

 

I tried resetting the system by unplugging it and removing the battery, and the P,R thing... nothing works.

 

I can't believe Apple would release such a horribly flawed operating system.  I have been using Apple computers since OS 8.  Sure upgrading always has a few quirks, but this... its all quirks and no functionality.

 

Safari won't load a page if my external drives are asleep.  I have to wait for them all to spin back to life before the pages will load.  The system takes for ever to start and shut down.

 

Welcome to Windows 98.


MacBook Pro, Mac OS X (10.7.1)
  • Hunter45S Level 1 Level 1 (0 points)

    My Macbook Pro is a 4,1 model Early 2008.  I do like Lion but did use Skype reguarly until the upgrade to Lion and now cannot use any camera function.  Essentially the USB hub does not see the inbuilt isight and some have said it a the 32bit/64 bit issue.  Like you I have tried everything and I would like a statement from Apple that this is recognised as a fault and a possible fix date.  I can downgrade to Snow Leopard but remain hopeful that a fix will come.

  • SLSerdikoff Level 1 Level 1 (0 points)

    I also have been unable to get the built-in iSight on my mid-2008 MacBook Air to work since upgrading to Lion. I've tried all suggestions I've found online (shutdown and unplug for 15 min; reset SMU/PMU with Shift-Control-Option-Power for +30 sec; reset PRAM/NVRAM with Cmd-Option-p-r during boot and allow multiple chimes; & hold shift after pressing Power to perform a SafeBoot) EXCEPT removing the battery (because it is an Air).  I've tried various programs (Photo Booth, iChat, creating a digital signature in Lion Preview) using both my account and a "test user" account I created. I do not have any external USB devices attached. No picture - no matter what!

     

    In my case, the iSight DOES appear in the system profile (unless I boot in SafeMode):

    iSIght Screen Shot 2011-09-15 at 9.15.44 AM.png

     

    I have not noticed anything else not working properly or taking longer than before. I do not use the camera much and probably won't downgrade back to Snow Leopard, but I hate the idea of having something not working.

     

    I agree with Hunter45S that a statement from Apple that this is recognized as a fault and some indication of a possible fix date would be nice.

     

    [Windows 98 - maybe.  Still not as bad as the Vista fiasco!] --SLS

  • Brian Gavin Level 1 Level 1 (50 points)

    Try unplugging the USB hub.  I know its stupid but apparently Lion can't handle too many USB things at one time.  I have two identical external drives plugged into a hub and when they are plugged in, no camera, but if I unplug them and boot the computer there is the camera, but then the drives wont work.  Don't plug them in until you shut the computer down again otherwise Lion kills them and you have to reformat them using another machine.

     

    It has been a nightmare, I wrote to Apple's tech support and have heard nothing from them.

     

    Someone on another site with the same problem said a clean install will clear it up, but I have been trying to get that to work for the past sixteen hours.  The download keeps failing, so... back to Snow Leopard for me.

     

    All in all Apple gets an F on this project.

  • SLSerdikoff Level 1 Level 1 (0 points)

    Thanks for the tip, but I do not have a USB hub - I have a MacBook Air with only one external USB and nothing plugged in.  The other USB items shown in the system profile pic I posted are internal - built-in like the iSight. Of course, that does not mean that the problem isn't the same -- these internal USB devices could be blocking the iSight.  This will be a problem with every MBA, if that's the case.  The devices are disabled, but I know of no way to physically disconnect them.  Any suggestions on that?

     

    For the record, I made an appointment with Apple Support and they spent an hour on the phone with me, walking me through all of the steps I had already tried (SMU reset, PRAM rest, etc.).  In the end, the tech said it must be hardware and suggested I take it to the local Apple dealer.  That was just over a week ago - I have not had a chance to do it yet.  What I'm afraid of is that I'll have to pay for them to replace something that does not need to be replaced.  If it's not really hardware, then a new camera wouldn't work either - right? And in that case I should not have to pay for it - right?  I do not have any experience with this.

  • Brian Gavin Level 1 Level 1 (50 points)

    Is your Mac Book Air still under warranty?  It can't be that old can it?  Anyway it can't be a hardware issue because too many of us are having the same problem. If you have a way to do a clean install of Snow Leopard you can do that first and see that the camera still works fine. I know it's a huge hassle, but it worked for me. I'm actually doing it again now for my husbands Mac Book Pro too.

     

    There is no way they can charge you for anything, just have them come here and read how wide spread the problem is.

  • Brian Gavin Level 1 Level 1 (50 points)

    I just discovered the doing a full and complete clean install did nothing to help with the external drive problem.  So apparently Lion can't handle USB at all.  I am right back to where I was originally only now I have a computer with no programs on it.

     

    I'm so angry that Apple released Lion with such a MASSIVE flaw, and I'm even angrier that no one from Apple is addressing it.

  • SLSerdikoff Level 1 Level 1 (0 points)

    Ouch - that's why I can't even think about a clean install of Snow Leopard just to check the iSight.  Like I said, I don't use the camera much so I can probably wait it out.  Not that coincidences don't happen, I'm also inclined to agree that this is not hardware issue.  And, I'm very surprised Apple has not responded to you or even come out to say they know about it and that they are working on it.  Not a good first impression of the new Apple regime!!

  • Hunter45S Level 1 Level 1 (0 points)

    Update...... The Isight is now recognised and is working correctly in all apps - probably always going to be a mystery.  Maybe Apple fixed it? Anybody else report mysterious fix?

  • SLSerdikoff Level 1 Level 1 (0 points)

    Not working for me -- but my problem was different.  My iSight was/is showing up in the system profile and the green light goes on in all apps.  It's just that there is no picture; black screen in Photo Booth, iChat, etc. --SLS

  • Jung Jongbin Level 1 Level 1 (0 points)

    Had the same problem. "Disk Utilities > Repair Permissions" fixed it for me tho- Give it a try?

  • SLSerdikoff Level 1 Level 1 (0 points)

    Thanks for the tip, but I tried "Disk Utilities > Repair Permissions" and it did not work. ~~SLS

  • grammatootall Level 1 Level 1 (0 points)

    Tried all of the above, nothing has worked to restore a perfectly good iSight. No camera recognized in any apps, nor in system profiler...since installing Lion! whaaaa???

  • EZ Jim Level 7 Level 7 (21,780 points)

    • If Apple's http://support.apple.com/kb/HT2090

       suggestions do not help you, continue with the following.

     

    • Use Disk Utility to repair permissions and then

       download and apply the 10.7.2 Combo Update:

         http://support.apple.com/kb/DL1459

     

    • Repair permissions again immediately following the system restart

       that completes the Combo update.

     

    The Combo version of updates can sometimes correct

    strange problems like yours.

     

    If your built-in iSight is still not recognized as a USB Hardware device in your Mac's System Information utility, see your AASP for professional help.

  • grammatootall Level 1 Level 1 (0 points)

    Thank you for responding! I already had the 10.7.2, and i did repair disc permissions, and do the restart yesterday...but maybe it all just needed to rest...shutdown last night, and this morning iSight is back. whew! thanks!

Previous 1 2 Next