4 Replies Latest reply: Jun 3, 2014 9:59 AM by Dynasty3000
Rawrbee Level 1 Level 1 (0 points)

I recently brought a WD My Passport, Im trying to format it on my mac pro but its saying "volumes are busy and cannot be dismounted" the then tried formating with disk utility but it says "could not unmount disk" please help!!! WD


WD Passport
  • Camelot Level 8 Level 8 (46,120 points)

    Well, the error message pretty much tells you what's going on - the disk is in use, therefore can't be reformatted.

     

    You'll need to close any applications and files that you've opened on this disk before you try to reformat it.

     

    (Just to check, you're not booted off this disk, right? You can't reformat the disk you're booted from, under any circumstance).

     

    If you're not sure which application has a hold on this disk the best thing to do would be to restart your machine without the disk attached. Once booted, launch Disk Utility, then attach the drive.

  • Charles Palenz Level 2 Level 2 (215 points)

    make sure the WD smartware software is not running, that is probably active by default.

  • djmikeweb Level 1 Level 1 (0 points)

    incase someone else stumbles across this post. Move the WD quick formatter icon to your desktop. Eject the drive but leave it plugged in and then open the WD quick formatter icon on your desktop. This is what worked for me.

  • Dynasty3000 Level 1 Level 1 (0 points)

    Worked for me. Thanks!