9 Replies Latest reply: Jul 31, 2012 1:59 AM by magic890
g_wolfman Level 4 Level 4 (1,120 points)

I've been encountering some weirdness over the past week or so...and I'd like to see if anyone else had experienced something similar (and maybe has a solution) or if this may be indicative of a bug of some sort.


First, the basics: MacBook Pro 6,2, i7 processor, 8GB RAM, OS X 10.7.1, Filevault2 enabled.


The problem - whenever I boot from a cold start (and occasionally on a restart, but not normally) the system will begin the boot process and then reboot partway through.  At every occurance, the boot messages (I boot in verbose mode) immediately before the reboot are the same and always related to the kext cahes, as in the following representative extract from the logs:

12-09-11 7:23:05.411 PM com.apple.kextcache: rebuilding /System/Library/Caches/com.apple.kext.caches/Startup/kernelcache

12-09-11 7:23:06.292 PM com.apple.kextcache: JMicronATA.kext does not declare a kernel dependency; using com.apple.kernel.6.0.

12-09-11 7:23:06.581 PM com.apple.kextcache: JMicronATA.kext does not declare a kernel dependency; using com.apple.kernel.6.0.

12-09-11 7:23:06.862 PM com.apple.kextcache: JMicronATA.kext does not declare a kernel dependency; using com.apple.kernel.6.0.

12-09-11 7:23:28.868 PM com.apple.kextcache: Created prelinked kernel //System/Library/Caches/com.apple.kext.caches/Startup/kernelcache.

12-09-11 7:23:28.910 PM com.apple.kextcache: /System/Library/Caches/com.apple.kext.caches/Startup/kernelcache out of date.

12-09-11 7:23:29.205 PM fseventsd: Logging disabled completely for device:1: /Volumes/Recovery HD

12-09-11 7:23:30.350 PM com.apple.kextcache: Successfully updated helper partition disk0s3.



After the reboot, everything proceeds normally and the boot process completes successfully.


I have rebuilt the entire OS from scratch and this still occurs.  I have also, in order to test alternative configurations, tried booting from a cloned backup.  The only difference between the cloned backup and the internal drive of the MBP is that the internal drive is encrypted with FileVault and the clone isn't.  The clone boots cleanly every time, from both a cold start and a restart.


In summary, the problem seems to be almost uniquely an issue when cold booting from an encrypted disk.  I'm at a loss to explain it.


So, has anyone else stumbled across this problem, or something similar?

  • bkmoore Level 1 Level 1 (0 points)

    I've been having the exact same problem with a 17" mid 2009 MacBook Pro, upgraded to 10.7.1 Lion. I first noticed it after upgrading to Parallels 7, but it may be unrelated.


    I get the following on cold start:


    Sep 13 08:57:25 Brians-MacBook-Pro com.apple.kextcache[193]: JMicronATA.kext does not declare a kernel dependency; using com.apple.kernel.6.0.

    Sep 13 08:57:37: --- last message repeated 1 time ---

    Sep 13 08:57:37 Brians-MacBook-Pro FDERecoveryAgent[335]: Waiting for CoreStorage encryption be activated, will try again in 40 seconds


    After which my system reboots normally. I don't know if the issue is related to Parallels 7, the JMicronATA.kext, or CoreStorage. Any expert advice would be appreciated.

  • g_wolfman Level 4 Level 4 (1,120 points)



    I also recently upgraded to Parallels 7.  However, I upgraded from the Parallels 7 Beta, where I had no issues, so I'm not inclined to think that Parallels is the problem (but I won't rule it out either).


    After some explorartion on the Console logs of the other computers in the house (an older MacBook Pro 4,1 and an iMac 10,1) it seems that my laptop is the only one affected.  And the only one running FileVault2 (and, unfortunately, the only one running Parallels which means I can't conclusively rule it out as the culprit...).  In all three cases, JMicronATA.kext is of the same version and has the same date stamp - which seems to rule out that particular kext as the problem.


    I'm wondering if the FileVault encryption is somehow interfering with the way IOKit builds the device tree at boot time...I'm fairly certain that JMicronATA.kext controls the IDE bus - which in my case means the DVD drive...unfortunately, I don't know enough about that part of the boot process to make anything more than uneducated guesses.  Which isn't really even good enough to file a bug report...

  • bkmoore Level 1 Level 1 (0 points)

    I first tried disabling FileVault on my MacBook, but that didn't solve the reboot during startup and my console still had the same boot warnings. Last night I did a reformat and clean install of Lion and reinstalled all my apps. Previously, my system had been an upgrade install from Snow Leopard and I hadn't done a clean install since purchasing this computer. After the reinstall, I left FileVault turned off. That seems to have fixed the issue for now, but I'll hold off on activating FileVault until I find more information.


    I have not seen this issue mentioned in the Parallels forums, so I don't think it's likely related to PD7.

  • Atlantis888 Level 1 Level 1 (25 points)

    I have the same problem on two machines (2010 iMac and 2011 11 inch MacBook Air) that are running 10.7.1 with filevault2 enabled.  The problem didn't start until I installed Parallels 7.  My other machines which are not running Parallels 7 are just fine with filevault2

  • g_wolfman Level 4 Level 4 (1,120 points)

    Well, that's interesting.  I knew that I couldn't conclusively dismiss Parallels as being part of the problem, but my instincts were in a totally different direction...thanks for providing another perspective and set of configurations.


    Of course, having some three-way interaction between the kextcache system, FileVault and Parallels is going to make nailing this down to a reproducable bug a bit of a pain...expecially since I'll have to back out to both Parallels 6 and 7Beta, in order to identify where exactly the bug was introduced...


    Oh well, it's not like I had anything else planned for Saturday.

  • Atlantis888 Level 1 Level 1 (25 points)

    Hi Everyone,


    Parallels just relased an update to Parallels 7.  I just applied it to my 11 inch MacBook Air which is using filevault2 and it solved the problem.  I will try it on my iMac and other machines once I get home but Parallels seems to be the root cause at this point.  My MacBook Air is booting and rebooting normally now.

  • Atlantis888 Level 1 Level 1 (25 points)

    Confirmed fixed on my iMac as well after applying the Parallels 7 update.

  • g_wolfman Level 4 Level 4 (1,120 points)



    And it's nice to know Parallels addressed the issue relatively quickly.

  • magic890 Level 1 Level 1 (0 points)



    I don't have Parallels installed now, but I've tried to install Parallels 6 and 7 a long time ago.

    After that I've uninstalled it with AppCleaner (an application that runs like an uninstaller and remove also the .plist files)


    Now, I've trouble with this bug.

    Do you know how to fix it or remove the bug?

    I don't want to reinstall or use Parallels anyway.


    Thank you.