Previous 1 2 Next 24 Replies Latest reply: Sep 15, 2011 2:41 AM by BDAqua
crampy Level 4 Level 4 (1,135 points)

Ahoy.

While trying to figure out why safari keeps quitting on me, I found an answer to someone else, who was told to go into logs and I was floowing along, but I guess they are ahead of tiger- anwyay I did find this, and wonder, can I do as it suggests somehow?

 

 

iPhoto: WARNING: The DiscRec SPI from the DiscRecording framework is deprecated in 10.3 and later.
iPhoto: WARNING: This app is contributing to an overall degradation of system performance and should
iPhoto: WARNING: be updated to use the DR API instead.
iPhoto: WARNING: The DiscRec SPI from the DiscRecording framework is deprecated in 10.3 and later.
iPhoto: WARNING: This app is contributing to an overall degradation of system performance and should
iPhoto: WARNING: be updated to use the DR API instead.
Fin

powerbook G4 17, Mac OS X (10.4.11), Airport Extreme base station.
  • Limnos Level 8 Level 8 (44,515 points)

    So which version of iPhoto do you have?  To me it seems like it is saying it is finding something that is old and not in use since OSX 10.3

  • crampy Level 4 Level 4 (1,135 points)

    opening up iPhoto to see.... iPhoto2.  My machine is 10.4.11 and safari is 4.1.3

    May I ask a Q unrelated? I lost the place I had been- someone said that fake flash can get into our computers- do you know how to determine if so?

    Thanks, either way...

  • Limnos Level 8 Level 8 (44,515 points)
    opening up iPhoto to see.... iPhoto2.

    Maybe that's the reason.  I'm not sure which version came with Tiger but I have iPhoto5 dated 2005 on mine.

     

    About the fake flash. Apparently it arose in August. Apple issued security updates, but they don't issue them for any but the last two operating system versions, and we're 4 behind so no update for us.  I can't seem to find any reference on the web about how this affects older Mac users.  One site (http://mac-security.blogspot.com/) says it affects the hosts file which we also have, so I guess it could affect us.  I just checked my hosts file and it is a simple 9-liner (6 of those are comment lines) so if it is going to introduce extra lines directing you to false sites then I'd expect more there.

     

    The thing to keep in mind is you really have to work to get a nasty on your Mac, even older ones.  The recent trojan pretends to be a Flash Player installer and you have to download it, open it, run the installer, probably enter your password etc.  I wouldn't get Flash Player from anywhere except the Adobe site, and don't bother now since they stopped updating it for Tiger.  Just avoid getting software from anywhere except legitimate sources.

     

    Surprisingly one regular source of security issues for Macs (http://www.securemac.com/) makes no mention of the fake player issue.

  • crampy Level 4 Level 4 (1,135 points)

    Hey. Thanks...

    Since you responded I have had some not fun moments...

    I had cleansed all flash stuff earlier- there were two in there- no idea which was which. The tv station site had want to update? and I did click that... I thought  it took me to adobe...

    Where is "host file" on the drive?

    Back to the adventure- everything works, but the verify disk....I get a very upsetting response- saying the Hard drive needs repair...

    But- In doing the flash away, I also dumped the microsoft garbage...No need for it? I emptied, and restarted and the permissions repair and verify works fine...just  verify disk gave me that grief.

    Safari was being seriously obnoxious. Between this computer being a lemon from day one and then the market crash- I have intensely lost money and time to this pile. Then the constant obsolescence is not worth it. GARBAGE.

    Thanks for your responding. Peace.

  • BDAqua Level 10 Level 10 (120,925 points)

    You should first uninstall any previous version of Flash Player, using the uninstaller from here (make sure you use the correct one!):

     

    http://kb2.adobe.com/cps/865/cpsid_86551.html#prob1=uninst,os=m10.6,

     

    Download this if you haven't...

     

    http://fpdownload.macromedia.com/get/flashplayer/installers/archive/fp10.1.102.6 4_and_9.0.289.0archive.zip

     

    Once downloaded if it doesn't unzip automatically the double click on that file.

     

    Look for the fp10.1.102.64_and_9.0.289.0archive folder, open it, look for the Flash Player 10.1.102.64 folder & open and look for 101r10264 folder & open it, double click on the flashplayer101r102_64_ubmac.dmg file, choose the Install Adobe Flash Player file to install... they don't make it easy!

     

    Or smaller here...

     

    http://dl.dropbox.com/u/450421/flashplayer10_1r82_76_ub_mac%20copy.dmg.zip

     

    Stand alone player...

     

    http://dl.dropbox.com/u/450421/LastFlashPPC.zip

  • Limnos Level 8 Level 8 (44,515 points)

    BDAqua saved me a lot of typing.   It wasn't clear, though, if you just needed to vent or if you're wanting to address these issues (which will involve a lot of typing).

     

    One of the main ones you need to do before you do any installing or installing of Flash Player is deal with the disk that won't verify.  Basically you're working with a computer that doesn't know where all its files are.  The computer uses a directory to keep tack of them and your directory needs repairing.  If you don't repair it then you'll just end up losing files, and getting more problems with running the computer.  It's a little bit like never changing the oil in the car, or dealing with an oil leak when it happens.

     

    First, if at all possible make a backup of the drive in its present configuration.  If something goes wrong during repair attempts and makes things worse you will have a backup.  You will have to decide how to work this in the light of any present backups you may have, for example, a backup that may be a few days out of date.  In that case you may want to keep that one and make a second backup of this as they are now, though I realize people often don't have a lot of empty drives sitting around.

     

    Boot from the System Installer disc that came with your computer or is the one for the version you currently have on there, select language if applicable, choose utilities, run Disk Utility and verify (and repair if necessary) the drive. You can verify a drive from DU on your main drive while booted but I have found this can result in incorrect reporting of errors. To repair your drive you have to run it from a drive other than the boot drive anyway.

     

    Next, boot from your drive in [Safe Mode|http://docs.info.apple.com/article.html?artnum=107393] and repair permissions.  You can repair permissions while booted from the installer disc but this uses the permissions configuration on the installer disc which may be out of date if you have run any updates on your computer.  Booting your computer to Safe Mode restricts the number of things running on your computer while permissions are being run and does a bit of spring cleaning at the same time.

     

    +Reading+

    [Resolve startup issues and perform disk maintenance with Disk Utility and fsck|http://docs.info.apple.com/article.html?artnum=106214]

     

    [Using Disk Utility in Mac OS X 10.4.3 or later|http://docs.info.apple.com/article.html?artnum=302672]

     

    [Disk Utility's Repair Disk Permissions 10.0-10.6|http://docs.info.apple.com/article.html?artnum=25751]

     

    "Try Disk Utility" (modified from [http://support.apple.com/kb/TS1417])

     

    1. Insert the Mac OS X Install disc that came with your computer (Edit: Do not use this disc if it is not the same general version as what you have currently on your computer, e.g. use a Tiger disc for a Tiger drive, not a Panther disc), then restart the computer while holding the C key.

    2. When your computer finishes starting up from the disc, choose Disk Utility from the Installer menu. (In Mac OS X 10.4 or later, you must select your language first.)

    Important: Do not click Continue in the first screen of the Installer. If you do, you must restart from the disc again to access Disk Utility.

    3. Click the First Aid tab.

    4. Click the disclosure triangle to the left of the hard drive icon to display the names of your hard disk volumes and partitions.

    5. Select your Mac OS X volume.

    6. Click Repair. Disk Utility checks and repairs the disk."

     

    Then boot in Safe Mode, (holding Shift key down at bootup; takes longer to boot this way so be patient), run Disk Utility in Applications>Utilities, then highlight your drive, click on Repair Permissions, reboot when it completes.

     

    [Mac OS X: Starting up in Safe Mode|http://docs.info.apple.com/article.html?artnum=107393]

     

    [What is Safe Boot, Safe Mode? (Mac OS X)|http://support.apple.com/kb/HT1564]

     

    [Safe Boot takes longer than normal startup|http://docs.info.apple.com/article.html?artnum=107394]

     

    [Mac OS X 10.4, 10.5- Computer shuts down during Safe Boot|http://support.apple.com/kb/TA24054]

     

    There's some things Disk Utility won't repair (more often thatn not). In that case you need to use a tool such as Diskwarrio (probably #1 but only does this one thing), or TechTool Pro, or...

  • crampy Level 4 Level 4 (1,135 points)

    G'day BDAqua- you have helped me in the past... Thanks...

    Yeah- I might have shot myself in the foot. The first bunch of warranty work I got they slapped a new hard drive in. After warranty ran out it was in fact, all that time (and money lost!) the logic board.

    They gave it back, after a half-price of the new unit repair job, with supposedly Tiger in it. Anyway- so last night, I uninstalled flash (I had two in there, as a tv station site said- old flash, want to install new? and I had, oh back in may or june). method: drag to trash everything a search of my drive identified as flash...

    I also decided as I was doing it, to dump the microsoft stuff that was in there...I have no use for try this, OK like it? 400 dolla prease! so to trash, and dump.

    It was in there that I made this thread....

     

    Then I found the bit with the very ending up with saying need to repair drive... repair permissions is fine... Then I had to go to bed...it was after 2 am my zone... OK so, below your response is from the fellow (or lady? Sorry, whichever) Limnos- which I read along with yours a while ago...

    So now here is an odd question- I was looking at the drive files, and I found an info folder for panther.

    IF THEY INSTALLED TIGER (giving me no disk, sorry just installed it they said) why is any mention of panther on here?  Apple- about this mac: 10.4.11  Anyway- the advice to repair from disk is easy if I was ripped off and not given tiger, and my original disk will work.. (O the irony) and if I am tiger'd, then i am out of luck about the repair.... I can get to a couple of sites- like here, my trading site and some news, as long as i do not click on the stories... then safari quits, and I must restart, quit, and start again to have it "work"

    ANy idea what would happen if I tried to repair from disk and it was tiger'd?

  • crampy Level 4 Level 4 (1,135 points)

    Good Morning or whatever it is when you read this, Limnos.

    Thanks so much for trying to help... I had to go to bed last night. It was a couple of hours after my usual lateness.... and the time mixed with my anger disappointment and frustration put me down hard.

    I read your response today,and looked around... I emptied all my desktop files and restarted.... and while looking through files I found I have a file regarding panter the intro book on drive... HUH? HAd they upgraded me, it should be Hello, here is TIGER...

    So- if they only put in safari in repair (see reply to BDAqua) then maybe I can use my original install disk?

    What a mess. I am still whomped from it all....

    Thanks for your attempts to help...

  • Limnos Level 8 Level 8 (44,515 points)

    Check your discs. Do they say 10.4 (Tiger) or 10.3 (Panther)?

     

    In a Finder window go to the Apple in the upper left corner of your computer, then About This Mac. What version does it say there?  It sounds like you have a mixed series of versions in terms of software which is one problem. However, you still need to repair your drive, but how you do it depends upon what versions are where. Do not use Panther disks to repair a Tiger drive.

     

    I say you need to repair your drive because that's #1 on your list.  If you have dry rot in your house foundations you don't think about painting the house first, or installing a new kitchen, or cleaning the windows. You do the foundation first or else you'll just have clean windows when the house falls down some day.  You could install new Flash, system, etc. and almost immediately have issues again (unless you erase your whole drive and all your files, 100%, which I take it you don't want to do).

     

    So, let us know what system you have on your computer and what disc (disc = optical, disk = hard drive) version you have.

     

    Limnos  = guy. BTW.

  • crampy Level 4 Level 4 (1,135 points)

    Hey Man. Thanks for patience with me...

    OK opening the apple and about this mac it says version 10.4.11

    When I open a finder window and type in search bar, "tiger" I find one picture, and 3 quicktime packages and :migration DVDCDSharingTiger.pkg....

    iPhoto 2 is what I have there...

    When I do the verify disk (sorely mis-spelled in my post to BDAqua, oops, fingers or keys not working right) i get some nasty red copy saying I need to repair drive... first repair...oh what is the word, volume maybe, then next line the drive.

    If it is a mixed bag install, then I can only say it is in keeping with ALL the service/product I have gotten.

    Not that that is a whole lot different than my entire life anyway- it seems more like a LAW of NATURE, like Gravity- that nothing is to go right for me... hahahaha dang.

    Part of me says, I should go through my bookmarks, convert the addresses to emails, save that to disk and just do a total new install with that, and be done with internet and all that... Two years of my life have gone to this machine, as a total waste. Yes it was fun to find olf friends from thirty and more years ago, but that is ALL I got (ok volcanocam, weather satellite pics too...seismographs...)

    Is there  a place to apprehend, or borrow, a tiger install disk?

  • Limnos Level 8 Level 8 (44,515 points)

    Okay. Situation summary. You have no installer discs of any kind, correct?  You do have Tiger installed on the computer now.  Maybe you didn't before you took it to this place. Maybe they just installed the system and didn't update all your software (like iPhoto).  Maybe it had Panther on it before, but now it's Tiger. It isn't unusual for me to read here of people getting newer systems installed by repair shops.  Oh, they won't give you the discs because they probably have one set for working on customer's machines and technically you should own a set of discs for whatever OS is on the computer, and if you had Panther and they put on Tiger then you're supposed to re-install Panther when you get home...fat chance.  They may not even have Panther discs in the shop anymore and had to put something on your computer.

     

    Still (just in case I haven't mentioned it yet), your #1 is to get that disk (meaning hard drive) repaired because that could well be the underlying source of all the woes you are having with this machine.  Since you do not have discs (meaning installer DVDs) it will be tricky.  Question: Do you have an empty external drive with a Firewire connection?  If yes, there's an easier way.  Otherwise you will need to print out the instructions in one of the links I provided earlier about how to repair your drive if you don't have installer discs.

     

    Oh, one small thing you can try if you are very lucky.  Try restarting the computer with the shift key held down until it tells you you are booting in Safe Mode. Then try verifying the drive (not permissions) with Disk Utility.  If you are lucky that might have repaired it while booting, or it may even have been that because the drive was being used before it thought it was seeeing an error that isn't there.  Safe Mode trims things down a lot and give the verification a quieter drive to analyze.

     

    On Tiger discs, no it isn't easy to get hold of. Apple only sells current OS version up front, and the previous one if you contact support. You could try calling customer suppoert (not sales because they will just try to sell you Lion and then try to sell you a new computer on which to run it 'cause yours won't), but I'm not optimistic. Oh, it'll still cost $129 or whatever.  Alternatively you can try e-bay, but be very very careful (ask us first) what you buy because many people sell discs that only work on their model computer (and are not intended to be sold alone) and about 75% of the "Tiger won't install" posts we see here are people who bought the wrong discs.

  • crampy Level 4 Level 4 (1,135 points)

    I bought this in october or november 2003... I have the panther install disk. Apple store did the reworking. Two drives during warranty (3 yr extended, pricey and got no help) after that finally they said well, yeah the logic board needs to go (I tried to say from hour three that the entire thing was a lemon but they are too busy to care about one lemon with a billion happy folks).

    Anyway- that bit in your last paragraph- I recall going through that in the early days- I may try that.

    I am thinking- wondering- whether I blew it by dumping the stupid pig microsoft stuff. I do not need it. I  will try it then report back.

  • crampy Level 4 Level 4 (1,135 points)

    WOW- you are a genius Limnos! I did the safe reboot- it took like five minutes holding down the shift key, and then as I was logged in I found trash had stuff in it- sometimes, when friends sent email with wmv i trashed, and next restart 'recovered files' would be in trash; those items... But these are4 exe things annex aux, annex db , file token.db qdfams.db

    and Local.fcache  systemfcache and user.fcache
    Did safe mode dump them? I see I must restart to get out of safe mode... I sure hope those things remain in trash....
    safe disk verify gave volume passed verification... YAY.
    So then a normal restart, stuff in trash still, and the verify again came out fine.
    PHEW!
    So then I guess I need to empty trash, yes?
    Now- how to say thanks with  cure posts to both you and BDAqua? I will now be able to go to where he said for the last usable flash.... Will that prevent page visits from making safari quit? And jam? No idea...
    But I will find out... How do we tell if the site saying adobe IS?
    And oh yeah- those weird files are still in trash- I should secure dump, yes? Lunch time late- back in an hour in case you are still around...
  • BDAqua Level 10 Level 10 (120,925 points)

    Do not use the Panther Disc to repair the Tiger Hard Drive, either Safe Boot like you did, or get Applejack...

     

    http://www.macupdate.com/info.php/id/15667/applejack

     

    After installing, reboot holding down CMD+s, (+s), then when the DOS like prompt shows, type in...

     

    applejack AUTO

     

    Then let it do all 6 of it's things.

     

    At least it'll eliminate some questions if it doesn't fix it.

     

    The 6 things it does are...

     

    Correct any Disk problems.

    Repair Permissions.

    Clear out Cache Files.

    Repair/check several plist files.

    Dump the VM files for a fresh start.

    Trash old Log files.

     

     

    See in each Browser which version of Flash it thinks it has...

     

    http://kb2.adobe.com/cps/155/tn_15507.html

     

    Then Test Adobe Shockwave & Flash Players...

     

    http://www.adobe.com/shockwave/welcome/

Previous 1 2 Next