Previous 1 2 Next 18 Replies Latest reply: Nov 20, 2011 8:54 AM by sshbeck
Bernhard Sperrfechter Level 1 Level 1 (45 points)

Since we upgraded to Lion we keep loosing wifi and Internet. Have to switch off the router. Then it works again for about a few minutes.

Please help!

 

Router is Linksys WRT54GS

Lion is: 10.7.1

 

Thanks in forward

 

Bernhard


MacBook Pro, Mac OS X (10.7.1)
  • DrVenture Level 2 Level 2 (180 points)

    When you say your wifi drops out, does your Wi-Fi icon (at the top right) go grey or does it stay black and you just cannot surf the internet?

     

    Also, are you running on the latest firmware for your Linksys router (or DDWRT if you went that way)?

     

    What channel is your Linksys set to use and what wireless security are you using?

     

    Can you do the following in a terminal and paste the output to this thread?

    sudo /System/Library/PrivateFrameworks/Apple80211.framework/Resources/airport -s

  • Bernhard Sperrfechter Level 1 Level 1 (45 points)

    icon stays black

    Linksys firmare 1.50.5

    Channel 11, Firewall on

     

    SSID BSSID             RSSI CHANNEL HT CC SECURITY (auth/unicast/group)

                      EasyBox-EB4F20 00:23:08:eb:4f:b0 -90  1,+1    Y  DE WPA(PSK/TKIP,AES/TKIP) WPA2(PSK/TKIP,AES/TKIP)

                             Sitecom 00:0c:f6:b3:fd:a8 -90  11,-1   Y  -- WPA(PSK/TKIP/TKIP)

             FRITZ!Box Fon WLAN 7240 00:24:fe:a6:7b:d4 -75  1,+1    Y  -- WPA(PSK/TKIP/TKIP) WPA2(PSK/AES/TKIP)

  • DrVenture Level 2 Level 2 (180 points)

    Ick. You have three neighbors using HT40 in 2.4GHz. Meaning they are taking up all available channels (two are taking up ch 1 + 6 and one is taking channels 11 + 6). But the good news is they are seen at fairly weak signal stregnths.

     

    I would definited stay on channel 11.

     

    Now if your WiFi icon is staying black, I am willing to be your wireless link is not dropping. Here is how you can prove it.

     

    Open two terminal windows (we will call them A and B).

     

    In termianl A you want to ping your Linksys router (it shows up as the default gateway on your Mac, usually 192.168.1.X). If you router's address is 192.168.1.1 the command would look like this:

    ping 192.168.1.1

     

    You should see ping replies coming back from your router.

     

    In terminal B, ping a dns name, like this:

    ping www.google.com

     

    again you should see replies coming back.

     

    Go ahead and use your Mac as usual with the two ping commands running. Once you get into trouble where you cannot browse, check mail, etc. go back and look at the two ping windows.

     

    If the ping in terminal A is still getting replies, but terminal B is not, then that means your wireless link is good to your Linksys router and the problem lies some where beyond your Linksys router and your internet modem (time to call your ISP).

     

    If the pings in terminal A and B are working, but apps like Safari, mail, etc are not work, then that sounds like a stack issue.

     

    If both pings are failing, then it might be a wireless link issue.

     

    Give that a try.

  • Bernhard Sperrfechter Level 1 Level 1 (45 points)

    both pings are failing!!

     

    Thanks.

    Bernhard

  • DrVenture Level 2 Level 2 (180 points)

    Ok, the next thing to look at is why the wireless link is dropping. Trying turning up airport logging:

     

    Open a terminal and do:

     

    sudo /System/Library/PrivateFrameworks/Apple80211.framework/Resources/airport debug +alluserland +alldriver +allvendor +LogFile

     

    Reboot your Mac.

     

    Once you Mac comes back up and you join the wireless network open a terminal and do:

     

    cd /System/Library/CoreServices

    open .

     

    This will open a finder window. Double click the Wi-Fi Diagnostics App. Let the app run for a bit, then take a screen shot of the app and post it here in the thread.

     

    Now go about your Internet business (browsing, mail etc). Once you run into trouble, do the following in terminal:

     

    cp /var/log/wifi.log ~/Desktop

     

    Then double click the wifi log on the Desktop and paste the log into this thread.

  • lupunus Level 3 Level 3 (995 points)

    Bernhard Sperrfechter wrote:

     

    Since we upgraded to Lion we keep loosing wifi and Internet. Have to switch off the router. Then it works again for about a few minutes.

    I had (like countless others) very similar problems with the wireless after upgrading to "better future related technic".

     

    Not with Lion, as I'm on 10.6.8, but that's not the point as it is presumably a "new capability's" and compatibility mode thing.

     

    The keywords are:

    WiFI signal stays, connection drop. Airport units like Airport Express vanish from the Airport Utility, Ping fails.

     

    This is merely caused by unwanted network traffic like "bad packets" and collisions and likely caused by multiband and 802.11g compatibility mode.

     

    Look at this article an check if something described in there match your situation.

    https://discussions.apple.com/message/16166320#16166320

     

    It's written about the Apple Airport Extreme, but will cover other Router's as well as the problems are related to the wireless at this.

     

    At very first, after a major upgrade like a new OS, you should first run a permission repair with the Disk Utility with wireless switched OFF.

     

     

     

    Lupunus

  • lupunus Level 3 Level 3 (995 points)

    The signal / noise ratio is horrible (-66) and the TX rate says: This is 802.11g wireless, where 54 MBit/s is the nominal speed (bandwidth).

    Three times the same SSID tell's that this a roaming configuration, whitch ich generally a good idea.

     

    Especially the signal / noise ratio indicates, that there are interferences in the 2.4GHz band, either from neighborhood networks, Bluetooth or the own network.

     

    Try to change channel. But remember to keep a 5 channel gap to the disturbing wireless, so channel 1 or 6 may be a choice if 11 have interferences.

     

    Another idea is, to change the old "g" router to a newer model.

     

     

    Cheers - Lupunus

     

    To improve

  • Batteman87 Level 1 Level 1 (0 points)

    I've had the exact same issue. Same router and everything. Worked like a charm with Snow Leapord but since the update it doesn't. I also noticed my iphone can tell when the router is "timed out" I guess you call it. It will detect that it's there but can't join it for whatever reason. I was looking to maybe get a new router, but don't unerstand why if it work fine before Lion. ??? You find anything out yet?

  • lupunus Level 3 Level 3 (995 points)

    Batteman87 wrote:

     

    I've had the exact same issue. Same router and everything. Worked like a charm with Snow Leapord but since the update it doesn't.

    Unfortunately the WRT54GS is from 2005 and there are not longer Firmware updates available for that model.

    http://homesupport.cisco.com/en-us/wireless/lbc/WRT54GS

     

    On Mac's there is problem with wireless access points using a 2.4GHz/5GHz mixed mode if both parts of the wireless network have the same name (SSID) but due to technical rules two different addresses (BSSID) for the different wireless modes.

    On that the Mac switches between the radio bands to provide allways "the best" connection.

    That causes disassociation from the wireless what shows you then the well known effects in your wireless.

    Also a band hopping "Guest Network" may disturb the connection if there is no dedicated name (SSID) is set for the Guest Network.

     

    On the WRT54GS

    Check that the "Guest Network" is disabled.

    Check that WPA2 Personal AES (not TKIP) is the security mode. See -> http://www6.nohold.net/Cisco2/ukp.aspx?pid=80&vw=1&articleid=22050

    Eventually change network mode from mixed (default) to "wireless-N Only" or "wireless-G Only" if the 2nd BSSID cause trouble with the Mac. -> http://www6.nohold.net/Cisco2/ukp.aspx?pid=80&vw=1&articleid=22555

     

    On the Mac

    Generally follow the instructions here -> http://www6.nohold.net/Cisco2/ukp.aspx?pid=80&vw=1&articleid=15805

    On System Setup - Airport (WiFi) main page uncheck (disable) "Ask to join new networks"

    Eventually set up a new location for your home network.

     

    Eventually delete all obsolete wireless networks from the "known networks" list including your WRT54GS

    Delete also the corresponding key's from Kechain Acceess

    Reboot the Mac

    Configure your home wireless on the Mac from scratch.

     

    Eventually try the Linksys Forum to find more information.

    http://homecommunity.cisco.com/t5/Wireless-Routers/bd-p/Wireless_Routers

     

    Regards - Lupunus

  • DrVenture Level 2 Level 2 (180 points)

    Lupunus...

     

    Please stop spreading misinformation.

     

    lupunus wrote:

     

    The signal / noise ratio is horrible (-66) and the TX rate says: This is 802.11g wireless, where 54 MBit/s is the nominal speed (bandwidth).

    Three times the same SSID tell's that this a roaming configuration, whitch ich generally a good idea.

     

    Especially the signal / noise ratio indicates, that there are interferences in the 2.4GHz band, either from neighborhood networks, Bluetooth or the own network.

     

    Try to change channel. But remember to keep a 5 channel gap to the disturbing wireless, so channel 1 or 6 may be a choice if 11 have interferences.

     

    Another idea is, to change the old "g" router to a newer model.

     

     

    Cheers - Lupunus

     

    To improve

     

    The S/R in the graphic is NOT -66. His graph is showing -66 dBm with a noise floor of around -92 dBm. His SNR is around 26 which is fine.

     

    54Mbits a second is NOT the nominal (minimal) speed for 802.11g. 54Mbits is the Maximum data rate for 802.11g.

     

    How are you concluding that he has a roaming configuration? I see a single BSSID with three measurements (taking over time listed). This has nothing to do with roaming per say.

     

    The graph above does not show he has an interferance issue at the time he took the measurement. What DOES show he has interference issues are the results of his airport -s output, which I already explained above.

  • DrVenture Level 2 Level 2 (180 points)

    lupunus wrote:

     

     

    On Mac's there is problem with wireless access points using a 2.4GHz/5GHz mixed mode if both parts of the wireless network have the same name (SSID) but due to technical rules two different addresses (BSSID) for the different wireless modes.

    On that the Mac switches between the radio bands to provide allways "the best" connection.

    That causes disassociation from the wireless what shows you then the well known effects in your wireless.

    Also a band hopping "Guest Network" may disturb the connection if there is no dedicated name (SSID) is set for the Guest Network.

     

    What?

     

    When you say mode, are you refering to Security Type? It is perfectly fine to have a dual band capable AP to use the same SSID for both radios. Each radio will have its own BSSID. When a a/b/g/n client scans, it will see two entires for the same SSID with different BSSIDs. This is fine.

     

    If you are refering to security, then it "could" cause an issue if a user sets up (like with a Linksys E4200) two different security types with the same SSID for both radios. For example:

     

    5GHz radio is set with SSID test and security WPA2/PSK

    2.4GHz radio is set with SSID test and security WPA/WPA2/PSK

     

    The problem with the above would be if a client messes up the multicast key from going to one BSSID to the other. Or if the client probes (or processes a beacon) where is expects AES in the RSN IE and it gets TKIP for the multicast key (or the other way around).

     

    In any case best practice is to use one security type for each SSID. If you are extending a network (DWDS or WDS) make sure your security types matches up on all APs.Meaning, don't have the AP creating the network doing WPA2/PSK and have the extenders doing WPA/WPA2/PSK.

     

    Lastly, if the Guest Network does not have an SSID set, then a client will not be able to join it....

  • wifiguru Level 2 Level 2 (235 points)

    lupunus,

    Please stop providing incorrect information. Your above replies are incorrect like Dr. Venture pointed out and you had posted other incorrect info. ( Mac's don't not support 802.1X etc.) on these forums. You are doing folks here a disservice by providing them incorrect information.

  • lupunus Level 3 Level 3 (995 points)

    DrVenture wrote:


    What?

     

    When you say mode, are you refering to Security Type?

    No. Radio mode.

     

    DrVenture wrote:

     

    It is perfectly fine to have a dual band capable AP to use the same SSID for both radios. Each radio will have its own BSSID. When a a/b/g/n client scans, it will see two entires for the same SSID with different BSSIDs. This is fine.

    Pretty fine, but unfortunately it seems that Lion have a problem with that.

     

    Lupunus

Previous 1 2 Next