Previous 1 2 3 Next 29 Replies Latest reply: Mar 22, 2014 6:27 AM by Andriset
aucharwood Level 1 (0 points)

For the bleeding edge amongst us: I'm trying to install windows8 preview on my MacBook air but it won't boot from the USB using the windows8 ISO.. any ideas?  I have no issues using the same USB drive to boot from with the Windows7 ISO contents on the USB, however I've had no luck with the Windows8 Dev preview ISO contents. 


And yes... it's not supported. I'm experimenting..... and am hoping some like-minded people know the clever details around what it takes for the boot process to work for Win7 & not Win8.



Chris Harwood

  • Ra'ad Level 1 (0 points)

    I'm on the same boat as you are. I've just downloaded the Windows 8 preview, and I will try to install it on my MBP from USB first thing in the morning. I'll tell you what happens as soon as I actually go through with it.


    Best Regards,
    Ra'ad Kawwa

  • aucharwood Level 1 (0 points)

    So after a few hours I've not had any more luck with booting from USB.  I thought I was onto something when an in-place upgrade from Win7 Enterprise x64 to Win8 Dev build x64 got as far as 90% before "an error has occurred" and the only option was 'cancel'. 

  • lapizzara2616 Level 1 (0 points)

    For future reference and for people who otherwise don't know this, the Win 8 preview is meant to be a clean install only, aka no in-place upgrades. Haven't had a chance to try it yet myself, but you might do that instead. I'm going to wipe my Bootcamp partition and start from scratch that way to see if I have any luck.




  • Daniel0524 Level 1 (5 points)

    First off:


    @lapizzara you're wrong. Both the x86 and x64 versions allow you to keep your profiles, files and settings without a clean install. However, if you install the x64 w/ developer tools, you have to do a clean install. See image I took from msft's website.





    As for my install, I was able to use the bootcamp tool with the x64 iso without a problem. However, the WindowsSupport driver bundles offered by apple can not be installed. On my 2011 MBA, Win8 automatically recognized my video card, my wireless card and audio. However, the trackpad only works as left click, and the keyboard hotkeys don't work. All in all, it's workable and a reasonable enough experience to try out windows 8.


    A side note, it doesn't matter if you upgrade a windows 7 bootcamp that does have the windows support drivers installed and working, because they will not work after the upgrade.


    Also some flash drives don't work so be sure to try a few if you're getting that cannot find boot disk error.

  • magellanx Level 1 (5 points)

    I got the preview without tools working through the boot camp assistant. I had to manually install the drivers in the windows support folder from Apple once in Windows 8. Not all of them worked, but the main ones seem to be working so far. Haven't go the trackpad multi gestures or the keyboard working with the brightness buttons and volume buttons, but so far those seem to be the only issues so far in my limited use.


    I would suggest using a bluetooth or usb mouse so you can have right click access.

  • dajmeister Level 1 (0 points)

    I have windows 8 installed on my early 2009 white macbook via bootcamp. I have tried both 32 and 64 bit versions and keep running into the same problem. I get it installed, and the trackpad works initially with the generic drivers. But then when I install the bootcamp drivers the trackpad stops working completeley.


    When going manually running the AppleTrackPadInstaller driver it reports successfully installing the apple trackpad enabler, but failing to install the apple trackpad.


    There isn't even a device under device manager that reports an error. (besides the isight, but that is less important)


    Anyone else run into a similar problem or have an idea for a solution?

  • dajmeister Level 1 (0 points)

    After some investigation It looks like the trackpad stops working after the AppleKeyboardDriver is installed.

  • NotreDewey Level 1 (0 points)

    I haven't been able to get bootcamp to recognize the disc in which I burned windows8 to.  Any suggestions?

  • freshlyputsir Level 1 (20 points)

    Hey there, first post here.


    Anyway, I was able to put Windows 8 on my 2011 MBP using bootcamp very easily.


    Burned the .iso to a disk using diskutility, and copied the windows support application files to a USB.


    After installing, I poped in my USB and tried to run the setup.exe, but was confronted with an error stating that that version of bootcamp needed to be installed on Windows 7, so I went into the folders that contained the drivers and individually ran each driver .exe. About 80% work, the others fail. Remember to go into the 64x folder if you downloaded the 64x windows 8.


    Two finger scrolling, and right-click were both not working. I fixed it by downloading the latest bootcamp software update for windows located here.


    I then downloaded winrar from, and extracted the .exe (a note, since you can't right click with the trackpad, I had to put in a usb mouse, and from there I right clicked the .exe itself and selected "extract to-"). From that I dragged an application file named something like, Bootcamp Software Utility to my desktop. Then I opened it, and there are some options there that allow you to turn on right click, two finger scroll, and two finger tap to right click.


    The only thing not working for me are the F-key functions. I tried toggling the F-key setting under that application, but it gave me an error when I hit apply. This also includes the eject key, not functional.


    Good luck to everyone else.

  • Ra'ad Level 1 (0 points)

    I already had windows 7 running using bootcamp on my mid-2010 MBP. I copied the .iso to the Bootcamp partition, ran windows 7, mounted the image to a virtual drive and performed a clean install of windows 8.


    No need for any USB or DVD if you already have windows 7 installed via bootcamp. As for windows support, I downloaded the latest bootcamp software and had the same error which states that it only installs in windows 7, so I ran it in compatibility mode (windows 7) of course. It installed nicely, but some features still dont work, which is to be expected.


    Good luck, and enjoy!

  • lazarevicdrago Level 1 (5 points)
  • pointvicente Level 1 (10 points)

    Yes I got Windows 8 working on a mac mini but not as stable as windows 7 because I think the devices plugged in such as the webcam.


    A couple hiccups were partition sizing, I had to cleanup enough space and basically choose a smaller partition size for the small mini hard drive (50GB).  Then I came up with the unexpected error message upon installation.  I reran the installation from the DVD and this time the screen went blank. I restarted and it looked like it was going to logon but then the screen went blank again.  I then took the DVI - to HDMI/apple mini cable off and replaced it with DVI - DVI / to apple mini connection.  Rebooted and wa la i was able to boot up properly.  It seemed stable at first but then on occasion it will freeze for no apparent reason.  Never once had this problem with windows 7.  I then tried to install the Logitech C310 webcam drivers manually because windows 8 didn't recognize the device.  A message came back that said this device is not supported on this operating system and would not allow me to proceed.


    Are there any generic webcam drivers that will allow this C310 webcam to operate in Windows 8 at this time?


    I haven't tried the webcam on the new PC (ASUS M5A88-V EVO) but I suspect I'll have the same problem.  Any help would be appreciated.


    Note: On a different note I sure wish the SuperDrive firmware 3.0 would fix the noise the drive makes upon waking up from sleep.  It looks like Apple may have offered to replace it a while ago. 


    SYSTEM: Early Mac Mini 2009

  • pointvicente Level 1 (10 points)

    I unplugged and plugged the USB cable back in rebooted and its working like a charm.  However, Windows 8 on the mac mini is not stable it freezes either 10 minutes after rebooting or 50 minutes later.    Apparently its telling me that the 2nd core drivers are not installed.  I'm still investigating

Previous 1 2 3 Next