11 Replies Latest reply: Dec 14, 2012 3:13 AM by kikuyama
Darren Pullman Level 1 (5 points)

I've updated three Mac Pros via software update today and I keep getting, "The application FMRenderer quit unexpectedly" I'm running Leopard. This hasn't affected G5 PowerMacs running Leopard or MacPros running Snow Leopard. Any ideas?


Mac Pro, Mac OS X (10.5.8)
  • Darren Pullman Level 1 (5 points)

    I've investigated this further and it seems to be connected with Suitcase Fusion 3.

  • Steve Schiffman Level 1 (20 points)

    Have you found an answer? It keeps popping up over and over for me. I see that FMRenderer is in the Suitcase Fusion 3 package.

  • Darren Pullman Level 1 (5 points)

    It was clear that there was a problem with Suitcase Fusion 3 and Intel Macs running 10.5.8.

     

    The solution I applied this afternoon was to upgrade the Macs to Snow Leopard. Now all is well.

  • YSR50 Level 1 (65 points)

    Hmm, wonder what the solution is if updating to SL isn't an option. 

  • Steve Schiffman Level 1 (20 points)

    I downgraded to 14.0.4 ( I still have the original installer). In Suitcase 14.1 I deactivated the FMCore in the application preferences and quit the application. Then I used Time Machine to revert back to the previous Font Vault and preference files. Finally, I reinstalled Suitcase 14.0.4. There were no problems installing it over the new version. Then I did the upgrade to 14.0.6. I don't have any need for the newer version since I'm still at OS X 10.5.8.

  • YSR50 Level 1 (65 points)

    Looks like maybe it's a permissions issue. Admin account didn't have any problems, just managed accounts so I changed permissions on Suitcase Fusion 3, Contents, Resources and FMRenderer to Read & Write for everyone. Looks like that may have fixed it.

  • Steve Schiffman Level 1 (20 points)

    Yes, I was having trouble with a managed account. I had checked the admin account and it had the same problem. I had done the update in the managed account so maybe that's where the trouble came from. Perhaps you need to run the update in the admin account to avoid the problem. Thanks for the solution.

  • YSR50 Level 1 (65 points)

    14.1.1 is out today. Not sure if this issue has been address though

     

    *edit* nope, doesn't fix things

  • YSR50 Level 1 (65 points)

    I have a question for those of you that had this problem. Did any of you have Helvetica and/or Helvetica Neue active on your machines when you were getting this error? Updating the OS would load these fonts. I just had one of our operators activate both fornts and the error has not come back.

     

    We are a printing company and need to use different Helveticas throughout the day so we removed them using Extensis' Best Practices for Managing Fonts in Mac OS X.

  • kikuyama Level 1 (0 points)

    Wow! thanks, Your solution is convenient for me. In fact, I was afflicted by the trouble it becomes no response when I tried to register two or more fonts into Font Library of Suitcase Fusion3. I also changed app and all Permissions of Contents in Package to 777.  777 is a lucky number after all.

     

    MacPro 10.5.8

    Suitcase Fusion3 14.2.1

     

    from Japan

  • kikuyama Level 1 (0 points)

    *correct

     

    It's feeling better before situation but I still have some problems.

     

     

    /I tried to register some font to Suitcase font library, it will be no response still now even if I set app's permission to 777.

     

     

    /If app becomes to no response, some registered fonts was broken on next app's boot time.

     

     

    In conclusion, I also recommend to update OSX ver or install Suitcase Fusion newer ver If you are in trouble with using 10.5.8(Intel Mac) and Suitcase Fusion 3.