12 Replies Latest reply: Jul 4, 2012 4:25 AM by TomaCabron
woollymammoth Level 1 Level 1 (0 points)

I can't copy mp3 files from my computer to the Itunes library. I have tried File>Add file to library, then selected the files in My Music, but nothing happens. I have tried having Itunes search for music in the "Home" folder, but all it finds are some old ringtones buried in the Downloads folder. I am running Itunes 10.4.1.10 on Windows 7. What's up?

  • ed2345 Level 7 Level 7 (20,955 points)

    Use Windows to find one of the files.  Right-click the file and choose Open With > iTunes.

     

    If the file is compatible, it will start playing and will be added to your iTunes library.

     

    If the file is not compatible with iTunes, nothing will happen.

  • woollymammoth Level 1 Level 1 (0 points)

    I tried this. The files apparently are not compatible with Itunes. But they are mp3 files, they play on Windows Media Player, and Itunes does handle other mp3 files.  How can one mp3 file be compatible and another not be? Is there a way to make the files compatible?

  • ed2345 Level 7 Level 7 (20,955 points)

    How can one mp3 file be compatible and another not be? Is there a way to make the files compatible?

     

    It is common, since iTunes is very picky about even slight corruption in MP3 headers that does not bother other players.

     

    Simply treat the files with a 3rd party tag cleanup program such as MP3 Validator, and then iTunes will be happy.

  • woollymammoth Level 1 Level 1 (0 points)

    I tried Mp3 Validator, MusicBrainz and Media Monkey to fix the tags. None of them worked. Itunes still does not like my files. Sigh. So much for putting the music onto my Ipad.

  • ed2345 Level 7 Level 7 (20,955 points)

    Wooly,  Before you give up, try one more thing. Use a 3rd party conversion program such as Switch to convert them to WAV, and add the WAV files to iTunes.

     

    If iTunes accepts them, you can then convert them to MP3 within iTunes.

  • woollymammoth Level 1 Level 1 (0 points)

    Hmmm, that was interesting. Switch is converting most of the mp3s to wav files that are a grand 46 bytes. I give up!

  • ed2345 Level 7 Level 7 (20,955 points)

    Sounds like there is a problem with the files themselves. 

     

    One last question:  are you sure they are MP3s?  Since nothing seems to handle them except Windows Media Player, I am wondering if they might be protected WMA files?

  • woollymammoth Level 1 Level 1 (0 points)

    The file extensions are all mp3. Most of them are music I rescued from dying cassette tapes many years ago. I know they are in mp3 format since that is the format I used when copying them from tape. It's unfortunate as these are beloved music, but I don't remember the artists names and have not been able to locate the music anywhere. Bing and Google don't turn up anything, stores search their catalogs and can't find them. So they live on only on my laptop. The only alternative I have found is to use Dropbox to transfer them to the Ipad, then play them through Dropbox. But there is no way to organize playlists. Looks like that will have to do.

     

    Ed, thanks so much for your help.

  • ed2345 Level 7 Level 7 (20,955 points)

    Believe me, I know the "beloved song that can't be found anywhere else" phenomenon.

     

    As long as you have other ways to play them (WMP and Dropbox) all is not lost.  Even though they defied Switch and MP3 Validator, there is probably another way to clean them up.  A project for another day.

  • hypa3000 Level 1 Level 1 (0 points)

    not sure if this has been mentioned before

    i was pulling my hair out trying lots of different things as I couldn't add tunes to itunes playlists with latest itunes 10.5.3.3. installed on Win 7 64bit OS

     

    but in the end solution which worked for me was very simples

     

    Not sure which of these two did it  as I unchecked both of the following:

     

    1)

    right click the iTunes shortcut on the desktop

     

    Properties > Compatibility > UNchecked 'run this program as an administrator'

     

    (I had checked this above when trying out things in the past).

     

    2)

    I also did this

     

    Again right click the iTunes shortcut on the desktop

     

    Properties > General > Advanced > unchecked 'File is ready for archiving'

     

    hope this helps

     

     

  • lolane09 Level 1 Level 1 (0 points)

    Thank you very much!

  • TomaCabron Level 1 Level 1 (0 points)

    Guys i hope you haven't deleted your songs. I too went through this **** and nothing mentioned here helped. What i figured out was that these converting programs are crap and you need a specific program to convert mp3 to wav. Use SUPER.... You can thank me later. I was getting wav files that were 0KBs and now with super they are 20MB. Ah sweeet victory!