11 Replies Latest reply: Apr 14, 2013 1:16 PM by SwankPeRFection
samyuwel Level 1 Level 1 (0 points)

my macbook pro cannot connect to the internet via Wi-Fi. It always say "Wi-Fi has self-assigned IP address 169.xxx.xxx.xxx and not be able to connect to Internet." or sometimes "Wi-Fi has no IP address". What can I do?


MacBook Pro, Mac OS X (10.7.1)
  • 1. Re: Wi-Fi has Self-Assigned IP Address
    OffSunset Level 1 Level 1 (0 points)

    I had the same problem IT told me to switch my wifi incryption from WEP to WPA. Called my internet provider and had them switch it, in two seconds. Now my MBP connects just fine.

  • 2. Re: Wi-Fi has Self-Assigned IP Address
    artandsoul Level 1 Level 1 (0 points)

    I have the same problem. Why can my macbook and ipod get on the same network using WEP?

  • 3. Re: Wi-Fi has Self-Assigned IP Address
    artandsoul Level 1 Level 1 (0 points)

    Well found the answer. Under network settings in System Pref., click the "assist me" button on the bottom of the screen. It takes you through similar steps as in "Netowrk diagnostics" but this actually WORKS! I can only assume it configures it to WPA instead of WEP.

  • 4. Re: Wi-Fi has Self-Assigned IP Address
    Rematore Level 1 Level 1 (0 points)

    I have the same issue.  it is not the fact that you use WEP or whatever.  it is something with the computer or OS.  this happens to me almost everyplace i go: home, work, airport, starbucks.  It always says no IP address or that i self assigned it and it can't connect.

     

    The only fix i've found is to restart the computer.  sometimes this works, sometimes it doesn't.

     

    If you ask the question on these boards people will tell you over and over to check your router or password or change to WEP.  None of those are the issue.

  • 5. Re: Wi-Fi has Self-Assigned IP Address
    Scott Lahteine Level 1 Level 1 (5 points)

    I've had this issue more often lately too, maybe only on WEP, which is what most locations use. My pet solution has been to create a new Network Location, then guess the wifi network range and configure everything Manually under the Advanced options of Network Preferences. Usually the network router is at 192.168.1.1, so I set my MacBook's IP Address to something high like 192.168.1.222. Occasionally this still doesn't work because no DNS can be found. Adding a DNS entry with 192.168.1.1 (same address as the wifi router) has done the trick in most cases. If the router won't do DNS by itself, there's always Open DNS, whose IP Addresses are 208.67.222.222 and 208.67.220.220.

     

    The most common addresses for wifi routers are 192.168.1.1, 192.168.2.1, 10.0.1.1, and 10.0.2.1.

  • 6. Re: Wi-Fi has Self-Assigned IP Address
    BigPhil71 Level 1 Level 1 (0 points)

    None of the options above have enabled my MBP to connect to the internet.

     

    Anyone with additional ideas to try?

     

    Apple support have been completely silent on the matter.

  • 7. Re: Wi-Fi has Self-Assigned IP Address
    clintonfrombirmingham Level 7 Level 7 (28,675 points)

    BigPhil,

     

    You need to start a new thread of your own and let us know exactly what you have tried.

     

    Clinton

  • 8. Re: Wi-Fi has Self-Assigned IP Address
    henry95 Level 1 Level 1 (0 points)

    I've been told that when the "self-assigned IP address" message is presented, the 169. at the beginning is an indication of the problem, thought I would throw that in there incase someone could elaborate or discredit this theory...

  • 9. Re: Wi-Fi has Self-Assigned IP Address
    SwankPeRFection Level 4 Level 4 (1,435 points)

    169.x.x.x address is a self-issued address by the TCP/IP stack on a client when it cannot contact a DHCP server to get one.  Generally, it was designed this way so that it would help facilitate easier networking for people who don't know how to properly set up an IP network.  Technicallly speaking, you could connect two Macs together with a crossover ethernet cable and wait until they both finally self-assign themselves 169.x.x.x addresses.  Once this happens, IP network connectivity will allow for both Macs to talk to each other accross that single ethernet link.

     

    When dealing with a WIFI network, an address of 169.x.x.x usually indicates one of a few things.

     

    1) You somehow manually misconfigured the security type and password for the WIFI network you're tying to connect to.

    2) The WIFI network you're on does not have a DHCP server to issue an address.

    3) The WIFI network you're on has MAC (no, not the computer Mac, lol) address blocking turned on and doesn't recognize your network card's MAC as a valid client to allow connections.

     

    The gotcha here is that 1 and 3 usually only happens on systems that aren't smart enough check and see if the WIFI connection has accepted the password and OK'd it.  On some systems and with some older encryption like WEP, as long as the passcode matched the length of the password required, it would let you connect (or rather it would show you connected but with limited connectivity).  This is the state that tends to trick people into thinking they have a good WIFI connection to the network, but something else is wrong, when in fact, they DO NOT have a working connection to the network even at the base security layer (before the TCP stack even begins binding).  In situations like this, you must delete the WIFI network and (on a Mac), also clear out the Keychain entries for that WIFI network because that's where the security key is stored.  Once this is done, you reconnect to the network and make sure that you're tying in the (usually case sensitive) password as it's given to you.  If that still doesn't work, then test with another device.  If that device works, then you're still making a clarical mistake on the password on your previous device or that device has other network issues.  If the second device doesn't work either, then you've either been given incorrect info for the WIFI network, the WIFI network is misconfigured to not give out DHCP IPs, the WIFI network is doing MAC blocking, the WIFI network router is locked up and not allowing new client connections (power cycle it to fix this), or you're still somehow making a clarical mistake inputting the info for it.  Pretty much all these will require you to probably talk to whomever manages that WIFI network if you still want to connect to it.

  • 10. Re: Wi-Fi has Self-Assigned IP Address
    galaxyglue Level 1 Level 1 (0 points)

    This worked for me, similar problem. It's most helpful to know that the "self-assigned IP" error is misleading.

     

    Key piece of info here was suggesting a clerical mistake in entering the password. I didn't type it in, but copied and pasted - that was the cause of my problem. Typing it in carefully solved everything. Thanks!

  • 11. Re: Wi-Fi has Self-Assigned IP Address
    SwankPeRFection Level 4 Level 4 (1,435 points)

    You're welcome.  You'd be surprised how many times people have asked me to fix their issue with not being able to connect to a WIFI network in the office or somewhere else and 99.99% of the time it's a clerical mistake when they typed their password in.  People always deny that until I type it in from their info they provide and it works fine.  They go "What did you do?"  Nothing, I typed it in correctly... you weren't. :rolleyes: