Previous 1 2 Next 22 Replies Latest reply: Oct 30, 2012 6:13 AM by JeffDeM
jonescreative Level 1 Level 1 (0 points)

When I first installed Lion my magic mouse worked just fine. During the first few weeks the mouse was switched back and forth between the magic mouse and mighty mouse and now when trying to use the Magic Mouse, I can't scroll up, down, horizontally or use any of the gestures. I've checked preferences and reset the SMC as well as the PRAM. I've restarted in Safe Mode and still does not work. One thing I have noticed is now when going to the Mouse preferences, I don't see the gestures example showing the different ways to use the magic mouse. It show's the mighty mouse settings, but when I disconnect the mighty mouse from the keyboard and use the magic mouse, I can move the mouse around, click on things but just can't scroll at all.

 

Please if anyone has any suggestions, I would greatly appreciate it. It's very frustrating not being able to utilize the mouse and gestures.

 

Thanks,

Darren


Mac Pro, Mac OS X (10.7.1)
  • captfred Level 7 Level 7 (26,265 points)

    Check the settings in System Preferences > Universal Access > Mouse & Trackpad > Mouse Options button > check Scrolling.  If already checked, uncheck and recheck.

     

    Regards,

    Captfred

  • jonescreative Level 1 Level 1 (0 points)

    Thanks Captfred but unfortunately that didn't help either. I have tried everything and it's coming down to either reinstall Snow Leopard then reinstall Lion again. But if this is a known issue or bugs within the OS then I might not reinstall Lion. There are some nice things about Lion I like, but there are things that I can do without.

     

    Thanks though for offering your suggestion.

     

    Best,

    Jonescreative

  • Takiar Level 1 Level 1 (0 points)

    My Magic Mouse worked fine when I got my MacBook Air i7 with OS Lion.

     

    But since the Lion update a couple days ago, no more scrolling, and the cursor jumps everytime I lift the mouse.

     

    Preferences are checked as they should be, already.

  • artistrik Level 1 Level 1 (0 points)

    have you check its battery .. I have the same problem .. the battery is 20%, cant scroll... after replacing the battery, the problem of missing

  • TimothyJay2004 Level 1 Level 1 (0 points)

    I'm having the exact same issue. This is really annoying. It worked fine when I first did the 10.7.2 update, then a few days later, just stopped working. I can only point and click ... no scrolling in any direction. I have to use the up/down/left/right keys from my keyboard to navigate the web. This is seriously rediculous, expecially with how much you pay for the mouse!

  • jonescreative Level 1 Level 1 (0 points)

    I would agree with you. You pay for a wireless mouse and now you can't use it properly. The interesting thing is, I did a complete reinstall going back to Snow Leopard, worked just fine. Did the updates, then reinstalled Lion, worked just fine, did the latest Lion update then migrated my users once I did that, the mouse stopped scrolling. The one thing I haven't done is to create a brand new user and work with that user for a few days to see if it stops working.

     

    I'm running out of ideas but hopefully there will be another update that might take care of the problem.

  • mac16 Level 1 Level 1 (0 points)

    Overall, seems scrolling via mouse is likely a bug with Lion at this time -- I have a similar but slightly different problem.  My mighty mouse will only scroll down and left and right. It will not scroll up.  If I check "move content in the direction of finger movement" in mouse preferences, it scrolls down normally but not up. If I uncheck it, it scrolls down in reverse but not up.  Another poster alluded to a checkbox in Universal Access > Mouse and Trackpad > Mouse Options.  No such checkbox exists for me in Lion 10.7.2.  I am on a MacBook Pro and I can scroll normally with the track pad.

  • JeffDeM Level 1 Level 1 (5 points)

    Same thing for me.  I have Magic Trackpad and Magic Mouse, neither scrolls.  I've checked the batteries, I've deleted their respective preferences, I've tried to uncheckand and check scrolling, nothing is working.  My preference pane for each item doesn't show the images or video either.

     

    This is getting frustrating because I need scrolling, it's a major feature of both input devices, and neither work.

     

    I've alsoinstalled and uninstalled third party preference pane software, they don't do anything for me.  USB Overdrive, SteerMouse and MagicPrefs.  It wasn't scrolling without these items, and it didn't scroll with them either.

     

    I unpaired & deleted the devices, then re-paired them.

  • jonescreative Level 1 Level 1 (0 points)

    JeffDem,

     

    The only way that I solved this problem was to completely reformat the computer and re-install the OS. Once I did that I haven't had the issue come up at all. It's possible that some of the updates may have taken care of this problem but I completely understand your frustration. I hope that you find a solution and hopefully if you go to this extreme it might take care of the issue. Good luck.

  • JeffDeM Level 1 Level 1 (5 points)

    OK, thanks.  Do you use any non-Apple mice on your iMac?  I'm not sure, but it seems like the problems cropped up after I connected a USB mouse.

     

    I also run Parallels, is there any known connection there?

     

    These may be long shots, but I'm trying to avoid a repeat of this little fiasco.

  • esrasaginc Level 1 Level 1 (0 points)

    I have the exact same problem. System prefs shows preferences for the mighty mouse, so I can't make use of gestures, or scroll. I'm having to use the USB mighty mouse which is annoying as I have paid for a wireless which I cannot use. It's also worth noting that I bought the magic mouse when it first came out, it did not come packaged with my iMac.

     

    I also use parallels.... were you able to find a solution?

     

    Ta.

  • jonescreative Level 1 Level 1 (0 points)

    Sorry for the delayed response JeffDeM, but to answer your question I don't use non-Apple mice. However I did swtich from using the wireless to a USB and I believe that's where the problem occured. Ever since I did the reformat and reinstall the OS the problem went away. I currently still switch between the Magic Mouse to the Mighty Mouse and the problem has not come back. I'm also now using Moutain Lion so maybe in one of the updates it took care of the glitch. As far as running Parallels, I don't know if there is a connection there, I don't use that so I can't say if that's the culprit.

     

    Are you still having the problem? Did you reformat and reinstall the OS?

  • jonescreative Level 1 Level 1 (0 points)

    What OS are you running esrasaginc? Have you tried reinstalling the OS and see if the preferences are set for the Magic Mouse? If you haven't reinstalled the OS, make sure you don't have the USB mouse plugged, see if it picks up the wireless mouse and then check the preferences.

     

    I know it's frustrating especially when you pay for the wireless mouse but can't use the gestures. I like the Magic Mouse for some things but I don't. The sensitivity when you accidentally brush your fingers on the top makes the page scroll I wish there was a setting for that sensitivity.

     

    Good luck.

  • JeffDeM Level 1 Level 1 (5 points)

    Thank you for answering.

     

    I still have the problem. I did not reformat and reinstall the OS. It seems like an extreme measure to get a mouse and Magic Trackpad work, so I just removed the batteries and placed them in a drawer. I like to think I have more preferable ways to spend an evening. I am using a Wacom tablet and a Logitech mouse instead.

     

    There is a new update that came down yesterday, so I'll run that and see if it does anything.

Previous 1 2 Next