Previous 1 2 3 4 Next 84 Replies Latest reply: Oct 31, 2014 10:03 AM by carolynfromgvegas Go to original post
  • Coolangatta Gold Level 1 Level 1 (0 points)

    What did you figure out?

     

    I cannot get Home Sharing to work at all. Despite having tried all the solutions discussed on this forum and the help, all devices are authorised and home sharing is swithched on, but sharing does not show up in the iTunes menu or on the iPhone.

  • rmrtcy Level 1 Level 1 (0 points)

    What I found out for me to make it work was after I made sure that all devices were turned on to home sharing the main computer that is originally signed up to I Tunes has to be on (on at all times to watch a movie or TV show) and have I Tunes opened for me to stream my movies or TV shows from my I tunes library.

  • Coolangatta Gold Level 1 Level 1 (0 points)

    Thanks, still does not work for me.

  • digigrapher Level 1 Level 1 (0 points)

    Thanks for the clarification.  The problem is back again!!!

     

    1. AppleTV does not see my computer in the Home Sharing.
    2. iMac does not recognize my printer.  Friday morning I could not print the boarding passes for my family.  I was able to print this morning, and now again cannot print.
    3. The iPADs and iPODs are with my family so don't know about them.

     

    All my devices are connected by WiFI to my ISP's wireless router.

  • anas.k Level 1 Level 1 (0 points)

    I am also having the same problem - After authorizing and turning on home share, the Sharing tab appears on the left pane but as soon as i hit "Done", the tab disappears.

     

    I am wondering if this has to do with firewall settings on my laptop - i can not seem to figure this out

  • digigrapher Level 1 Level 1 (0 points)

    Keeping my fingers crossed...  But I think I have fixed the problem.

     

    I configured my router to issue static IP addresses to my printer, AppleTV, and it has been working for the past 8 days.

     

    What I found was that with Dynamic IP addresses, each time we power off and power on my router/computer/printer the router showed different device names.  I don't know who the culprit is here. I was thinking the computer was trying to resolve with the old name, but then even when I manually added the printer with the IP address it had failed to detect it.

     

    The firewall had nothing to do the problem.  I turned off and still had problem.

  • blametheadmin Level 1 Level 1 (5 points)

    Apples solution to the Home Sharing debacle is iTunes Match.

  • Wooroonden Level 1 Level 1 (0 points)

    I am having the problem that you described here earlier:

    it could not see my Computer in the "Computer" menu.  It had a message to Turn on home sharing on my computer which is already turned on!!

    only since the Mountain Lion upgrade in my case, and would like to try your fix, BUT I cannot see my computer as you describe:

    I went back to this account page and removed my computer

    I can only see my iPhone and iPad. Can you see your computer because you have more than one?

  • Wooroonden Level 1 Level 1 (0 points)

    After working through several procedures with Apple Support on the phone, we established that Home Sharing is also not working with the iPad3, not just ATV2. We tried rebooting everything and even setting up a new user account on the computer. Nothing worked.

     

    I also noticed that when Home Sharing is turned off in iTunes, 'SHARED Home Sharing' does not appear in the left hand menu. Going to Advanced > Turn On Home Sharing makes it appear there BUT as soon as I enter my username, password and click on Done after it appears, the 'SHARED Home Sharing' section disappears again, although Home Sharing is now On in the Advanced menu.

     

    Definitely a problem with iTunes and/or Mountain Lion as I didn't have any problems before now. I am hoping that Apple Support can get back to me with a solution.

  • anas.k Level 1 Level 1 (0 points)

    I had all the above symptoms yet I seem to have figured part of the problem - as soon as i disabled my norton network protection, i was able to view my itunes data on Apple TV. However, on the desktop i was not able to view the "Sharing" icon on the left pane.

     

    Bummer yet partially working...

  • Wooroonden Level 1 Level 1 (0 points)

    After following advice from Apple Support, my problem has been resolved by buying a router.

     

    To function correctly, the home sharing feature requires that both the home sharing computer and the ATV be connected to the same network. If the iMac is acting as a router (as mine was), it isn't actually on the network but is the one supplying the network. That did work in Lion but apparently not in ML.

     

    I am using a wireless internet USB dongle, so I bought a 3rd party wireless router that was compatible with it. That way the Mac and the Apple TV are connected to the same network, therefore fulfilling the system requirements as described in the article below:

     

    http://support.apple.com/kb/TS2972

     

    This has worked for me, including when the computer is asleep. The bonus is that AirPlay also now works for me.

     

    SHARING still disappears from the iTunes sidebar once Done is clicked on after turning on Home Sharing, but that doesn't seem to be a problem.

  • Wooroonden Level 1 Level 1 (0 points)

    I take back the bit about it working when the computer is asleep... it works with display sleep only.

  • mr perry smith Level 1 Level 1 (0 points)

    In regards to Planetxan's last paragraph, I am having the same issue.

     

    In the videos app on my iPad, when I click on the shared library tile under the 'Shared' button, the library loads until the indicator gets halfway, and then it just stops. However, in my iPhone (4, iOS 6), the library loads almost immediately.

     

    What's the deal?

  • destne Level 1 Level 1 (0 points)

    I am completely new to Apple with my new iPhone with IOS 6 but been working PC's last 20 years so used to "self support" I had the problem of Home sharing not showing up in Libraries.  Lots of people having this problem it seems.

    ..

     

    I solved it, hope it helps for you. I have static IP's between 2 windows 7 PC's..In iTunes I turned off home sharing from File/Home Sharing on both PC's. Turned off firewall both PC's. Enabled multicast on Router. Use "Run as administrator" to start Itunes on both PC's. In iTunes go to File/home sharing to re-enable - as you enter Apple ID and password, Home sharing pops up in your library. Carry on and click Done. I then had to close and re-start ituned on 1 PC, the other worked fine.With both now connected, re-enabled firewall.

     

    The only other step I tried was deleting AppData\Roaming\Apple Computer\iTunes\iTunesPrefs.xml but I don't think that is part of the solution.

     

    Respect to the various other writers who pointed out bits of the steps, thanks.Note to Apple: you don't have to - you probably can't - solve everything out of the box but giving some "open advice" on things to try will protect your rep a whole pile better than denial - Ms learnt this 10 years ago

     

    Good luck to all,

    P

  • blametheadmin Level 1 Level 1 (5 points)

    @destne, I will certainly give this a try. However, there's always the possibility that it will work for a while but then will stop. For how long has this worked for you? Have you turned off your PCs? Have you closed the Music app in your iOS and then restart it? 

Previous 1 2 3 4 Next