1 Reply Latest reply: Sep 19, 2011 4:21 PM by lllaass
Fallende Level 1 Level 1 (0 points)

I have an ipod touch, and whenever I try to open an app I've downloaded that's not preloaded into the ipod, it'll open up for about a second and then instantaneously flash back to the home screen. At first is was one app, then it was several, and then it becomes all of them. Sometimes they lose their picture too.

It's set to the newest version, there are no updates. I've checked. I've also checked if any of the apps require a new update or a newer generation ipod. Since I have the newest version and itunes won't install an app that requires a newer generation ipod, this can't be the problem. There are no problems with the battery.

I've tried reseting the ipod, no luck. I've tried restoring the ipod and putting everything back on (several times through a previously made backup, once from scratch): both of these work for about 2 days and then I have the same problem all over again. I refuse to restore and back up my ipod every few days.

(If this info helps you any, every time I plug it into the computer it doesn't recognize it as an existing ipod, it asks me to set it up as a new ipod and tries to sync it all over again. Even if I had not restored the ipod since last I plugged it in.)

I read through several forums on this and read the official troubleshoot on how to fix the problem, but none of the suggestions seem to work.

Does anyone know of anything else I should try, or do you think I should send it in and get it looked at?


Windows 7