10 Replies Latest reply: Jul 17, 2012 5:01 PM by soyroberto
Maxdragon Level 1 Level 1 (5 points)

Hi everyone!

I just solved a big problem with my boot camp i spend 7 hours...




After deleting boot camp 3.2 i tried to install new boot camp 3.3 but it doesnt work.

The most interesting - boot camp 3.2, 3.1, 3.0 doesnt setup too. - Error 2753.

I go to the internet to find answer. A few peoples wrote to download and install BootCamp 2.0.1, and after it 3... I found only version for xp and vista. No for win7.

After 7 hour i found a solution. Error 2753 happens because of file c:/windows/system32/AppleOSSMgr.exe. I just deleted it and try to setup again. And it works!


For all who receive error 2753 when setup bootcamp! Just try to delete file  c:/windows/system32/AppleOSSMgr.exe



If it does not work for you - look up Windows Installer LOGS to see in what moment happens error.

MacBook Pro, Windows 7
  • Sol_Rak Level 1 Level 1 (5 points)

    Great you solved my problem!!!!!!!

  • Cravit8 Level 1 Level 1 (0 points)

    Solved my problem! Mostly


    What the @#$?

    Am I only the third person in the world trying to install Boot Camp drivers onto Win 7 Pro 64 on Mac Mini 2010 with the official install DVD?


    Well then why did it take me 8 hours to find a solution that actually worked?


    Thank you Maxdragon!


    I got "64 not supported..." so I did the right-click compatability method.

    I then got the 2753 error, which could not be resolved not matter how many version of Boot Camp I tried, and oh boy let me tell you I tried them all, with several different Mac Install DVDs from 2008-2010.


    Deleting the file c:/windows/system32/AppleOSSMgr.exe actually allowed the install of Boot Camp 3.0 to actually go through.


    Problem however, is that file has something to do with the Boot Camp icon...that is not where it should be and controls which OS to boot to.  (something something EFI)

  • Sol_Rak Level 1 Level 1 (5 points)

    When you install bootcamp it overwrites it..

  • Cravit8 Level 1 Level 1 (0 points)

    Logic would dictate that the AppleOSSMgr.exe would be in place after installing bootcamp, but I don't think I saw it until after my second attempt.

    Additionally, my BootCamp notification icon did not appear until after I installed the updates 3.2 or 3.3.

    My mac mini is finally at peace.

  • Shawnna Level 1 Level 1 (0 points)

    Wow....   solved my problem - thanks so much! :-)

  • Noldorin Level 1 Level 1 (0 points)

    Many thanks for this Maxdragon! I really appreciate you posting this, when there is really no other information on the web. Problem is all fixed now here.

  • The hatter Level 9 Level 9 (60,915 points)

    There were some foolish suggestions, the part of going back to 2.0. typo?


    Did you mean "delete" or proper method, uninstall?


    Apple made it messy, getting better now, but you needed 3.0, and then upgrade to get 3.3.


    Apple OS Switcher part of Apple Services msconfig and found in control panel Boot Camp is "handy" but not 100% essential (I ran Mac w/ Windows only and never needed to change default / could be done from Mac side Startup Disk and write the variable to NVRAM).


    Going back to 3.0 is all. And when Lion and BC 4.0 came out and were buggy, people needed to uninstall BC 4.0, then go back to SL DVD BC 3.0.


    Editorial: (skip if you are so inclinded):


    What Apple should have and has transitioned to is to download the newest full package.

    That was suppose to be part of Boot Camp Assistant, and intro'd in 10.6.6, but it rarely (10% success?) worked (more field testing, us) and got better with 10.6.8.


    Of course with LION this became the only method to get a set of Windows drivers, BCA and wait and download and store locally.


    MS Installer Cleanup Utility use to be helpful for such chores.


    Turning off services is still possible along wth Startupitems.


    Had you asked here, can't recall, but Windows 7 came out after 10.6, Apple though didn't rewrite BC 3.0, they just said, and confused people, with "you need Boot Camp 3.1" and of course in some cases 3.0 was so bad people could not reboot into Windows and HFS read-only was also 'hazardous.'


    Sometimes seems like a) $30 for Lion just for drivers, and b) Intel and every motherboard manuf has to provide drivers for their products to add chipset support. And it is not this bad or require old out of date buggy drivers in order to install the correct ones you need.


    End Editorial / Back to OP and discussion:


    I don't recall in 5 yrs ever once seeing that error code mentioned and posted here. Kind of thing that sticks and I'd remember, and bookmark as well as search on MS and Bing.

  • bobzjosh Level 1 Level 1 (5 points)

    This solved my problem too. Amazing how a stupid step like this can frustrate you to no end.

  • Cravit8 Level 1 Level 1 (0 points)

    @The hatter

    He meant "delete", because that's what worked, while uninstalling Bootcamp driver actually left that AppleOSSMgr.exe file in place which is so very weird.


    That 2753 error code that comes up while in Windows is probably extremely rare, but it is very real. However, I do not know if it is a Windows for Apple bootcamp error code.


    I was unable to even repeat the problem when I reinstalled Bootcamp and Windows 8 months later, but I do remember it happened only after a first failed attempt to install Bootcamp driver (version un-remember) which originally placed the AppleOSSMgr.exe that subsequently made following attempts fail.


    I say thanks and tip-of-the-hat to Maxdragon for finding this file, I don't know how he did it or what made him look through the entire System32 folder to find it.

  • soyroberto Level 1 Level 1 (0 points)

    It worked! We have a winner