9 Replies Latest reply: Dec 27, 2012 7:18 PM by ddemsey
probe_droid Level 2 Level 2 (470 points)

I am now struggeling with an annoying issue for a few weeks now and hope that someone could give me a hint to get it solved.

 

All by sudden, maybe through a Windows update, my Windows 7 SP 1 system with Bootcamp 3.2 drivers and a self-upgraded NVIDIA driver for my 8800 GS made my screen either freeze or my display to turn off.

The system was still running (as I had it running for a while to finish a download and it did), but was unresponsive for any keyboard strokes to shut it down or on the power off button. Only doing a force shutdown by holding the power button for 5 seconds did turn it off.

 

I then explored different things and also started to uninstall any drivers that could interfere with something.

After removing all the Bootcamp drivers (including the control panel) even for the graphics card and having Windows going back to the out-of-the-box ones, the system went much more stable. But still not that much as it did for the whole last year. Interestingly, the Bootcamp control panel was still there and it magically showed the version number 4.0 (as I did not upgrade to Lion by then).

 

But what is Windows running on a Mac without using all the comfortable keys on the Apple keyboard?

So I waited until I finished checking all my OS X apps to be supported in Lion to install Bootcamp 4.0.

But even after doing this about 1 week ago, it did not really help.

 

Before I now go the hard way of backing up my user data and reinstalling Windows 7, I would appreciate any ideas on still getting this fixed on my current system.


iMac 8,1 24, Mac OS X (10.7.1)
  • ScuseMe Level 2 Level 2 (215 points)

    A couple things....

     

    Have you tried installing Boot Camp 3.3? You mention 3.2 only.

     

    Have you tried installing Boot Camp 4.0?

     

    I have an iMac 9,1 with an Nvidia GT130 card. It's just a little newer than your iMac 8,1. I only use the latest WHQL drivers from Nvidia, plus the Realtek audio drivers. All other drivers come from Apple's Boot Camp drivers or from Microsoft. To install the 4.0 drivers, I had to do the compatibility trick with the Bootcamp64.msi file to get it to install. I've been running pretty well for the past couple of weeks, but in the beginning it was real ****

  • probe_droid Level 2 Level 2 (470 points)

    I cannot really recall if I was on Bootcamp 3.2 or on 3.3, but after uninstalling Bootcamp completely, it had not let me re-install 3.x as the Bootcamp control panel was magically showing version 4.0 (which I had not installed by then).

    I am now on Bootcamp 4.0 after upgrading to Lion, but the issue persists.

     

    And I also had installed the latest WHQL drivers from Nvidia and I had not problems until a few weeks ago.

    I also played around with the power and energy saving settings, but this also did not change anything.

    It could also not be a graphics card issue as Lion runs verys smooth without any issues or hick-ups - OK, Firefox is sometimes crashing on Flahs content, but this is most likely related to Flash as always .

  • The_cobra666 Level 1 Level 1 (0 points)

    I am also having this issue. It's very weird. I removed my Vista x86 last night which was working great and installed Win7 x64. Installing happend without a problem, I only started having problems this morning. The screen just turns completely off.

     

    Bootcamp 3.3 and latest nVidia drivers. OSX runs fine btw, so I know the hardware is fine, heck even Vista ran fine.

     

    My iMac is an: Mid 2008 (C2D 3,06ghz 8800GS and 4GB ram). Did you find a solution for this?

  • The_cobra666 Level 1 Level 1 (0 points)

    Sinds removing the latest nVidia driver, windows 7 runs just fine.

     

    I'm going to try and install the latest driver again tonight and see what it does.

  • Dwayne Allen Level 1 Level 1 (0 points)

    I have also just run into this same issue. I'll be working in Windows 7 for a bit then blammo, my screen goes black and keyboard becomes unresponsive. I would also have to do a hard restart just to reboot. My BootCamp version is Ver. 4 and my nVidia driver is up to date. I did however just went and changed my power settings from the control panel and set both to "Never". I will keep an eye and see if that changes anything. But if anyone should happen to figure out a solution I'll keep checking back.

     

    I'm on an iMac 24" 3.06GHz Mac OS X 10.7.1, 4 GB Ram, nVidia 8800 GS

  • Dwayne Allen Level 1 Level 1 (0 points)

    OK... I think I've fixed the issues I was having and I'm not sure if this will apply to anyone else but its worth a shot.

     

    Find the most up to date driver for your video card and download it but don't install it. Restart Windows in Safemode and go to your Control Panel and select Device Manager. Once there go to your Display Adapters and right click on your Video Card and disable it. Note... if you have more than one video showing up in the menu disable them all.

     

    Restart into Windows, your screen resolution will be low since you've disabled your video card. Uninstall it if you can, I didn't have any problems doing so on my end. Once they've been uninstalled you'll need to restart Windows yet again. Once booted up, go to the drivers you've just downloaded. Right-click and run as administrator. Once thats finished you'll need to restart for changes to take in effect. That should do it.

     

    Since I've done that I haven't had KSoD rear its ugly head so I think thats the trick. Hope this helps out for anyone else who's had this problem.

     

    On a side note... If this problem is happening only on the Windows side and not on the Mac side then it has to be a software / driver issue. I've heard from some people say that its a hardware issue, but this was clearly not the case.

  • The_cobra666 Level 1 Level 1 (0 points)

    I will try your solution! Thanks!

  • The_cobra666 Level 1 Level 1 (0 points)

    Unfortunately, my imac still has the same problem

  • ddemsey Level 1 Level 1 (0 points)

    Same problem.  Running the interl video driver.