Previous 1 2 3 Next 70 Replies Latest reply: Jan 31, 2012 11:51 AM by DOBM
VigorMortis-video Level 1 Level 1

Update is there and I just can't get it.

If I go to  the Final cut page I get the message:

 

"Final Cut Pro 10.0 is already installed and was not purchased from the Mac App Store.

Do you want to buy Final Cut Pro 10.0.1?"

 

What??? Of course I purchased and installed it from the Mac app store!!!

 

If I go to the "Purchased" page, instead of update I get an "Install" button. When I click it, this time I get:

 

"Final Cut is already installed on this computer. Choose Software Update from the Apple menu to check for available updates."

 

But I go to the software update from the apple menu and there is nothing there?

 

What's going on???


Final Cut Pro X, Mac OS X (10.7.1)
Solved by Steviemac63 on Sep 21, 2011 5:40 AM Solved

For anyone else with this issue, i can confirrm that placing your original install of FCPX in the trash and hitting 'install' in the Appstore has succesfully downloaded the new version without re-purchase or without the need to download the original and then the update.

There was no need to empty the trash either so i could pull my original out if any download issues arose.

Reply by James Cude on Sep 20, 2011 2:01 PM Helpful

Yep make sure you actually empty the trash and not just place it there.

All replies

  • eddymceditor Level 1 Level 1

    sounds like the servers are busy. some people can download now while others can't. maybe try again later today

  • Andrew Burke Level 1 Level 1

    I am in the same boat as VigorMortis. There appears to be no update available, either in the App Store or Software Update.

     

    Oddly, in the App Store, the update for Comressor appears for download. But not for FCP 10.0.1.

     

    Well, it's certainly the end of a good era.

     

    Andrew

  • VigorMortis-video Level 1 Level 1

    I tried deleting the app using AppDelete and now I am redownloading FCP from the app store. Hopefully it will be the updated version. I will keep you posted.

  • rhodiad Level 1 Level 1

    Same issue here. AppStore is updating Motion but not Compressor or FCP (both show the erronious "not purchased from the AppStore" message.) I'm not in a big hurry, so I'm not yet resorting to uninstalling/redownloading/reinstalling—hopefully Apple will get things worked out soon and I can avoid the nusiance.

  • CheesesteakMEDIA Level 1 Level 1

    Same here.  Updated Motion & Compressor.  No go on FCP.

  • Bill Flynn2 Level 1 Level 1

    Ditto on updating Motion & Compressor and not FCP.

  • Joseph Nilo Level 1 Level 1

    I'm having the same issue on my MacBook Pro running Lion but was able to update FCPX just fine on my Mac Pro running Snow Leopard. Same App Store account. I hope there's a solution.

  • eddymceditor Level 1 Level 1

    what is your MacBook Pro's graphics card?  if supported (http://support.apple.com/kb/HT4664) you could also try trashing the app from every partition and emptying trash, then downloading from app store again

  • TomWheel Level 2 Level 2

    I had exaclty the same issues as the other posters.  I solved them by dragging the Final Cut Pro X app to the trash.  I could then download and reinstall FCP X from tehe app store.  When I opened FCP X it updated my projects to compatibility with FCP 10.0.1.

     

    I also found an update to Motion which I downloaded form the App Store and installed.  I opened Motion and it state that it was version 5.0.1 which is the latest update.  However, the App Store was still showing that Motion 5 needed to be updated.  I downloaded and installed it again and that solved the problem with No Updates available for me in the App Store. 

     

    I had exaclty the same thing happen with Compressor 4, and it took 3 downloads and installs before that cleared up.

     

    I sent a Customer Support request to Apple App Store.  I was to receive an automated e-mail response in 15 minutes, but it has now been two hours and no response. 

     

    Tom

  • supergenehm Level 1 Level 1

    Hi from germany, i have the same problem. The Motion update is loading but Final Cut 10.0.1 not.

    screen.jpg

  • rhodiad Level 1 Level 1

    FWIW, I'm experiencing the AppStore issue in SnowLeopard so I'm assuming this is an AppStore bug/behavior at this point (rather than OS or app-related) and waiting for Apple to work it out rather than deleting and re-downloading the apps.

     

    I'm sure Apple is learning some me.com-style lessons from this continuing FCP/AppStore situation. Namely, that if they're going to use the AppStore to market and distribute professional level products, then #1, the products had better be up to professional standards; and #2, the AppStore had better have the capacity to elegantly handle the demand.

  • London_Mark Level 1 Level 1

    Tom's approach to FCP X seems to be working for me.  The problem I faced was just the same as everyone else - Motion updated; FCP wouldn't

     

    Quick question - did the rest of you move FCP X into a separate folder so that you could keep running FCP7?  I wondered if that was causing the problem - although moving FCP X back into Applications didn't help.

  • andynick Level 5 Level 5

    I'm updating now - it's downloading as I type from Apple UK App Store.

    FCP X update.jpg

    Andy

  • rhodiad Level 1 Level 1

    FCP10 is right where the AppStore put it (and I'm experiencing the AppStore bug). I also have Final Cut Studio 7 installed.

Previous 1 2 3 Next