Previous 1 2 3 4 5 Next 70 Replies Latest reply: Jan 31, 2012 11:51 AM by DOBM Go to original post
  • James Cude Level 4 Level 4 (1,235 points)

    Yep make sure you actually empty the trash and not just place it there.

  • buildyo23 Level 1 Level 1 (5 points)

    Quick Update:

     

    The Gigabyte download from the App Store just completed, I opened FCP X and it was ...

     

    still version 10.0 :-(

     

    but now when I go to the App Store I can see the update.

     

    Enough for today I'll downloading/updating tomorrow.

  • leefromnew haven Level 1 Level 1 (35 points)

    Same here ...

     

    Can't Update .... says I didn't buy FCP X from the store.

     

    I bought a 25 licence Volume pack!!!!! LOL

     

    Lee

     

    BTW OS 10.6.8 here ... never moved FCPX from the default location, FCP7 is installed and where it was movied to by default. Sigh

  • Skyking Level 2 Level 2 (440 points)

    Many Thanks for this suggestion. While I was able to get all the updates on 3 of my machines, I couldn't on my Mac Pro (just FCP X). Dragged it to the trash (didn't even empty the trash) and that solved the issue. I did get the update 10.0.1. I then emptied the trash. It does seem Apple has some problems to fix with updating via the App store.

     

    Thanks!!

     

    Sky......

  • rhodiad Level 1 Level 1 (0 points)

    You can keep FCP10.0 in your trash until you confirm that 10.0.1 has downloaded and is working.

     

    Just move FCP 10.0 out of the applications folder into the trash, go to the AppStore Purchases tab, find FCP and click on the "install" button. 10.0.1 should download and install itself into your Applications folder. (It did for me anyway.)

  • alexgrainger Level 1 Level 1 (30 points)

    Hi. I also could update motion and compressor but not Fcpx.

     

    If I move Fcpx to the trash, will I lose any of my purchased effects or preferences?

    Has anyone who has been unable to update via mac app store now found that they can, or do we think apple are still to fix?

  • andynick Level 5 Level 5 (4,925 points)

    alexgrainger wrote:

    If I move Fcpx to the trash, will I lose any of my purchased effects or preferences?

    No - these are in your project and events and preference files and will not be lost if you move just the FCP X application from the applications folder to the trash.

     

    Has anyone who has been unable to update via mac app store now found that they can, or do we think apple are still to fix?

    I have read on this forum that this method is successful. It didn't happen to me because I was able to update successfully from Apple UK first time.

    Andy

  • andynick Level 5 Level 5 (4,925 points)

    Alex, I just noticed you are in the UK. How are you trying to update?

     

    Go to the App Store and when you log in, there should be a blue icon against the 'Updates' tab. I just clicked that to open it, then selected FCP X first. It worked first time.

     

    I did not move anything to the trash.

     

    I updated Motion and Compressor later.

    Andy

  • alexgrainger Level 1 Level 1 (30 points)

    Hi Andy,

     

    I went to the App Store, and clicked on Updates as you suggested.

    Only Motion and Compressor appeared. Not FCPX.

     

    When I click on FCPX on the front screen, the only option I got was install, not update. It looked like it was going to charge me a second time!

     

    I haven't moved anything to trash yet. Hopefully Apple will fix this asap so I can update correctly.

  • Chazzzzy Level 2 Level 2 (150 points)

    I have the same issue on my iMac which has Final Cut Studio also installed.. but I DIDN'T have the problem with my Macbook Air which DOESN'T have Final Cut 7 Installed.  So it appears that the issue happens when you have the previous version of Final Cut Studio installed.

  • Steviemac63 Level 1 Level 1 (10 points)

    I have exactly the same issue.  In the Appstore, the button under the icon has said 'install' instead of 'Installed' since the day it was downloaded.

    I figured it was just a minor bug with a confirmation message not updating the page at the time. Didn't realise it would affect my ability to download future updates.

  • alexgrainger Level 1 Level 1 (30 points)

    I am having the problem on my iMac under Snow Leapard, which has FCS3 installed.

     

    Has anyone had the problem without FCS3 installed?

  • Steviemac63 Level 1 Level 1 (10 points)

    For anyone else with this issue, i can confirrm that placing your original install of FCPX in the trash and hitting 'install' in the Appstore has succesfully downloaded the new version without re-purchase or without the need to download the original and then the update.

    There was no need to empty the trash either so i could pull my original out if any download issues arose.

  • VigorMortis-video Level 1 Level 1 (0 points)

    This is far from being a true apple-like experience, but that's the way it is. Loads of people complaining that the app store says erroneusly that we have not spent $300 or $400 with the FCP and its family(not to mention the hard ware). In addition to that we have to delete the original app, download it again and yet another download for the update.

    I must say that although I have been an enthusiast for this version of FCP, Apple has been deeply testing my faith. With all this uninstalling and reinstalling, I felt like a Windows user all over again!!

  • Douglas Parker1 Level 2 Level 2 (175 points)

    Having the same issue here with the Mac App Store saying I did not purchase it from there (where did it come from then?).  Dragging to trash allowed me to redownload...thanks for the advice.  If Apple Support truly ever reads these boards, this is really inexcusable.