Previous 1 22 23 24 25 26 Next 437 Replies Latest reply: Aug 5, 2015 6:18 PM by rlmilton Go to original post Branched to a new discussion.
  • t-leish Level 1 (0 points)

    SMC reset didn't solve my USB keyboard problems, but a powered USB hub did.



  • urbicande Level 1 (0 points)

    Quick update on my side. I followed the advice of John May here:



    And deleted my /Library/Preferences/ (do that in single usermode). Everything has been working perfectly since then (more than a week now).

  • zpjet Level 1 (0 points)

    yep, i wish i read it before reinstalling.


    just to confirm... have you transferred settings from old mac? or connected many different screens?


    it looks new users won't have this issue. my windowserver file was rather long, ca 20 entries...

  • urbicande Level 1 (0 points)

    Yes, it was installed from an Time Machine backup. And yes I'm connecting my computer everyday to at least two different displays (home, which is the previous generation cinema display, and at work, thunderbolt display).

  • zpjet Level 1 (0 points)

    yep, that's what i thought. it looks like issues happen when windowserver is "messed up" from previous computer. glad we got it sorted - mine has been fine more than a month now.

  • urbicande Level 1 (0 points)

    The person that found that solution should be hired by Apple. In my case, they sent someone twice to fix the display and then exchanged it with a new one. Nothing worked of course. I put it back in its box and was waiting for moutain lion to be released.


    I gave it a try again when reading about deleting the windowserver file, and I'm gald I did!

  • ttsang5 Level 1 (0 points)

    count me in too, got the 27" Thunderbolt Display with issues on unplugging then the cover-closed 13" MBA i7 256GB (mid 2012) actually "dead-sleep". it require a hard-reboot from a long press of powerkey.


    Ethernet wasn't a big issue as it take some time like 20-30 second to get online after i plugin the Thunderbolt display, but there's a time when i unplug my USB-Wired mouse, it crash the system to freeze (hard reboot is required). 99% of the time I need reboot the Mac if its unplug with cover-closed.


    Mac Lion 10.7.4

    Thunderbolt Display 27"


    Hardware Overview:


      Model Name:          MacBook Air

      Model Identifier:          MacBookAir5,2

      Processor Name:          Intel Core i7

      Processor Speed:          2 GHz

      Number of Processors:          1

      Total Number of Cores:          2

      L2 Cache (per Core):          256 KB

      L3 Cache:          4 MB

      Memory:          8 GB

      Boot ROM Version:          MBA51.00EF.B00

      SMC Version (system):          2.5f4

  • john straw Level 1 (5 points)

    I have a 2012 MBA 11" and the 2012 TB display. I have a 500 gig G Drive plugged into the TB port acting as a Time Machine backup. This configuration works perfectly.


    However as soon as I plug in anything that looks like a USB peripheral - mem stick and keyboard seem to be the worst offenders, the Time Machine drive locks up totally and consistantly. A reboot doesn't work - the dock display disappears and the machine locks - requires a physical on/off button action to effect the reboot.


    When I first got the display i bought it with a USB keyboard which acted oddly. Now it won't even recongnise it.

  • tonym20 Level 1 (0 points)

    I have the same problems with USB keyboard & USB mouse attched to the monitor.  I tried switching the order and now have the keyboard connected to the first USB slot on the back of the monitor, then the USB mouse in the second.  Having the keyboard in the first slot (slot closest to the side of the monitor) seemd to have fixed the issue.


    Give it a try

  • Erik Johnson3 Level 1 (0 points)

    Hi folks,


    It's been at least a month (or more) since I last posted and update regarding my MBA and the TB display. 


    Ever since I performed the following steps, I have had absolutely no problems with the TB display and my MBA.  I know that there are many "secret sauce" approaches (esoteric keystroke sequences, special booting instructions, etc) posted here by fellow troubleshooters on how to remediate this problem, but I was primarily interested in getting down to the root cause of the problem, which I think I now understand.  I was not interested in trying to fix symptoms.  If other solutions work well for you, then that's all that counts.


    Root cause:  Underpowered USB hub on the TB display.  Plugging in too many USB devices will exceed the power limitations of the hub and cause the numerous problems documented in this forum to appear.  Apple has not yet addressed this root cause; it may be a hardware engineering issue, which could take some time to flush out, or a combination hardware and firmware issue (up to Apple to determine).


    My root-cause workaround solution:


    1.  Perform an SMC reset on your MBA (very well documented in this forum).  Peforming the reset was very easy and seemed to have no negative consequences on MBA operations whatsoever.


    2.  Ensure you are operating on the latest version of the MBA firmware.


    3.  Remove any high-current devices off the back of the TB display.  Examples: unpowered USB hubs, portable disk drives (that power off the USB), etc.  I still charge my iPhone and iPad off the TB display, as well as have the keyboard plugged in there, but other high-current devices I just plug directly into the MBA on the rare occasion that they need to be hooked up, and it has no effect on the display.


    4.  When connecting the MBA to the TB display, I always ensure that I'm logged into my user account on the MBA first, then plug in the display.  Performing a restart with the TB display attached hasn't been a problem.  No issues noted when removing the display from the MBA, logged in or not.


    My configuration works for both Lion and Mountain Lion.


    That's it.  I am 100% satisfied with the performance of the display and the MBA now (and am just waiting for Apple to actually address the root cause).  Hope this workaround helps.


    P.S. For those folks still working on identifying specific symptoms, the software Hardware Growler, available from the App Store, may help pinpoint other issues.  It tracks and reports hardware events, so I suspect that when a TB display condition occurs that it may help narrow down what the problem is.  I use both Growler and Hardware Growler -- great software and very inexpesive for what it does (reporting system events).


    Message was edited by: Erik Johnson3

  • Grant Griffith Level 2 (165 points)

    This issue was resolved with Mountain Lion for me.

  • john straw Level 1 (5 points)

    With me to.

  • SaintDudesDay Level 1 (0 points)

    SO I just returned from the Mac store in Santa Monica. Genius bar appointment. He looked in the Apple database (private) and said that Apple is aware of this problem, and working actively on a patch. No timeframe was given. NO explanation of why apple cannot publicly ackowledge this to save people the time and hassle and waste of genius bar appointments for this problem. Also, he had no idea of a workaround.


    But.... help is coming... Thanks apple.

  • akisok2 Level 1 (10 points)

    I am just now experiencing the same issues after nearly 1 year of flawless performance and fucntionality from my MBA and TD combo. To be sure that it wasn't software, I did a fresh install of Mountain Lion last night but it did not fix the problem.

  • akisok2 Level 1 (10 points)

    Thank you! That process worked perfectly for me too! After completing the SMC and PRAM resets, I unplugged my iPhone and USB SuperDrive and then plugged the Thunderbolt Display back in. Once the display was active, I closed the lid on my MBA and tested the volume keys -- they indeed worked with the TD speakers instead of the MBA speakers. Final test was to plug in the iPhone -- and it worked! Recognized by the MBA and charging as we speak!


    I'm guessing that the SuperDrive is the culprit, maybe it draws too much power...?  That's weird because I've left it plugged in to the TD for months now. Oh well -- guess I'll just leave it unplugged for now and plug it into the MBA directly when I need to use it.



Previous 1 22 23 24 25 26 Next