3 Replies Latest reply: Feb 1, 2012 9:22 PM by nkorosec
Aadityavikram Level 1 Level 1 (0 points)

I tried to uninstall google chrome using appcleaner but after it placed the files in trash and I tried to empty trash it deleted all files including plist files except the main chrome.app . It says that the file is locked whereas when I check, it shows it to be unlocked. There is no other file in trash except the chrome.app. And when I try to install it from the chrome site again it says that chrome is already installed.Screen Shot 2011-09-22 at 12.30.50 PM.jpg

 

Screen Shot 2011-09-22 at 12.31.09 PM.jpg


MacBook Pro, Mac OS X (10.7.1), 13 inch 2011
  • ds store Level 7 Level 7 (30,315 points)

    Well I bet that's the last time you use appcleaner.

     

    All those gimmick app cleaners do is a search, they don't know what was installed or where.

     

    I'm assuming you don't have Timemachine or a Carbon Copy Cloner around?

     

    Tried to change the name of Chrome and reboot? Repair Permisisons in Disk Utility?

     

     

    You can download the free OnyX and I believe there is a option to Nuke the Trash with extreme prejudice.

     

    http://www.titanium.free.fr/

  • thomas_r. Level 7 Level 7 (29,585 points)

    Try holding down the option key while choosing Empty Trash.  That forces the OS to delete locked files without you having to hunt them down.  If that doesn't work, see:

     

    http://www.thexlab.com/faqs/trash.html

  • nkorosec Level 1 Level 1 (5 points)

    I had the same problem and it drove me nuts. Finally figured it out. When deleting the Chrome.app make sure to delete the support files found in /*your_home_foler*/Library/Application Support. What you're looking for is a folder called "Google". There is another similar folder found in the same directory minus the "Application Support" bit. So all in all 2 "Google" folders and the Chrome.app should go in the trash for a complete uninstall.