11 Replies Latest reply: Feb 7, 2013 12:34 PM by criwil
chaihoney Level 1 Level 1 (0 points)

A few days ago my mail crashed a few times in a row. Restarted the computer and all was fine.

today it happened again -- but restart did NOT work.  tossed out the prefs, reset the info and tried again.

NO MAIL - keeps crashing.

Noticed all sorts of weird prefs - symbols, etc. Tossed them into the trash. Emptied trash and tried again -- More crashing.

The report says:

 

Exception:  EXC_BAD_ACCESS (0x0001)

Codes:      KERN_INVALID_ADDRESS (0x0001) at 0x683c0104

 

I have no idea what to do! HELP.


iMac, Mac OS X (10.4.11)
  • 1. Re: Mail keeps crashing!
    BDAqua Level 10 Level 10 (116,480 points)

    Any more from the Crash log, like from Thread xx cashed on?

     

    Not certain, but this can fix myriad Mail problems...

     

    Safe Boot from the HD, (holding Shift key down at bootup),  it will try to repair your Disk Directory while the spinning radian is happening, so let it go, run Disk Utility in Applications>Utilities, then highlight your drive, click on Repair Permissions, then move this folder & file to the Desktop.

     

    Move this Folder to the Desktop...

     

    /Users/YourUserName/Library/Caches/Mail/

     

    Move this file to the Desktop...

     

    /Users/YourUserName/Library/Mail/Envelope Index

     

    Reboot.

  • 2. Re: Mail keeps crashing!
    chaihoney Level 1 Level 1 (0 points)

    I'll try this later when I get home -- though I am not sure if I understand it all - for as many years as I've used Macs  (since the beginning!) I get nervouse when I have to do this kind of stuff.

    I have already run repair permission on the hard drive -- though haven't done the safe boot.

     

    more detail:

    Thread #9 this time - last time it was #7!

    Thread 9 Crashed:

    0   ...entSemanticMappingFramework     0x964165eb LSMMapCounter::~LSMMapCounter [in-charge]() + 19

    1   ...entSemanticMappingFramework     0x9641ca4c LSMTrainingMap::~LSMTrainingMap [in-charge deleting]() + 40

    2   ...entSemanticMappingFramework     0x9641c1cf LSMMapLoadWithOptions + 271

    3   ...entSemanticMappingFramework     0x9641c1fb LSMMapLoad + 25

    4   com.apple.MessageFramework         0x9948e37f JunkMailGlobalMap + 129

    5   com.apple.MessageFramework         0x994ec8a7 MFJunkMailLevelForString + 24

    6   com.apple.MessageFramework         0x9943d905 -[MessageCriterion _evaluateJunkMailCriterion:] + 1262

    7   com.apple.MessageFramework         0x9943ac3d -[MessageRule doesMessageSatisfyCriteria:] + 193

    8   com.apple.MessageFramework         0x9943a946 +[MessageRouter putRulesThatWantsToHandleMessage:intoArray:colorRulesOnly:] + 504

    9   com.apple.MessageFramework         0x99488c6b -[MessageRouter routeMessages:fromStores:] + 1319

    10  com.apple.MessageFramework         0x994985a5 -[MessageRouter routeQueuedMessages] + 911

    11  libobjc.A.dylib                    0x90a5cd76 objc_msgSendv + 54

    12  com.apple.Foundation               0x92802d82 -[NSInvocation invoke] + 932

    13  com.apple.MessageFramework         0x9940a8d0 -[MonitoredInvocation invoke] + 128

    14  com.apple.MessageFramework         0x9940a761 +[WorkerThread _execute:] + 80

    15  com.apple.Foundation               0x927fbcfc forkThreadForFunction + 123

    16  libSystem.B.dylib                  0x90023d67 _pthread_body + 84

  • 3. Re: Mail keeps crashing!
    BDAqua Level 10 Level 10 (116,480 points)

    I was nervous to begin with too!

     

    Not certain, all I see is Rules there really, we might have move these to the Desktop while in Safe Mode also...

     

    If that doesn't do it and you can afford to redo all your Rules, try these & reboot...

     

    /Users/YourUserName/Library/Mail/MessageRules.plist

     

    /Users/YourUserName/Library/Mail/MessageRules.plist.backup

  • 4. Re: Mail keeps crashing!
    chaihoney Level 1 Level 1 (0 points)

    This didn't work -- I assume I am supposed to trash the files on my desk top.

    Is it time to re-install the mail program?

     

     

  • 5. Re: Mail keeps crashing!
    BDAqua Level 10 Level 10 (116,480 points)

    Yes, you can trash them if you like.

     

    I can't remember, but I think the big Combo update had Mail 2.1.3 in it, you might try reapplying that...

     

    The combo update for PowerPC-based Macs...

    http://www.apple.com/support/downloads/macosx10411comboupdateppc.html

     

    The combo update for Intel-based Macs...

    http://www.apple.com/support/downloads/macosx10411comboupdateintel.html

     

    Repair Permissions afterwords, reboot.

  • 6. Re: Mail keeps crashing!
    chaihoney Level 1 Level 1 (0 points)

    so I should use the download fromt he web rather than my cd of system 10?

  • 7. Re: Mail keeps crashing!
    BDAqua Level 10 Level 10 (116,480 points)

    Well, I'm thinking that would be best, assuming the combo does contain Mail, it may repair other things too.

  • 8. Re: Mail keeps crashing!
    chaihoney Level 1 Level 1 (0 points)

    Downloaded - ran - no email!

    thank heaven I have webmail!

     

    Any other clues? Is there a way to run my install disc and ONLY re-install the mail program?

  • 9. Re: Mail keeps crashing!
    chaihoney Level 1 Level 1 (0 points)

    I decided to give it one more try -- after running the update, nothing happened.

    I went back in and removed the various files you had listed and it worked!

     

    I am very hopeful that whatever was the bug is no longer the bug . . .

    Thanks for your efforts and guidance!

  • 10. Re: Mail keeps crashing!
    BDAqua Level 10 Level 10 (116,480 points)

    Good to hear!

  • 11. Re: Mail keeps crashing!
    criwil Level 1 Level 1 (0 points)

    I just had the problem and fixed it by disconnecting the ethernet cable so that Mail couldn't get the offending email...then I was able to select another email and all is well.