Previous 1 2 3 Next 83 Replies Latest reply: Apr 16, 2014 4:49 AM by nkalvi
lemon-kun Level 1 Level 1 (15 points)

Back in Snow Leopard, we had the possibility to view all characters of a certain font if we selected "View>Glyph" in the character viewer. In Lion, this option seems to be missing. Is there any way to browse all characters of a specific font?

 

The reason I need this: I have several special fonts with symbols for scientific work (really specialized fonts, with characters you won't find in the symbols Apple provides). In SnowLeopard, they didn't show up in the character viewer as normal symbols, but in Glyph View one could select the font and then all characters were displayed, so one could easily select the right symbol (my friends using Windows could even assign a keyboard shortcut for each character in their character viewer).


MacBook Pro, Mac OS X (10.7.1)
  • quicksilver8 Level 2 Level 2 (310 points)

    With Font Book you can.

  • lemon-kun Level 1 Level 1 (15 points)

    Ah, thank you! However, is there any possibility to get those "into" a written text? With character viewer you could insert by double clicking or drag and drop. Do I have to purchase an app for that under Lion?

  • quicksilver8 Level 2 Level 2 (310 points)

    Control-click over a character in Viewer, and you can copy charcater * infos about it (shows submenu: show char. Infos)

  • lemon-kun Level 1 Level 1 (15 points)

    Sorry, probably I am not clear enough:

     

    I want to insert some special characters of a certain font into a text. I have no possiblility to view those characters in CharacterViewer. So I open FontBook where I am able to see all characters of that certain font. How do I insert now the wanted character into the text? It's still not visible or even selectable in CharacterViewer, and from FontBook I am unable to insert into the text.

  • quicksilver8 Level 2 Level 2 (310 points)

    You can do from Fontbook so:

    Open in Fontbook that font, then, from Preview menu of Fontbook, you must select Ad Hoc (Custom). You'll see that, in that view, you can select every single font and copy it. For me, it works fine.

  • lemon-kun Level 1 Level 1 (15 points)

    Thanks, that works at least for the first few characters. Problem is, with this view it displays only ABCDEFG...abcdefgh...1234567890. Not all characters. So I am still not able to insert, say, character 145 of a certain font...

  • quicksilver8 Level 2 Level 2 (310 points)

    I can with all. Don't forget the scroll bar to scroll all of characters! Also, you can set the size of font to view them all in the screen.

  • lemon-kun Level 1 Level 1 (15 points)

    Very strange. In FontBook, I only get a preview of

     

    ABCDEFGHIJKLM

    NOPQRSTUVWXYZ

    abcdefghijklm

    nopqrstuvwxyz

    1234567890

     

    nothing more. I file a report to Apple's OS X Lion feedback website. For the moment, I'll do the following: next monday, I'll ask a friend using Windows to write all the required characters in a Word or RTF-File, and then I'll put it on my mac and open that, copy/paste from it.

     

    That's cumbersome of course, probably I will have to buy an app like Fontcase.

  • Tom Gewecke Level 9 Level 9 (74,465 points)

    lemon-kun wrote:

     

    Very strange. In FontBook, I only get a preview of

     

     

    You want Preview/Repertoire to see everything.  But to input you will have to get PopChar, and even that will not show you glyphs with no Unicode number.  Hopefully the stuff you want has that. Could you provide more info these symbols?  10.7 has a whole set of STIX fonts that might have them too.

  • Paul Boyer1 Level 1 Level 1 (5 points)

    I have the same problem.  It seems to be another loss of function with Lion.  Either that, or they hid the feature so well that no one knows how to find it.

     

    There is no Viewer drop-down menu which allows one to select Glyph; nor can one select a particular font in the character viwer.

     

    If the feature is hidden, there is no documentation for it.

  • Tom Gewecke Level 9 Level 9 (74,465 points)

    Paul Boyer1 wrote:

     

    If the feature is hidden, there is no documentation for it.

     

    It's not hidden, the feature is gone with Lion, it's a well-known change.  You can use PopChar as mentioned earlier or borrow a copy of the 10.6 Character Viewer and run it as an independent app in 10.7.

  • Stokestack Level 1 Level 1 (0 points)

    Selecting the custom view does not work, because it doesn't show all the characters in the font.  It simply displays the default sample characters (not "repertoire") so you can edit it and put custom text in.

     

    And as documented above, Character Viewer is useless because it shows nonexistent characters.

     

    I can't believe I just wasted an hour trying to INSERT AN ARROW INTO A DOCUMENT, on the vaunted Mac OS, the OS for "creative" people.  Writers.  Artists.

     

    Uh huh.

  • softwater Level 5 Level 5 (5,370 points)

    Is this what you're looking for? Click on the cog in the top-left of character viewer and choose 'customise list'.

     

    Screen Shot 2012-07-08 at 13.52.18.png

  • Stokestack Level 1 Level 1 (0 points)

    No, thanks.  That still doesn't let you show the characters that are availalble for a particular font.  That big assortment of arrows it's showing?  Essentially useless, because they're not available in any font I can find.

     

    I did discover a cumbersome workaround by using both Font Book and Character Viewer.

     

    1. Go into Font Book and select the "custom" preview.  Put the cursor in that editable preview area.

     

    2. Now go over to Character Viewer and double-click the character or symbol you're interested in.  It will be pasted into the "custom" preview of Font Book.  However, there's a bug; for some reason after the special character is pasted in, the glyphs that were showing for the font will return to being boxes.  You have to select a different font and come back, in order to display the glyphs again.

     

    You can now use the up/down arrow keys to step through all the fonts in Font Book and at least see which fonts have the character(s) you're looking for.

Previous 1 2 3 Next