9 Replies Latest reply: Jul 16, 2013 2:39 AM by skybunkerboy
SEJBEH Level 1 Level 1 (0 points)

I've had my Macbook Air for two weeks now and for some reason the "me" picture in Adress Book (6.0 - Lion) keeps changing itself. I've tried everything but the picture keeps switching back to the old default picture I chose when I set up my computer. If I open up my card in Adressbook and change the picture it will switch back within 2 seconds right infront of my eyes! If I change my user icon in System Preferences it will revert to the old icon as soon as I open up Adress Book. I've also tried to set up another admin account and change it through there, but no luck.

 

It might sound like a petty problem but it's very frustrating so please help! How do I get the picture I chose as my "me" picture to stay?

 

/E


MacBook Air, Mac OS X (10.7.1)
  • léonie Level 9 Level 9 (65,225 points)

    Have a look in your User Library at the AddressBook Pictures. Maybe your old buddy picture is corrupted or locked.

     

    The old Addressbook Pictures should be installed here:

     

    /Users/your short user name/Library/Application Support/AddressBook/Images/

     

    Quit Address Book and System Preferences if they are open.

     

    The Library folder is hidden by default. You can open it from the Finder  menu -> Go -> Got to Folder or typing Shift-cmd-G, then enter "~/Library"  and navigate to Application Support/AddressBook/Images/.

     

    You might be lucky and can spot your old picture by its preview, if they are jpegs, but more likely the pictures will have no previews. Then open them with Preview, and if you find your old picture remove and trash it. If it is locked or write protected you need to fix the permissions or remove the lock:

    Select the picture in the Finder, type cmd-I  (Finder menu -> File -> Get Info) and click the lock in the info panel. Enter your admin-password and disclose "Sharing and Permission", add read and write permissions for yourself, if you don't have them, in the General-section uncheck the lock.

     

    Now log out and log in again, restart Address Book and see if the offending buddy picture is gone.

     

    Good Luck

    Léonie

     

    P.S: More buddy pictures are installed in

    /Users/your short name/Library/Images/People/

    These pictures are named like the email-adress.

     

    Have a look there, if the above solution dosn't help.

  • SEJBEH Level 1 Level 1 (0 points)

    Thank you for your response. Unfortunately it didn't help. I went through all the adress book pictures (all 998 I'm guessing from backing up my iPhone). But all I could find were the pictures I've been trying to use as the "me" image. The old picture that I can't get rid of is a default mac icon that I picked when I set up my computer the first time. It's an icon with a pink flower which I can not find among my adress book pictures in library/application support/adress book/images.

     

    It's all very weird to me because I can change any other contact in the adress book. It's only my own contact that is acting up...

  • léonie Level 9 Level 9 (65,225 points)

    SEJBEH wrote:

     

    The old picture that I can't get rid of is a default mac icon that I picked when I set up my computer the first time. It's an icon with a pink flower which I can not find among my adress book pictures in library/application support/adress book/images.

     

    It's all very weird to me because I can change any other contact in the adress book. It's only my own contact that is acting up...

    Hello SEJBEH,

    your old .mac account is probably the culprit - in the address book help it says:

     

    "A picture can also appear if a contact has a MobileMe subscription that was originally a .Mac account that was set to share pictures."

     

    Unfortunately, it does not say how to remove that picture. Perhaps you should stop synching mail and contacts, set up your Address Book and then revert the Mobile Me Address Book.

     

    Léonie

  • SEJBEH Level 1 Level 1 (0 points)

    Hi LeonieDF!

     

    I think I have solved my problem by simply deleting my own adress card and make a new one. So far so good . Thank you for all you time! I've never had a MobileMe account so I didn't try that.

     

    Thank you again!

  • léonie Level 9 Level 9 (65,225 points)

    Such an easy solution! Im glad you solved the problem!

     

    Regards

    Léonie

  • iXeron Level 1 Level 1 (0 points)

    Also you can export and then import your vCard.

  • SiloBlue Level 1 Level 1 (0 points)

    So  I have had this problem even after updating to 10.7.5 What I noticed is that in the box that says full name in users and groups under system preferences I did not include my middle name. However in my contacts I had created it with my middle name being in the first name field. Once I changed it to include my first name in the user and groups area it started working and has not chancged back yet. I hope this helps the others that couldnt get it fixed before. Please let me know if this helps you.

  • Fordsfords Level 1 Level 1 (0 points)

    Strangely, this same problem started happening to me this morning ... after months of no problems.  I am certain that I haven't made any remotely-related changes in the past few days.

     

    Anyway, here is an easier solution that worked for me.

     

    Instead of trying to change the pic from the address book app, I went into the system preferences screen "Users & Groups".  (If locked, unlock the page to make changes.)  Click on the picture and select "Edit Picture".  At the top select "Recent Pictures" and select the one you want.  Then click "Set".

     

    Within a second or two, the address book picture changed to my desired picture.  No problems since.

  • skybunkerboy Level 1 Level 1 (5 points)

    Thanks Fordsfords this worked for me 

    its actually the easiest/quickest fix here

     

    pat yourself on the back!