1 2 3 4 Previous Next 55 Replies Latest reply: May 27, 2014 6:01 PM by Funmunke Go to original post
  • 15. Re: Disk Utility cannot unmount disk
    hoosier Level 1 Level 1 (0 points)

    PRAM also didn't help

  • 16. Re: Disk Utility cannot unmount disk
    Kappy Level 10 Level 10 (226,845 points)

    Then what you can do is boot from the installer DVD, use DU to erase the internal drive, install OS X from scratch then restore your files from the backup you have.

     

    While you are free to re-setup the drive you can create any new partitions you want (if you want any.)

  • 17. Re: Disk Utility cannot unmount disk
    hoosier Level 1 Level 1 (0 points)

    When I go to erase the disk I get "Disk erase failed with the error: Could not unmount disk"

     

    Any other ideas?

  • 18. Re: Disk Utility cannot unmount disk
    Kappy Level 10 Level 10 (226,845 points)

    Drive Preparation

     

    1.  Boot from your OS X Installer Disc. After the installer loads select your language and click on the Continue button.  When the menu bar appears select Disk Utility from the Utilities menu.

     

    2. After DU loads select your hard drive (this is the entry with the mfgr.'s ID and size) from the left side list. Note the SMART status of the drive in DU's status area.  If it does not say "Verified" then the drive is failing or has failed and will need replacing.  SMART info will not be reported  on external drives. Otherwise, click on the Partition tab in the DU main window.

     

    3. Under the Volume Scheme heading set the number of partitions from the drop down menu to one. Set the format type to Mac OS Extended (Journaled.) Click on the Options button, set the partition scheme to GUID then click on the OK button. Click on the Partition button and wait until the process has completed.

     

    4. Select the volume you just created (this is the sub-entry under the drive entry) from the left side list. Click on the Erase tab in the DU main window.

     

    5. Set the format type to Mac OS Extended (Journaled.) Click on the Security button, check the button for Zero Data and click on OK to return to the Erase window.

     

    6. Click on the Erase button. The format process can take up to several hours depending upon the drive size.

  • 19. Re: Disk Utility cannot unmount disk
    hoosier Level 1 Level 1 (0 points)

    Got to step 3 and when I hit partition it gives me "Partition failed with the error: Could not unmount disk"

  • 20. Re: Disk Utility cannot unmount disk
    Kappy Level 10 Level 10 (226,845 points)

    I think you have a defective drive assuming you are following the instructions correctly.

  • 21. Re: Disk Utility cannot unmount disk
    hoosier Level 1 Level 1 (0 points)

    That's what I was affraid of just didn't wan't to give up on it.

  • 22. Re: Disk Utility cannot unmount disk
    dmdimon Level 3 Level 3 (840 points)

    @Kappy you can not "fix" mean write something to drive without mount it w

    check yourself - boot single and read some last 2-3 strings - there it is

     

    @hoosler your mac should be able to boot in target mode

    read here instructions http://www.techrepublic.com/blog/helpdesk/boot-a-sick-mac-into-target-disk-mode- for-troubleshooting/293

    try to repair/repartition target drive from other mac

    also read this: http://support.apple.com/kb/ht1661

  • 23. Re: Disk Utility cannot unmount disk
    Kappy Level 10 Level 10 (226,845 points)

    Well, not to start a battle over this but I'm afraid neither Apple nor Unix seem to agree.

     

    File System Maint. - fsck

  • 24. Re: Disk Utility cannot unmount disk
    dmdimon Level 3 Level 3 (840 points)

    its simple - just try it and you'll see.

    look:

    "

    If fsck found issues and has altered, repaired, or fixed anything, it will display this message:

    ***** FILE SYSTEM WAS MODIFIED *****

    "

    file system can not be modified while r-only mounted

     

    looks like error or not exact description.

     

     

    @hoosier also you can give a try with a Disc Warrior or Drive Genius

  • 25. Re: Disk Utility cannot unmount disk
    hoosier Level 1 Level 1 (0 points)

    Any free software to try? Target mode gave me the same error that the disc could not be unmounted

  • 26. Re: Disk Utility cannot unmount disk
    dmdimon Level 3 Level 3 (840 points)

    download some fresh Ubuntu live cd, boot from it and repartition internal HD to anything MBR,

    then boot from install DVD and repartition into GUID, 1 partition (you should set GUID in options)

  • 27. Re: Disk Utility cannot unmount disk
    Xejorax Level 1 Level 1 (0 points)

    The problem I was having was with a Toshiba 500GB external USB 2.0 drive. The symptom was that the Mac OS X Disk Utility could see the drive but trying to format it would hang indefinitely at "Unmounting Drive".

     

    I formatted the disk with the built in disk format and partitioning tools in  Windows 7. Then I could mount and unmount on the Mac OS X Disk Utility. Maybe using utilities in Linux would also work. After this I was able to format the disk in Mac OS X and use the drive for time machine.

     

    How my problem started: Hooking up the drive to the WNDR3800 router seemed to mess it up and my Mac coul no longer reaad the disk correctly. Foratting it in a Windows env was the only way I could get it to work again on my Mac.

  • 28. Re: Disk Utility cannot unmount disk
    Martin Le Level 1 Level 1 (0 points)

    It is pretty easy that you just need to right click on the disk that "unable to unmount" >>>select reveal that file in finder >>> then reject the disk ( remember to quit DU) >>> then reopen DU again >>> and now you are done, you can remove the partition as usual

    Cheers

  • 29. Re: Disk Utility cannot unmount disk
    Queso de Papa Level 1 Level 1 (0 points)

    I didn't read everything, so this might be redundant, but I was getting the same error message, and it was because there was some Seagate software called 'Mac Installer' that had mounted on the desktop.  I ejected that, and was able to partition immediately. 

     

    I would recommend looking for anything with the white, thumb disk-icon that looks like it might have come with the new drive, and eject it.  Or if you have any other files open that came pre-installed on the drive, close them.