13 Replies Latest reply: Sep 30, 2011 11:48 AM by mek!
mek! Level 1 (15 points)



I have a Mac Mini Server (Mid 2011) which does not boot up anymore.


A benq screen is connected via HDMI and a mac keyboard via USB.


What I did before:


* generate lion recovery stick

* boot up with it an created a raid1 on the two internal 750gb drives

* reinstalled OSX (which took way to long, I want a full USB installer and not a network based one!)

* booted up OSX (worked nicely)

* installed the 5 pending software upgrades (one was the EFI Update)

* the efi update itself looked ok (grey progress bar was 100%) but instead of starting up my screen went blue

(=sign for lost hdmi signal) and the mac mini fan went to full speed.

* there was no interruption, power outage, reboot or whatever during the EFI BIOS update.


After that I called the Apple support, which only mentioned that I have to bring it in.


After waiting >30 min on the first support call they said I shall turn it off and on.

I tried the 10sec power button press method, pram-zapping, target mode towards an

other mac via thunderbolt, recovery mode, ... nothing changed the behavior.


The only thing it does on powering it on is to show a steady led, you feel the virbrations

from the spinning disks and after 25sec the fan turns full speed again.


For me it smells like an EFI issue, I wonder if the update routine got confused by the RAID1

(like trying to store some temporaty file which failed)


If I press the power button while plugging in the power and press power again the led does not

lite and the fan turns on imidiatly, these are the two modes in which I seem to be able to power it up.


I saw for older macs exists an "Firmware Restoration CD" http://support.apple.com/kb/HT2213

But I did not find anything else.


After calling Apple support again and spepding 2h in the phone queue and two disconnects

I got to a "Senior Advisor" who did not even knew about the "Firmware Restoration CD" at all, ...

He said there is no Recovery for this model and that most likely the logic board has to be replaced.




What I would like to hear from all of you out there:


* is there any way to recover a EFI firmware on the most recent Mac models, like my Mid 2011 Mac Mini Server?

(if not this sounds a bit broken by design)


* Any other suggestions what I could do to bring the Mac Mini back to life?



Thx, mek!

Mac mini, Mac OS X (10.7.1), Server with 2x750 in Raid1