5 Replies Latest reply: Sep 30, 2011 12:35 AM by hoongern
augustj Level 1 Level 1 (0 points)

I have a new 15 inch Macbook Pro that shipped with Lion which has recently succumbed to a sleeping problem.  When I have the computer plugged in to the wall outlet for charging, and I close the lid, it goes to sleep, but the sleep light stays on solid; it does not blink/fade on and off.  Then, under these same circumstances, when I open the lid, I see my login screen for about 1.5 seconds and then the screen goes black.  If I click the F1 button to turn the screen brightness down, the login screen returns, and I can login and use the computer as normal with no issues.  If I unplug the MagSafe charger and allow the computer to run on its battery, none of these issues occur.

AND all of the Energy Saver preferences are set to the default, and all sharing is disabled.

 

All help is sincerely appreciated,

Jake


MacBook Pro, Mac OS X (10.7.1)
  • 1. Re: Sleeping problem with OS X Lion?
    gert2202 Level 1 Level 1 (10 points)

    I have the exact same issue! I'm so glad it isn't just me having this problem ..

    I also have a 15 inch Macbook Pro with OSX Lion.

    I really don't know whether it's a new feature of Lion or a bug.

    Sleep mode seems to be disabled while charging ...

     

    If you put the Macbook Pro to sleep with the magsafe adapter plugged in, it won't go to sleep. You can still hear the fans running, and the light won't blink, as you indicated. When you open the lid again, the screen lights up for a few seconds, then turns black. I haven't tried the F1 key, but I do know the screen comes back when you unplug the adapter ...

     

    And it's getting even stranger: when you close the lid with the magsafe adapter plugged in, my MBP won't go to sleep. But when you plug out the adapter while still having the lid closed, my MBP WILL go to sleep. When you plug the adapter back in while sleeping, it will still keep asleep but the battery WON'T charge, although the adapter 's connected (the light is green while it should be orange, since the battery is not fully charged).

     

    None of these issues occur when you put the MBP to sleep without the power adapter connected; it goes to sleep seamlessly.

     

    It seems to me that this could be a bug, but it could also be an extra safety feature of apple ..

    Maybe they wanted to protect the battery this way? I hear a lot of people say it's bad to keep for your battery to keep your laptop plugged in all time, although I doubt it.

     

    Someone who knows more about this, or has a fix for this 'bug' ?

  • 2. Re: Sleeping problem with OS X Lion?
    nathanfromhokesbluff Level 1 Level 1 (0 points)

    I have a 2.3 Ghz 13" Macbook Pro with Lion, Same Issues. I haven't Called Apple Yet, But I plan on it Soon.

    I have Noticed Mine not sleeping when Unplugged too, because My battery was Dead after being in my bag for three hours with a half charged battery to start with. Early 2011 Macbook Btw.

  • 3. Re: Sleeping problem with OS X Lion?
    gert2202 Level 1 Level 1 (10 points)

    Problem solved! Been looking around on some other topics and it solved my problem:

     

    https://discussions.apple.com/message/16091347#16091347

    https://discussions.apple.com/message/16077384#16077384

     

    Apparently, VMWare fusion is a cause, and also printer drivers and printer task ques.

    I had an item in an offline printer que, deleted it, and my macbook went to sleep again!

  • 4. Re: Sleeping problem with OS X Lion?
    augustj Level 1 Level 1 (0 points)

    ^That was the ticket! Thank you so much!

    I had an item in the print queue of a printer that I no longer have hooked up.

     

    Thank you for the help, hopefully this will help other peoplel as well.

     

    -Jake

  • 5. Re: Sleeping problem with OS X Lion?
    hoongern Level 1 Level 1 (0 points)

    As has been noted by a few people here and there, running "pmset -g assertions" from the terminal will let you know what is preventing your OS from sleeping.

     

    It ranges from file sharing to printer sharing to remote SSH users, etc.

     

    Also, the conditions which prevent a computer from sleeping can vary depending on whether the computer is on AC, or running on battery, which is why some people have solved their issue by unplugging their computer first.

     

    I also made a small app to help with diagnosing the problem, if anyone is interested. Source code is provided. If you don't trust it, just use "pmset -g assertions".

     

    Hope Apple fixes it soon.