8 Replies Latest reply: Sep 27, 2011 8:26 AM by 4thSpace
4thSpace Level 1 Level 1 (0 points)

Lately, Numbers is taking a very long time to start (minutes).  The icon will appear in the doc bouncing for quite a while.  Then the app isn't responsive.  Today, I tried to save a file and Numbers froze.  It is listed in Force Quit Applications as "(not responding)".  After a  force quit, that didn't help much.  I started Numbes and tried to click the menu, but just get the spinning rainbow.  Clicking the icon in the dock does nothing.  It does have the spotlight under it.

 

I also restarted the computer but that didn't help.  Any suggestions how to resolve this?

  • Wayne Contello Level 6 Level 6 (15,715 points)

    I would start by moving the current preferences file in your user space and force Numbers to create a new one.

     

    To do this:

    0) Quit Numbers

    1) Go to the preferences Folder for your user space by (from the Finder):

      a) type <command>+g, OR

      b) select the menu item "Go > Go to Folder…"

      Screen shot 2011-09-27 at 9.36.24 AM.png

    2) the type the path: "~/Library/Preferences"

    3) locate the file "com.apple.iWork.Numbers.plist"

    you may also move the file "com.apple.iWork.Numbers.LSSharedFileList.plist"

     

    4) move this file to the desktop (incase we need it again)

    5) start Numbers

  • 4thSpace Level 1 Level 1 (0 points)

    Thanks.  I did that and Numbers opened quickly.  Then I tried to open one of the files I've been working with.  It got to about 3/4 progress opening and stalled.  Now everything in Numbers is back to the spinning rainbow.  You have some idea what is wrong?

  • Wayne Contello Level 6 Level 6 (15,715 points)

    I should have added:

    6) quit Numbers

    7) create anew file, save, quit

    8) open the new file (just as a test)

    9 now open the file you are trying to open (my guess is this file is corrupt)

     

    Can you provide any details regarding the file?  Is it large?  Does it have many calculations?  Di Numbers crash while the file was open?  Anything else "odd" of weird before the the problems started?

     

    Wayne

  • 4thSpace Level 1 Level 1 (0 points)

    I tried the above.  When I went to save the new file, Numbers froze again.  All spinning rainbows and no response.

     

    It started when I was trying to save a file I work with everyday.  The file isn't large.  It is a file I create for each month.  There is a sheet for each weekday (M-F) of that month.  Each sheet has 4 tables.  There is an addition calculation in one column of one of the tables.  Nothing complex going on.

     

    Nothing else weird that I can recall when this started.

  • Wayne Contello Level 6 Level 6 (15,715 points)

    OK.  Then try removing the preference file from your User Space AND from the system:

     

    Add the following steps to remove the System Preferences File:

    0) quit Numbers

    1) go to "/Library/Preferences"

    2) locate the file "com.apple.iWork09.plist"

    3) move this file to the trash or the Desktop (but don't delete yet)

    4) remove the preferences files in your user space as we previously discussed

    5) start numbers

    6) create new file

    7) save file

    8) quit numbers

    9) double click new Numbers file you created in (7)

    10) if that opens, then try opening your "problem" file

  • Level 8 Level 8 (41,790 points)

    Try to run Numbers from an other user account.

    This way we will know if the wrongdoer is in your current user account or if it is among the thousands of files shared by every account.

     

    Yvan KOENIG (VALLAURIS, France) mardi 27 septembre 2011 17:18:18

    iMac 21”5, i7, 2.8 GHz, 4 Gbytes, 1 Tbytes, mac OS X 10.6.8 and 10.7.0

    My iDisk is : <http://public.me.com/koenigyvan>


    Please : Search for questions similar to your own before submitting them to the community

     

     

  • Wayne Contello Level 6 Level 6 (15,715 points)

    If you don't have another user then you will have to create on in the "Accounts" pane of the "Sytem Preferences".  To open "System Preferences" select the menu item "APPLE > System PReferences…"

  • 4thSpace Level 1 Level 1 (0 points)

    Looks like I can now open/close Numbers ok.  Creating a new file, saving, close and quiting Numbers all works.  So I went back to the problem file and it stalled at 3/4 progress.  I let it sit for a while and it opened.  Now all is back to normal and I have some ideas what to do next time this happens.  Thanks.