9 Replies Latest reply: Aug 3, 2012 12:03 PM by btbyd
lorifrommechanicsburg Level 1 Level 1 (0 points)

My ipod has had no issues connecting to wifi and now, all of a sudden, it will not connect.  It shows my network and allows me to join but still no connection.  It worked fine yesterday morning and by the evening it would connect.

 

Any help would be appreciated!


iPod touch, Windows Vista
  • Bophus Level 1 Level 1 (125 points)

    if you can join your network.  then the problem is with your router you will have to reset your router by unplugging for 10 seconds then plugging back in

  • Carolyn Samit Level 10 Level 10 (95,995 points)

    Try resetting.

     

     

    Hold the On/Off Sleep/Wake button and the Home button at the same time for at least ten seconds, until the Apple logo appears.

     

    If that didn't help, tap Settings / General / Reset / Reset Network Settings.

     

    If that didn't help, try here >  iOS: Troubleshooting Wi-Fi networks and connections

  • lorifrommechanicsburg Level 1 Level 1 (0 points)

    Thank you for the tips........however, all other devices work with my router.  It is a new router (just purchased 2 months ago).  I have reset, renewed and restored and nothing works....any other ideas?

  • JimHdk Level 7 Level 7 (27,775 points)

    Your router may not be giving your iPod a valid IP address. Go to Settings > Wifi > your network name and touch the ">" to the right to see the network details. If the IP address starts with 169 or is blank then your router didn't provide an IP address and you won't be able to access the Internet. The 169.254.x.y is a link-local address and is intended only for communication on the local network. The x and y are random numbers. The iPad assigns this address when it receives no IP address from the DHCP server (which is probably your router). This allows communication on a local network with no DHCP server. This is sometimes referred to as an "ad-hoc" network.

     

    Your other devices may continue to function with their existing IP address even if the DHCP daemon in your router is no longer issuing address. The fact that other devices on the network continue to work should not lead to the conclusion that your network router is faultless.

     

    Sometimes the fix can be as simple as restarting your router (remove power to the router for 30 seconds and then restart). This works because the DHCP daemon in your router will be restarted upon a router restart. Next, reset network settings on your iPad (Settings > General > Reset > Reset network settings) and then attempt to connect. In other cases it might be necessary to update the router's firmware with the latest from the manufacturer's support web pages.

     

    If you need more help please give more details on your network, i.e., your router make, model and version, the wifi security being used (WEP, WPA, WPA2), etc.

  • Phonon Level 1 Level 1 (0 points)

    I have had the EXACT same problem with my iPod Touch 4G since at least yesterday.

     

    Before I went on vacation, my iPod was working fine on the home wi-fi. When I came back home (after not using it for a week!), the iPod suddenly was unable to connect to the internet even though it can still "join" the network. I did get a 169. IP address, though.

     

    I restored the iPod and reset network settings, but the problem still didn't go away. I reset the router itself and now the issue has been resolved, at least for now. Hope that helps someone with the same problem!

  • rajfromnew brighton Level 1 Level 1 (0 points)

    I have had similar problems after I changed my DSL modem / wireless router (Actiontec GT784WN).  I have tried the pointers given in the replies - disconnecting the modem / router for 30 secs and conncting back - no luck in connecting the wireless.  There are (5) levels of secuity and encrption in this router - the advice is to set the wireless security at : WPA-WPA2 Personal,   I tried (3) of the other (4) security settings - WPA Pesonal, WPA2 Personal and No Security.   When I remove the security for the wireless, the iPOD works flawlessly.  I did not try the WEP security, since this has (4) keys and I did not want to be bothered by this.  By the way, the original security setting was WPA - WPA2 Personal and yes, I did enter the key without any errors.   The iPOD has strong WiFi signal - but the gear wheel keeps turning without settling down. The info on IP addresses (DHCP): 169.254.187.38 (Invalid address, as I understand!), Subnet Mask: 255.255.0.0, Router ---Blank, DNS---Blank; Search Domain---Blank.   When I was able to connect the iPOD, with no security on the wireless, the following are the figures; IP: 192.168.0.5; Subnet Mask: 255.255.255.0; Router IP address: 192.168.0.1; DNS: 192.168.0.1.205.171.2.25;  Search Domain: Home.   The firmware for the router is the most current one.  I have asked information on the driver status.

     

    Sorry to be so long winded - but like some of the others, am totally frustrated.

     

    Final, question - What is the security level the iPOD can tolerate?  The last router had WEP security.

     

    Thanks

    rajfromnew brighton

  • rajfromnew brighton Level 1 Level 1 (0 points)


    Hi JimHdk - please review my enquiry;  any help will be appreciated

  • Chandrafromaz Level 1 Level 1 (0 points)

    THANK YOU. I did what you had said and my ipod connects now.. If only I had read this last night LOL

  • btbyd Level 1 Level 1 (0 points)

    Thank you!!! Restarting my router worked!! yay!! Thank-you very much!