Previous 1 2 Next 15 Replies Latest reply: Apr 11, 2012 8:55 PM by TheMom1980
WhitR Level 1 Level 1 (0 points)

I work in Pages, but whenever I need to send a document to someone I convert it to Word since most people seem to use MS Word. It's never been a problem, until today. I go to Save As... under the File menu and try to save a document titled "XYZ" as a Word document. But it is giving me this error: "The document “XYZ” could not be exported as “XYZ.doc." That's it. No explanantion, no reason why it can't do something it's always done. I also tried the export route. But, while I don't get an error, the supposedly exported Word document never appears where it should. Did some recent update cause this snafu? Any advice?

Thanks,

Whit


MacBook Pro, Mac OS X (10.6.6)
  • fruhulda Level 6 Level 6 (15,120 points)

    More information, please!

    Are you still on 10.6.6 or have you updated to Lion?

    Has anything else new happened on your computer?

    What else can you tell us? We can't see you computer so good information will help a lot.

  • WhitR Level 1 Level 1 (0 points)

    Sorry. I'm on 10.6.8. I'm using Pages '09 (version 4.0.5). Nothing else has changed, as far as I know.

     

    I discovered a work-around by going to the Pages document on the desktop and manually adding a ".doc" to the file name. That seemed to do the trick. But I'd still like to figure out why my Save As... feature is no longer working.

  • WhitR Level 1 Level 1 (0 points)

    Forget it! I just realized that work-around failed! So, I have no way of exporting a Pages doc as a Word doc. Can someone offer some advice?

  • PeterBreis0807 Level 7 Level 7 (32,935 points)

    Try and isolate the problem.

     

    Do any of your Exports work such as rtf, txt, pdf?

     

    Just changing a .pages extension was never going to work, the formats are completely different.

     

    Is it possible you have something incompatible added into your Pages document. Or have added passwording?

     

    Do all your documents have the same problem?

     

    Try a fresh unedited template.

     

    Try starting up from a new User.

     

    Vary the circumstances and see if there is one which does let you export which will help narrow down the issue.

     

    Peter

  • Dale Gillard Level 5 Level 5 (4,365 points)

    Someone else had this problem and it was because they were saving a copy to a networked drive. Where are you saving your documents?

     

    Can't export Word docs to network drive

     

    Also, have you moved Pages/iWork from the /Applications folder or renamed Pages?

     

    Lastly, I'm wondering if this is a permissions problem:

    1. Can you save a document in a Word format to other folders?
    2. Have you run Disk Utility and had it Repair Disk Permissions?
    3. What permissions are set for the folder you're saving the document to? That is, from the Finder click once on the folder, choose the File > Get Info menu command and check you have Read Write access.
  • WhitR Level 1 Level 1 (0 points)

    Thanks, Peter. I can export as other document types (I did so successfully as pdf and rtf). It's only exporting as a Word document that is no longer working. I tried new documents; same problem. I haven't changed anything that I know of (no Pages changes, no passwording).

     

    Dale, I'm just trying to save to my desktop. I tried other folders, but it didn't work either. I haven't renamed Pages or moved it from the Applications folder. It's a mystery why this has suddenly occurred. Something is to blame, I'm just not sure what it is yet.

  • fruhulda Level 6 Level 6 (15,120 points)

    Try using Pages in a new account. You can create one in System Preferences > Accounts.

    If it works in the new account something is wrong in your old acount. Often it helps to ditch the com.apple.iwork.pages.plist in Users > your name > Library > Preferences folder

    Deleteing the plist should be done when Pages is quitted.

     

    If it doesn't work in the new account uninstall Pages/ iWork 09. you can download Yvan's script here

     

    <http://public.me.com/koenigyvan>

    Download :

    For_iWork:iWork '09:uninstall iWork '09.zip

     

    Expand the archive and run the script.

  • Level 8 Level 8 (41,790 points)

    Here are my two cents.

     

    The resources defining the file formats which Pages may import or export are stored in the file :

     

    Macintosh HD:Applications:iWork '09:Pages.app:Contents:Info.plist

     

    Assuming that you didn't installed the Developer tools, go to my iDisk (address below)

    Download :

     

    Pref Setter.app.zip

     

    Unpack the archive.

    Open the file "Info.plist" with Pref Setter.

    Open the entry entitled :  CFBundleDocumentsTypes

    Open the items 9, 10, 11, 12

    The normal contents is :

     

    2011-10-01-17.42.27.jpg

     

    Double check the parameters available for items 9 & 10.

     

    What you get may be linked to some oddity in these resources.

     

    Yvan KOENIG (VALLAURIS, France) samedi 1 octobre 2011 18:00:23

    iMac 21”5, i7, 2.8 GHz, 4 Gbytes, 1 Tbytes, mac OS X 10.6.8 and 10.7.0

    My iDisk is : <http://public.me.com/koenigyvan>


    Please : Search for questions similar to your own before submitting them to the community

     

     

  • guyvitetta Level 1 Level 1 (0 points)

    Have you tried simply going to "share' on the menu bar, then select "send via mail" which gives you 3 options, pages, word and pdf.  Select "word" and it will send your doc as word to the recipient.  That has always worked for me.  I dont even have word on my laptop, and never have a problem with word files opening or sending.

     

    Guy Vitetta

  • ARRichards Level 1 Level 1 (0 points)

    I am having the exact same problem today, never had it before.  Have tried saving different documents to different locations, always get the error messages.  I tried the "save as copy" as well as exporting, and the "share" option, none will work. 

     

    Have not yet tried deleting and reinstalling the application, but will try that after getting back to a faster internet connection.

  • Level 8 Level 8 (41,790 points)

    Hello ARRichard

     

    May you tell the version number of the application which you are running

    and the version number of the Operating System in use ?

     

    PS :

    I have an idea : check if the filename contains slashes (/) or colon (:).

    If you are running Lion, it may explain what you got.

     

    Yvan KOENIG (VALLAURIS, France) samedi 1 octobre 2011 23:21:06

    iMac 21”5, i7, 2.8 GHz, 4 Gbytes, 1 Tbytes, mac OS X 10.6.8 and 10.7.0

    My iDisk is : <http://public.me.com/koenigyvan>


    Please : Search for questions similar to your own before submitting them to the community

     

     

  • ARRichards Level 1 Level 1 (0 points)

    My pages is version 4.1, running OS X 10.6.8.  I tried a couple different filenames to see if that was affecting it, but none had slashes or colons in them. 

  • PeterBreis0807 Level 7 Level 7 (32,935 points)

    You have not said you have tried this from a new user.

     

    Peter

  • Jon Agirre Level 1 Level 1 (0 points)

    Reboot your machine and try again. I know it sounds dumb as h3ll, but it's the quickest way to solve this issue.

Previous 1 2 Next