Previous 1 2 Next 19 Replies Latest reply: Nov 4, 2013 12:05 AM by MacBraveheart
MacBraveheart Level 1 (130 points)

I know that the news is likely to be bad but here is hoping that I will get some feedback about "what next" in terms of what is possible if not possible to mount with a fix of some sort.


The problem:

I have a Western Digital My Book 500GB Firewire/eSATA/USB 2 Studio Edition external hard drive which is daisy-chained with 7 other hard drives, mostly WD and one Lacie which is the only drive to not mount.


I have done all the checks in that I have disconnected it from the daisy chain and followed the prescribed start up by unplugging, waiting, plugging it into direct power socket, pressing the rear button (also tried it with not pressing it), then plugging in Firewire/USB cables (in turn of course) into the drive and then only into the freshly restarted MacBook Pro (which is also mains connected) running OSX10.6.8.


Nothing will make the drive mount.


Replaced it into the daisy-chain, tried again with full power-cycle of the entire chain, they boot up as expected, the unmounted one remains visible in Disk Utility, checks out fine, repairs fine (since there is nothing TO repair) and still will not mount.


Unlike most (but not all) it has an Apple Partition Map, not a Master Boot Record or GUID Partition Table, if that is even relevant.  The other (WD) drive with the same partition map is fine.



The question:

Now having done my research I am very disheartened to note that it is likely to be a lost cause.


I cannot afford to lose the data on there.  It contains 480GB+ of film data which I was in the process of "mirroring" (but since I have 6TB of data to mirror that is a big task and I was working in strict order and only upto 5 with this one being 9 in a set of 13...) and I am keen to learn what I can possibly do to rescue this terrible situation.


Can I use firmware to "fix" its unmountability?  Can I send it somewhere to have the data extracted?  Can such data even be accessed, given that Disk Utility can see the drive but cannot "see" the files contained therein?


Please and thank you.

13, Mac OS X (10.6.8), also DVCPRO HD Panasonic HVX201
  • WZZZ Level 6 (12,855 points)

    I had success with a friend's WD external which had stopped mounting. The drive itself was fine. I removed it from the WD enclosure, which had gone bad (I think the WD external chipsets are of very poor quality) and put it in one of these. All the data was still there.


    Getting it out wasn't difficult. The plastic cover has to be pried open -- just work slowly and carefully; you don't want to bang or jar the drive. Putting it in the OWC enclosure took all of twenty minutes or less.

  • MacBraveheart Level 1 (130 points)

    You can never know how much of a relief that is to read!  Thank you from the bottom of my heart.


    I don't know enough about the physicality of it all so I wasn't sure if it was a bit like my Mac's hard drive which could be put into a "caddy" and then mounted that way.  Having "endured" that being done once before.


    I guess that if there is no magical solution to getting it to mount without resorting to physically taking it apart then I will at least have this solution!  Again- thank you.


    Can I ask you- will all types of external drives fit into a general caddy, or are there as many of these as there are types of drives to begin with?  Just that I have lost another drive (before my film-making days and reason WHY I am so consequential, if slow, about backing up the back-up), a Lacie (Porsche) which might be nice to recover if I can get the hang of it.  Mind you- that one is a bit more "substantial" to take apart...  *rolls eyes*

  • WZZZ Level 6 (12,855 points)

    I don't know how old the WD external is. I would think it's extremely unlikely its an ATA/IDE drive; I don't think they even came as big as 500GB, probably much smalller. Those were discontinued a long time ago. It's almost certainly a SATA 3.5" drive. But when I did this, I called WD first to confirm that the drive was SATA 3.5". Any SATA 3.5" drive, no matter what brand, will work with this enclosure.


    If you do a search for WD MyBook "take apart" or "remove drive," you will get a number of hits with illustrated directions for removal. You might not find directions specifically for your model, but what you will find, even with variations, will give you the general idea. You just pry open the plastic case deliberately with a flat blade screwdriver and then proceed to remove the various screws. The whole operation took about a half hour.


    Once out, you just slide the drive into the OWC enclosure -- no connectors to worry about -- and close it back up. It couldn't be simpler.


    EDIT: to prevent static electriciy from possibly wrecking the drive, just be careful not to touch the drive contacts or the circuit board.


    Message was edited by: WZZZ

  • MacBraveheart Level 1 (130 points)

    Yes, thanks for confirming this.


    I am in the UK and had a look at the enclosure you recommended and don't see it here but have seen others which seem to be similarly "easy" to use.


    I guess as long as I make sure that it is for the SATA version of my Studio Edition I should be fine.  Here these retail for about £19 which is not impossible to bear, especially when you stack that up against a pro-recovery job where they charge by the GB and have been known to charge for £450 for the same thing.


    Again- thank you for your input.  It has saved my weekend. 

  • WZZZ Level 6 (12,855 points)

    One more thing, if you're still reading this. Try getting an enclosure with an Oxford chipset (probably Oxford 934.) They are known for reliability and their compatibility with Macs.

  • MacBraveheart Level 1 (130 points)

    I am hanging on your every word.  Thanks for that.  I like recommendation for reliability and compatibility.  I will look to see what I can find in the UK which relates to your recommendations.  Thank you.


    Hopefully your advice will give others with this issue some hope because there are many threads on the net which merely condemn the OPs to the end.

  • WZZZ Level 6 (12,855 points)

    You're welcome. Naturally, you do understand there's a really excellent chance, based on my own experience and that the My Book enclosures are well known for this, that the reason it won't mount is due to a failure of the enclosure. That your drive is seen by DU also bodes well for success. But you should know there's a very small chance -- I'd bet against it, though -- that it's the drive and this solution won't work.


    Please post back when you do this to let me know the result.

  • MacBraveheart Level 1 (130 points)

    Yes, I do understand the chances are only very good but not absolute. 


    I have had a few fail in their time, internal and external and was not too concerned (except that I need the data it contains by Monday at the latest as I am actually doing a showreel for my daughter to hand to a client then).  "C'est la vie", as they say.


    And certainly- I will post back for our collective benefit. 

  • MacBraveheart Level 1 (130 points)

    Nothing to report yet- I have been unable to purchase your recommended "caddy", WZZZ.  I bought a cheap one after reviewing it carefully and noting that the only "one star" rating of import was a loose wire.  Would you believe it- the one I received last week had JUST that problem!?!  Anyway- I have requested a replacement because I thought that if I cannot get one which comes recommended then I don't want to spend the earth on getting one which might not do the job well enough for long enough.


    Now all I really want to do is to get that data off the drive and then consider something like disks for the really vital stuff for ALL my externals.  Just so stressful.


    I will post as soon as I have done this.

  • WZZZ Level 6 (12,855 points)

    Spend a little more and get something decent that will last.

  • MacBraveheart Level 1 (130 points)

    Annoyingly I haven't got around to this before now only to discover the "caddy" I have wont fit.  It has completely the wrong connections (and on top of it all- three of them to the MB's one).  Meh.


    Back to the drawing board. 


    I will need to begin again with the research as over a year has passed now. 

  • MacBraveheart Level 1 (130 points)

    Update:  installed into the correct enclosure and STILL wont mount.  Next step is to use some means of pulling the data off it and placing to new drive.  Meh...

  • bruxxx Level 1 (30 points)

    You don't mention whether the drive is visible in Disk Utility?  if not, probably the cable, power supply or controller.


    When you "did all the checks" did you swap out all the cables?


    Did you call WD support, these things are under support for a long time, if the box failed they will send you a new one and you can just take the old disk and put it inside and it will work ... if it has not had corruption.  Ask them also to send a new power supply.


    I do not think you can just take the drive out and put it in another enclosure, the format of the drive is often different from a bare drive in a system.


    One thing you might try it to take the internal drive out, if you can, and plop in a new one, closest you can get ... it's only 500GB ... the closest WD drives of the same line, and see if the box will work ... then you would know only if it works that your disk is what is bad.

  • MacBraveheart Level 1 (130 points)

    Thanks for this.  Yes, as mentioned in the OP it is visible in Disk Utility but would not mount.


    I bit the bullet and bought data recovery software, recovered the data and then left the "re-cased" drive in its new home and reformatted it.


    I am now using it for back-up, no problem.

Previous 1 2 Next