1 Reply Latest reply: Oct 2, 2011 1:33 PM by elikness
David Strait Level 2 Level 2 (175 points)

I use iMovie 11 (9.0.4) and have a problem with a few (but not most) of my movie projects. After publishing the final movie to iTunes, I tried to re-edit the final movies to make minor tweaks. As soon as I make the first edit, I get the message that the movie will need to be re-published and I click "OK." The movie then loses all the audio and is completely silent. This includes audio from clips and added music.

 

Fortunately, I first duplicated the project, so my original movie project is still intact. I have tried several times with the same result (on the same projects). Most other projects do not have this problem.

 

Any ideas?

 

Thanks,

Dave


PowerMac, Mac OS X (10.6.7), 2009 2.66 GHz 8 Core, 16 GB RAM
  • 1. Re: Audio disappears from finalized project when re-edited
    elikness Level 4 Level 4 (2,635 points)

    Have you done any preventative maintenance stuff like deleting preferences or repairing disk permissions? It's not that complicated and it sometimes works for projects that don't have corrupted files in them. Just go to

     

    Mac HD > Users > (your home folder) > Library > Preferences > com.apple.iMovieApp.plist (move it to the trash)

     

    And fire up Disk Utility and do a quick Repair Disk Permissions, reboot and open iMovie and see if the project's still lost the audio track.

     

    It almost sounds like it's messing up the Autosave it peforms in the background as you work on the project. My feeling is you could also test this by opening the project, make one edit. Quit iMovie. Re-open iMovie and see if it's also keeping track of edits properly.