1 Reply Latest reply: Dec 21, 2011 9:45 AM by beckalodeon
Artminibus Level 1 Level 1 (0 points)

I recently got this error while trying to play one of my songs, and solved it, so am posting to help others who might have hit this.

 

Here's the symptom:

  1. Click on a song to play it, and get a message saying you need to authorize to play it.
  2. Authorize, and then receive a message saying the computer is already authorized
  3. ...But, the song still won't play.

 

Deauthorizing all computers, reinstalling iTunes don't help.

 

Here's what the problem was for me: the song had been purchased with a different iTunes account, and so needed to be authorized under that account.  I had bought it under the iTunes account "fred" rather than my normal "fred@mac.com", but was trying to authorize it using "fred@mac.com".

 

You can check the account that you purchased the song under in the Options tab on the song info.  If it is different than the account you're currently logged in as, sign in with the song's account and the authorization should work.

  • beckalodeon Level 1 Level 1 (0 points)

    The solution above didn't work for me. However, using Get Info on the song in question, I noticed that the account information was correct, but there was no "Purchased By:" entry. This was pretty strange, given that I'd purchased the entire album, and all the other songs had this entry.

     

    Anyway, long story short, on a whim I tried deleting the song (to Trash) and downloading it again from iCloud - the newly-downloaded file had the Purchased By line and played fine.

     

    Odd, but there you have it.