Previous 1 2 Next 16 Replies Latest reply: Feb 22, 2013 3:38 AM by zaco88
mjconn75 Level 1 (0 points)

Anyone know why a single keyboard shortcut would quit working? My ⌘-\ shortcut for stack pick has stopped functioning. It's still listed as active in the command menu for shortcuts though. The ⌘-\ is the only keyboard shortcut that has quit working for me too.

Macbook Pro (early 2011), Mac OS X (10.7), 2.2 GHz Intel Core i7, 8gb Ram
  • Kirby Krieger Level 6 (12,510 points)

    Does the problem persist after re-booting?  Have you tried any trouble-shooting?

  • léonie Level 10 (90,614 points)

    You also may wish to have a look at the "System Preferences" -> Keyboard -> Keyboard Shortcuts -

    Sub Panel. Click on all the Applications listed in the left column and have a look if a newly installed application or Service has stolen that key-binding.

  • mjconn75 Level 1 (0 points)

    I have rebooted and repaired library (just because) but neither solved the issue.

  • mjconn75 Level 1 (0 points)

    Nice thought. I hadn't thought of that, but nothing has stolen it.


    I keyword in the bottom toolbar by typing in keywords I want into the input window. Too often I will forget I have left the input field for keywording and begin to type, which then actually activates a bunch of whatever shortcuts I hit related to the the keys I press.


    That make sense? That is what happened last time the ⌘-\ shortcut worked. Is there a button that would kill or shut-off a shortcut?

  • Frank Caggiano Level 7 (25,715 points)

    What happend when you try to use the shortcut in Aperture? Screen flash, ding sound, nothing?


    And just to be safe you have a stack open and you have an image selected when you try to use the shortcut?


    Finally if you go to Stacks->Pick and set the stack pick from the menu it works?

  • mjconn75 Level 1 (0 points)
    • when I try, nothing happens. No noises, flashes. Just nothing.
    • I do.
    • yes, the menu drop-down method works.
  • Frank Caggiano Level 7 (25,715 points)

    If you go to the command editor Aperture->Commands->Customize what is shown in the pulldown in the upper left part of the screen?


    Screen shot 2011-10-05 at 10-05 11.56.47.png

    Could you include a screen shot like this one of your system?

  • mjconn75 Level 1 (0 points)

    I do have a Custom Command Set on, but I have tried converting back to the default Command Set and the issue is still there.



    Oddly, I can't get this discussion to let me post the screen shot. "add image" won't activate. ?

  • mjconn75 Level 1 (0 points)

    Ok. I have a troubleshooting acct on the computer that is untouched and I use it for diagnosing problems.


    The shortcut does work in Aperture in that acct. So, help me figure out what that means. Is there a program somewhere stealing the shortcut? If so it's not listed in the preferences - Keyboard shortcut menu.


    What else?

  • Frank Caggiano Level 7 (25,715 points)

    OK so did the problem start after you made the Custom Command set?


    If it's working in the other account I would start by moving the preference file out and see it that resolves it.


    The preference file is in your home:library:Preferences folder and is Just drag that file to the desktop (with Aperture closed) and restart Aperture.

  • léonie Level 10 (90,614 points)

    If the shortcut works from a different account, that indicates that something related to your account is to blame, either some preference settings in your user library, or less likely, your Aperture Library (that is, if you made the test from your test account with a different Aperture library).

    So I would suggest to trash the file

    /Users/your_user_name/Library/Preferences/, and if that does not help, to repair your Aperture Library. (Make sure, you have a backup of both, before you try that.

  • mjconn75 Level 1 (0 points)

    Ok. Appreciate the effort here.


    Things I have tried now.


    • Started with exporting the Default Command set from the troubleshooting acct (in which the shortcut works) and importing to my copmuter acct and Aperture. Didn't solve it.
    • I shut Aperture, deleted the file and the file, and restarted Aperture. Didn't solve it.
    • Did a complete rebuild of my library. Didn't solve it.


    I'm gettting to be at a big loss here and running out of ideas. What else do you have?

  • mjconn75 Level 1 (0 points)

    Well, I hadn't tried rebooting the computer again yet. I just did and the problem is solved! The ⌘-\ is back.


    Thanks for the help. I don't know what solved it but problably the deletion.



  • scooper4711 Level 1 (0 points)

    I had the exact same issue, however it was a different cause. Since googling for "aperture keyboard shortcut quit working" returns this page as #1, I thought I'd document what fixed it for me.

    I had installed 1password. An otherwise excellent program, but it registers its keyboard shortcut in a way that it doesn't show up in Keyboard Preferences, but it is active absoluetely everywhere.


    Here's how I found out about it for others to troubleshoot: I opened console. Every time I pressed command-\, I got the message: Failed to send 'activate' to '', client not connected. The logging program was called "1PasswordAgent", so it was simple to figure out from there. Add this to your box of tricks when things aren't working - look in Console.


    Anyhow - after I got rid of that keyboard shortcut in 1password and logged out/back in, my Aperture keyboard shortcut started working again.


    Hope that this helps someone else in the future. If so, please reply to this post to keep it the #1 search result in google.

Previous 1 2 Next