2 Replies Latest reply: Oct 8, 2011 6:02 AM by SailBVI
SailBVI Level 1 (0 points)

I setup the Airport Express with speakers to connect to my Airport Extreme network and it works fine using Airplay on my iPhone. If I take the AirPort Express station elsewhere I'm not able to connect.  How do I configure Airport Express to work when connected to the home Extreme network and by itself elsewhere?

Airport Express
  • Tesserax Level 9 (50,020 points)

    Two things: 1) Take advantage of the fact that your AirPort can store up to five configuration profiles. I would suggest that you configure one for your home network and another for a stand-alone AirPlay configuration ...


    You will need to use the AirPort Utility, located in Applications/Utilities to create & save these profiles.


    To create a new profile:

    • Open AirPort Utility, select your AX from the list, and then, click "Manual Setup."
    • From the AirPort Utility menu, select "Base Station," and then "Manage Profiles."
    • Click "+" to create a new profile; give it a name, and then, click OK.
    • Set options, such as network name, passwords, Internet connection method, etc.
    • When done setting the options, click Update.


    To switch profiles:

    • Open the AirPort Utility, select your AX from the list, and then, click "Manual Setup."
    • From the AirPort Utility menu, select "Base Station," and then "Manage Profiles."
    • Click on the desired profile, and then, click OK to apply the new profile and restart the AX. Just remember to switch to the desired configuration profile before removing power from the AX.

    ... and 2) The following would be the basic configuration to use your AirPort stand-alone (no Internet connection) for AirPlay.


    The AX would not get a Public IP address, but it would have a Private IP address of ... and it would be providing wireless clients connected to it with Private IP addresses in the - range.


    I just verified that this works. Please double-check your settings to see if you may have missed something.


    AirPort Utility > Select the AX > Manual Setup > AirPort > Wireless

    • Wireless Mode: Create a wireless network
    • Wireless Network Name: <enter a desired Network Name or SSID>
    • Radio Mode: <leave the default or select a desired radio mode>
    • Channel: Automatic
    • Wireless Security: <select the desired wireless security type>


    Internet > Internet Connection

    • Connect Using: Ethernet
    • Connection Sharing: Distribute a range of IP addresses


    Internet > TCP/IP

    • Configure IPv4: Manually
    • IP Address:
    • Subnet Mask:
    • Router Address:
    • DNS Server(s): <leave blank>
    • Domain Name: <leave blank>


    Internet > DHCP

    • DHCP Beginning Address: <leave default or change to a desired starting address>
    • DHCP Ending Address: <leave default or change to a desired ending address>



    • Enable AirTunes (checked>
    • iTunes Speaker Name: <leave default or enter a desired speaker name>


    Advanced > Logging & Statistics

    • Allow SNMP (unchecked)


    Your AX will still report at least three errors: 1) Configuration of WAN, 2) SNMP over WAN, and 3) Double NAT. These can all be safely ignored to stop the AX's status light from flashing amber in this configuration.



  • SailBVI Level 1 (0 points)

    Thanks.  IT seems to be working fine at home this way. I didn't know about the multiple profiles.  I'm am able to connect to the 'new' independent AE network and Airplay finds the speakers. Real test will be later when I set it up at the hotel.