1 Reply Latest reply: Oct 10, 2011 11:28 AM by ovelky
ovelky Level 1 Level 1 (0 points)

I just installed Snow Leopard on my Intel Macbook 13" (Model Identifier 1.1, MA472LL/A Black) but now my Samsung Laser Printer (model ML-2510) will not work. The printer is an older one (purchased four or five years ago).

 

- I tried reinstalling the original printer software.

- I downloaded and installed the latest Drivers from Samsung's website.

- And I tried resetting the print & fax print queue, adding the driver back in, but all with no joy.

 

When trying to print, I get an error message saying the software was improperly installed, but that's bogus because I followed the install instructions to the letter and the Samsung ML-2510 Driver shows up as an option in the system.

I feel it is a Driver problem, because I also tried using the generic laser printer driver from the system and that driver made an attempt to work (the printer started "powering up") but then it stopped as well.

 

Can anyone help me with this, please? . . . Thanks!

  • 1. Re: I just installed Snow Leopard, now my Laser Printer will not work
    ovelky Level 1 Level 1 (0 points)

    Never mind . . . I just found my answer! It was only after I submitted the question that possible answers came up from a previous discussion (I don't know why it didn't show up when I searched for an answer prior to posting). Nevertheless, for the benefit of anyone else with the problem, I found the answer here:

     

    https://discussions.apple.com/message/10120099#10120099

     

    And the new driver that fixed the issue was posted on that discussion with this link:

    http://www.samsung.com/uk/support/detail/supportPrdDetail.do?menu=SP01&prd_ia_cd =&prd_mdl_cd=&prd_mdl_name=ML-2510

     

    Funny that this driver comes from the "UK" (British) version of Samsung's site. It didn't seem to appear on the U.S. version when I tried downloading drivers last week. I guess it's possible that I didn't follow the installation steps in the proper order somehow (even thought I tried it several times.)

     

    But, if you're interested, the successful procedure I used was as follows:

    (1) I downloaded the new print driver but did not install it, leaving it on my desktop.

    (2) I started the computer in Safe Mode (which might not have been necessary but I did it anyway) then brought up the System Preferences/Printing & Fax Preferences dialogue box, right-clicked on it and chose "Reset Print Queue" making sure there were no printers in the box.

    (3) Then I restarted the computer normally and installed the new driver.

    (4) I reopened the Printing & Fax Preference Pane and checked to make sure the new driver was the only one in the box. It was.

    (5) I opened a plain text document and chose Print. VOILA!—After a slower than usual first start (only a few extra seconds) it printed perfectly and has been working properly ever since.