1 Reply Latest reply: Jan 23, 2012 9:43 AM by jordifromaustin
philippergo Level 1 Level 1 (5 points)

hello community,

 

does anyone know a way change the language lion server uses for ical invitations to external adresses?

 

ical server uses english for invitations as default, which is fine for me, but not for our german customers.

 

css and html can be edited without problems, but it is the variables.

 

the templates for invitations and cancelations can be found at

 

/usr/share/caldavd/share/email_templates/invite.html

 

and

 

/usr/share/caldavd/share/email_templates/cancel.html

 

 

the templates use variables, eg.

 

%(summary)s


%(inviteLabel)s

 

etc as shown in the picture.

 


source.png

 

does anybody have some experience with customizing the invitation? how can one change the variables?

 

system is lion server 10.7.1 on mac pro.

 

any help would be great!

 

thanks in advance!

 


philipp

 

 

 



severals MBPs, MacPros, Mac Server, 10.6.8 and 10.7.1
  • 1. Re: how to change language for ical server invitations?
    jordifromaustin Level 1 Level 1 (0 points)

    I think I have the solution to this issue.

     

    What Happened to me:

     

    When I send invitations to my friends, they received the invitations in Japanese (I was in Japan for 2 years, that's when I created the MobileMe account, perhaps it is related).

     

    I changed the language of iCloud (in User Name -> Preferences, after signing in into http://www.icloud.com). The language was already "English".

     

    But the problem persisted:

     

    My Solution:

     

    Go to: https://appleid.apple.com, (Manage Your Account, once signed in, go to "Language & Preferences")

     

    There, you can type in the language for your inviations (English). Check the primary and the alternate mail addresses just in case. Sometimes, if the primary mail address is not iCloud or me.com, the invitations are not sent propperly.

     

    After that, you can save your settings. The invitations are sent in English.

     

    Problem solved on my side.