Previous 1 2 3 4 5 Next 62 Replies Latest reply: Dec 5, 2013 7:15 PM by rr100 Go to original post
  • Jim Knopf Level 3 (940 points)

    Excellent way to solve the problem - thanx a lot to everyone and JofArnold for the "easy" way.


    Only one little note for those not so apt in Terminal but with the same problem. These are the two lines you have to call in Terminal to move the two culprits to your desktop:


    mv /Volumes/[YOUR LION-DISK]/System/Library/Extensions/PGPwde.kext /Volumes/[YOUR LION-DISK]/Users/[YOUR USER-SHORTNAME]/Desktop


    mv /Volumes/[YOUR LION-DISK]/Library/PriviledgedHelperTools/com.pgp.framework.PGPwde /Volumes/[YOUR LION-DISK]/Users/[YOUR USER-SHORTNAME]/Desktop



    Jim Knopf

  • cypher123 Level 1 (0 points)

    i ditched PGP long time ago due to the constant problems when i updated the system.




    right now i have exact same problem you guys are having on a mid 2011 macbook air that has NEVER had PGP installed. it has apples own Filevault 2 turned ON....anyone else having this problem?


    i can start in recovery mode and i have even re-installed lion via recovery mode already without any luck.


    when it boot after re-installing lion it prompt me for the apple filevault pass..i type it and then i get the same gray screen with circle and slash over and its hanging there forever


    any ideas on what to try next?




  • JofArnold Level 1 (5 points)

    I ditched PGP Whole Disk Encryption, BUT there's still some PGP software on there.


    To see for yourself if that's the case on startup, do cmd+V for the visual boot mode (loads of commands scroll past on a black screen - it's used for debugging) and wait for it to freeze. Then scan through last few lines - ther's a pretty good chance it will have "PGP" somewhere. If so, follow the advice above. If not, I can't help you - really hope you find a solution!


    BTW the reason it happened to me is that Time Machine transferred PGP from another machine. So even though I use FileVault2, the PGP app was still there.

  • JofArnold Level 1 (5 points)

    UPDATE: PGP's gui uninstaller doesn't work for me (see ik8sqi2's wiki link above for more info) So for now I'm just keeping those files in their new out-of-the-way position until I find the time to go through and remove everything. Symantec have certainly made themselves no new friends today...

  • AppleStar Level 1 (45 points)

    Well,I would say you start in all usual places, where bad coded software products left their tracks:


    Kernel Extensions in





    mayby even




    Compare the content to a fully functional 10.7.2 system - since it's becomming harder to understand which ones are from Apple and which ones are not.


    In general I recommend a great tool for checking on extras within the Library folder :

  • hejish Level 1 (0 points)

    I did this but the PGP cleanup gui tools had already been deleted... So I manually found all the items in the list provided above and deleted them, rebooted, and I think I'm all good.  Thank you very much.

  • cypher123 Level 1 (0 points)

    oki... found the problem.

    i overlooked that i had to cd to /Volumes/hardrivename as the / files are the files in the recovery volume...hehe

    so i found :

      1. /Volumes/HD/System/Library/Extensions/PGPwde.kext
      2. /Volumes/HD/Library/PriviledgedHelperTools/com.pgp.framework.PGPwde

    and deleted them. how they ended up there is a mystery but it must have been via timemachine (that i dont use any more) or maybe even .me syncs? or i might have moved some folders from my desktop compter in past that i dont remember.  ...pgp desktop app was not installed on the computer at all and i will never get close to that again now that i hopefully have gotten it all removed once and for all.

  everything works fine again! thanks a lot for the help!



  • billfinch Level 1 (0 points)

    @Christopher Graham5:


    I had the same issues and went through all of these files one by one and removed them, then was able to boot normally.


    Thanks for the info and suggestions from all!

  • SpacePirate Level 1 (0 points)

    Removing the latter two did the trick; I was able to complete this in the recovery partition as per JofArnold's reply below as well... Thanks for the assist!


    To clean up, run the following in Terminal after a successful boot:


    sudo /Applications/ --uid 501


    That will run the PGP uninstaller script as the primary user, and clean up the rest of the PGP files.

  • MacgyverOne Level 1 (0 points)

    Ugh, these PGP conflict/errors are getting old.  Following the discussions above did the trick, the following two files seemed key to my recovery from the boot error.





    Thanks for all the help from everyone! 

  • dmojavensis Level 1 (0 points)

    ik8sqi2, thank you so much for the solution. It worked for me. Phew! Just like you, I thought I've gotten rid of all those bloody PGP files a while ago, but it seems like one can't quite fully get rid of it .


    For those less familiar with Lion (like I was just an hour ago), you can mount your root partition using Disk Utility (even if it's encrypted with Filevault)  once you boot off of a recovery partition (hold Cmd-r when powering on your Mac). This is obvious once you know about it, but it took me a little while to figure out.

  • kbata Level 1 (0 points)

    I didn't even realize that I had PGP installed.  Just went thru removing all the peices using all the instructions on this thread.

    My problem now is that after I got everything working again, before finding this thread,  with a fresh install and then pulling my data in from a backup drive I tried to use Filevault again.  This time instead of going thru the whole install, then pull the data in process I used disk utility to turn encription off on my boot drive.  As a side effect of that process my backup drive is no longer mountable.

    Invalid Volume Header @ 0: incorrect block type

    Invalid Volume Header @ 1999736188416: I/O error

    disk2 is not a CoreStorage volume


    Any sugestions for fixing the backup drive without wiping it?

  • murray1784 Level 1 (0 points)

    You left a step out when you erased your disk.  You needed to setup the disk with a GUID partition.  As far as I know the only way to fix it is to go back and erase the disk and do another restore.


    If it's any consolation, I made the same mistake even though I knew the correct procedure.

  • kbata Level 1 (0 points)

    And I thought I was done with all this.  At least after removing all that PGP stuff and rebooting my backup drive is working again.  Sounds like a fun project for this weekend.  This time I think I'll save the important things in icloud so I don't have to sweat it out durring that long coundown when restoring.

  • Shock Doc Level 1 (10 points)

    Wow! This is scary stuff.  So I had better be REAL careful before upgrading to Lion.  Uninstalling PGP 10.2.0 even after decrpting everything using the uninstaller BEFORE upgrading to Lion may not even work. 


    Thanks for the warning and Fix.  I will make sure I have the necessary time, food and alcoholic beverages before attempting!  Or just chicken out all together!