Previous 1 2 3 Next 62 Replies Latest reply: Dec 5, 2013 7:15 PM by rr100
SpacePirate Level 1 Level 1 (0 points)

Hi all,

 

I have a Macbook Air (mid-2011) system I use for preproduction testing. Previously, I had installed 10.7.1 and filevaulted the system. Today, after installing the 10.7.2 update via Software Update, the machine booted to the Do not proceed symbol (grey circle slash). As this is a MacBook Air, there's not a really easy way to target disk mode to another machine (this is my only Thunderbolt system). I determined I was able to boot to Verbose/Single user mode by holding the key combination prior to the encryption screen, which provided the following diagnostic output:

 

Still waiting for root device

 

Precisely as expected, based on my previous experience with PGP'd macs.

 

On PGP, I was able to mount disk0s3 from the another machine's Terminal app, delete boot.efi from the Boot OS X partition, and replace it with a renamed pgpboot.efi. Digging around in a similar fashion with Filevault, I was able to find a similar recovery partition at disk0s3, but no similar boot.efi files for replacement.

 

Anyone have any thoughts on recover here? No data loss for me on this system, but I just wanted to get this out there for anyone having similar issues.

 

Thanks!

Mike

  • murray1784 Level 1 Level 1 (0 points)

    I'm working through upgrade problems on my FileVaulted system.

     

    Try restarting while holding command-R down to get to recovery-HD mode.  Reload Lyon from there (requires internet connection for the download).  It will ask for the FileVault unlock key to gain access to the to the disk before it will proceed.

  • murray1784 Level 1 Level 1 (0 points)

    Do't bother trying my last suggestion, it didn't work.

  • ik8sqi2 Level 1 Level 1 (35 points)

    Arghhhh.. Same exact issue here on a Macbook Pro (2011). FileVaulted filesystem. PGP installed (but drive not encrypted with PGP WDE, just with FileVault2). Updated to 10.7.2. Same boot issues. Attached is screenshot for verbose boot.... I get prompted to enter the FileVault password, but afterwards this happens...

    /___sbsstatic___/migration-images/163/16335120-1.jpg

  • dlb029 Level 1 Level 1 (0 points)

    Same issue here, PGP installed but FileVault used for WDE. I really hope this doesn't end up being PGP screwing us over again on an OS update.

  • murray1784 Level 1 Level 1 (0 points)

    I have PGP as well, but stopped using it's "Whole Disk Encryption" when I upgraded to Lyon.

  • Christopher Graham5 Level 1 Level 1 (15 points)

    Okay, I also have the latest PGP Desktop installed, not using PGP WDE at all, never have. Just encrypting individual files when I need to send via email.

     

    i did get to the point of the picture above, which was progress in my case by going in via the recovery terminal and MOVING not REMOVING these files


    /Library/Receipts/PGP\ Desktop.pkg/
    /Library/Application\ Support/PGP/
    /Library/Contextual\ Menu\ Items/PGPcontext.plugin/
    /Library/Extensions/PGPdiskDriver.kext/
    /Library/Extensions/PGPnke.kext/
    /Library/Frameworks/PGP.framework/
    /Library/Frameworks/PGPclient.framework/
    /Library/Frameworks/PGPproxy.framework/
    /Library/Frameworks/PGPui.framework/
    /Library/Frameworks/PGPwde.framework/
    /Library/Mail/Bundles/PGP*
    /Library/Receipts/PGP.pkg/
    /Applications/PGP.app/
    /Applications/PGP\ Shredder.app/

     

     

    files from the user's ~/Library/Preferences folder
    com.pgp.desktop.plist
    com.pgp.engine.plist
    com.pgp.pgp.plist

  • ik8sqi2 Level 1 Level 1 (35 points)

    Phew.... Success. I removed all the files referenced in the article at:

    http://prowiki.isc.upenn.edu/wiki/Removing_PGP_Desktop_on_a_Mac

     

    But that wasn't enough. PGPWde drivers were still being loaded during boot. Searching thru the drive, there were still PGP remnants.. I found and removed these two as well:

    /System/Library/Extensions/PGPwde.kext

    /Library/PriviledgedHelperTools/com.pgp.framework.PGPwde

     

    I also found and deleted a couple of pgp-related plist files, but forgot where they were... probably not important anyways.

     

    After removing ALL of the above, Lion finally booted successfully.

     

    Moral - NEVER NEVER NEVER go anywhere near PGP/Symantec products again.

  • isamuel Level 1 Level 1 (0 points)

    You're my hero. I was having this problem too and this worked. Thank you.

  • Christopher Graham5 Level 1 Level 1 (15 points)

    The above got me oh so close, but I had to do more.

     

    in recovery terminal, I had to dig through the PGP.app to find an uninstall script. From that, I found all the rm statements. In /Applications, do the following find command to see the uninstall script - do not remove via "rm" any of the files yet - move then aside

     

    find . -name uninstall* -print

    ./PGP.app/Contents/Resources/uninstall_pgp.pl

     

    I moved them aside with the same directory structure that I found them in, in a directories like

    .../PGP-uninstalled/Library/Receipts/...

     

    Then, I rebooted, but still had no joy - stuck at a PGPWDE boot loader error.

     

    Going line by line in the uninstall_pgp.pl script, I took these lines and did them by hand, pulling the required files from my moved aside files ... if they are deleted you are toast, cause I could not find them in the DMG. You could pull them from another machine's install if needed. The key to these lines are that it fixes the boot setup to not have PGP in the mix.

     

    /bin/cp ./Applications/PGP.app/Contents/Resources/rmbp /Library/Application\ Support/pgpcleanup

     

    /bin/chmod a+x,u+s ./Library/Application\ Support/pgpcleanup

     

    /bin/cp ./Applications/PGP.app/Contents/Resources/com.pgp.cleanup.plist /Library/LaunchDaemons/com.pgp.cleanup.plist

     

    Then a rebot via safe mode and it came back up.

     

    All the files referenced in the script:

     

    ls -l /Library/Receipts/PGP\ Universal.pkg

    ls -l /Library/Receipts/PGP\ Engine.pkg

    ls -l /Library/Receipts/PGP.pkg

    ls -l /Library/Receipts/PGP\ Desktop.pkg

    ls -l /Library/Receipts/PGPwde.pkg

    ls -l /Library/Frameworks/PGP.framework

    ls -l /Library/Frameworks/PGPui.framework

    ls -l /Library/Frameworks/PGPusp.framework

    ls -l /Library/Frameworks/PGPwde.framework

    ls -l /Library/Frameworks/PGPwdesdk.framework

    ls -l /Library/Frameworks/PGPclient.framework

    ls -l /Library/Frameworks/PGPproxy.framework

    ls -l /usr/lib/libPGPdyndebug.dylib

    ls -l /Library/Application\ Support/PGP/PGPSyncEngine.app

    ls -l /Library/Application\ Support/PGP/PGP Engine.app

    ls -l /Library/Application\ Support/PGP/pgpipfwtool.pl

    ls -l /Library/Application\ Support/PGP/pgpdivert

    ls -l /Library/Application\ Support/PGP/PGP Random Seed.rnd

    ls -l /Library/Application\ Support/PGP/machine.uuid

    ls -l /Library/Application\ Support/PGP/.DS_Store

    ls -l /Library/Application\ Support/PGP

    ls -l /Library/StartupItems/PGPDesktopWatcher

    ls -l /Library/Extensions/PGPdiskDriver.kext

    ls -l /System/Library/Extensions/PGPwde.kext

    ls -l /Library/Extensions/PGPnke.kext

    ls -l /usr/local/bin/pgpdisk

    ls -l /usr/local/bin/pgpwde

    ls -l /Library/Contextual\ Menu\ Items/PGPcontext.plugin

    ls -l /Library/Mail/Bundles/PGPmail.mailbundle

    ls -l /Library/Mail/Bundles/PGPmailPanther.mailbundle

    ls -l /Library/Mail/Bundles/PGPmailTiger.mailbundle

    ls -l /Applications/PGP\ Shredder.app

    ls -l /Applications/PGP\ Viewer.app

    ls -l /Users/cgraham/Library/Preferences/PGP Universal Policies

    ls -l /Users/cgraham/Library/Logs/PGP/PGPlog.xmm

    ls -l /Users/cgraham/Library/Caches/PGP

    ls -l /Users/cgraham/Library/Caches/PGP Engine

    ls -l /usr/local/bin/pgpdisk

    ls -l /System/Library/Extensions/IOStorageFamily.kext/Contents/Resources/pgpdisk.icns

    ls -l /Library/LaunchDaemons/com.pgp.framework.PGPwde.plist

    ls -l /Library/PrivilegedHelperTools/com.pgp.framework.PGPwde

    ls -l /var/run/com.pgp.framework.PGPwde.socket

    ls -l /Applications/PGP.app

  • jconway Level 1 Level 1 (0 points)

    ik8sqi2 - This worked for me, thanks.

     

    Christopher Graham5 (and anyone else with this problem) I did not have to go thru your extra steps but I did boot off a recovery jump drive I created with Lion instead of the recovery partition, don't know if that made a difference.

  • hejish Level 1 Level 1 (0 points)

    I too am having the same problem.  I can use the recovery partition to boot, but cannot mount my disk0s2 to remove and move files.

     

    I am trying hdiutil mount /dev/disk0s2 -stdinpass (and then I put in my password)... oh - is it asking for the alphanumeric password it created?

  • Christopher Graham5 Level 1 Level 1 (15 points)

    Okay - what you need to do is after you boot into the recovery mode, go to Disk Utility and dounble click on your drive. It will ask for a password, and then mount the drive. Exit Disk utiltity, then go to the Recovery Terminal via the menu item.

     

    My password was not the alpha-numeric, but rather the master filevault password I set. You may just need to put in your user password, but I did not try that one.

  • AppleStar Level 1 Level 1 (45 points)
  • JofArnold Level 1 Level 1 (5 points)

    Full and faster solution:

    1. Boot into recovery mode (hold cmd+R as the computer starts)
    2. Use Disk Utility to mount your encrypted drive by double-clicking on the disk and entering your normal encryption password
    3. Load Terminal from the other utilities
    4. MOVE just the following two files to a convenient location
      1. /System/Library/Extensions/PGPwde.kext
      2. /Library/PriviledgedHelperTools/com.pgp.framework.PGPwde
    5. Boot - it should boot normally
    6. Once booted back into the GUI, copy those two files back
    7. Run the PGP removal stuff via the GUI
    8. Never ever ever ever use PGP ever again

    Props to all the above posters for leading me to finding this solution, and props to BenjieGillam for calmly running through it for me.

     

    Good luck!

    Jof

Previous 1 2 3 Next