Previous 1 2 3 4 Next 90 Replies Latest reply: Jun 24, 2015 7:57 AM by rexecca Go to original post Branched to a new discussion.
  • URBAN_GENIUS Level 1 Level 1 (0 points)

    OK, I too have had issues. But after some investigating I found the root cause for the syncing issues between the iPhone, iPad, and iCal on my Mac.

     

    The reason people are having issues is due to a mis-match of "calendar type" slected when one makes a calendar entry and not having all the calendar types selected to show on each device. Let me illustrate this point by images and ellaboration.

     

    A calendar event must be associated to one of three calendar choices on the iCloud calendar type - Home, Work, or Calendar. Also, if you use a calendar type to make an entry then you must have that type selected to show on all devices. Otherwise it will show on those that have it enabled and not on device that don't have it enabled.

     

    I have created four test events to illustrate this point. Test 1, 2, and 3 are events associated to one of three iCloud calendar type. While the "Introduction" event was entered using a non iCloud calendar type - "Work".

     

    You can see Test 1,2 & 3 calendar events showing on all devices. However the "Introduction" calendar event only shows up on the iCal.

     

    All four calendar events as seen on iCal on my Mac Pro. The event "Introduction" was created in iCal on the Mac Pro. This event was set to My Mac Work Calendar which is not a choice under iCloud calendar options. This is why it only apears on the Mac Pro and not the other portable devices.

    iCal-00.jpg

     

     

    iPhone: Only three events showing  

    iPhone.jpg

     

     

    Test 1 event was entered in iCloud Home calendar on the iPhone

    ip000.jpg

     

     

    This screen shows that all three iCloud calendars have been selected to display on the iPhone. This is why you can see all three Test events on all three devices.

      ip.jpg

     

     

     

    iPad: Only three events showing

    ipad000.jpg

     

    Therefore, when you make a calendar entry on any device and you want it to show on all three devices make sure you select one of three iCloud calendar types. Otherwise it will only show on the device you enter the event.

     

    Hope this helps...

  • David Grigg1 Level 1 Level 1 (0 points)

    URBAN:

    A calendar event must be associated to one of three calendar choices on theiCloud calendar type - Home, Work, or Calendar. Also, if you use a calendartype to make an entry then you must have that type selected to show on alldevices. Otherwise it will show on those that have it enabled and not on devicethat don't have it enabled.

     

     

    This doesn't help me at all.  On my iPhone, when I add a new event, I don't get the option of choosing what calendar type it belongs to.  The only calendar I have on the phone is the iCloud Calendar, but new events don't have any choices about what type they are.

     

    Your comments also don't help me with Contacts.  I very nearly lost all of my contact information, which vanished not only from my phone and iPad, but also then from iCloud - I literally saw them all disappear on the web site!  I only got them back because I'd saved them as vCards on my MacBook.

  • URBAN_GENIUS Level 1 Level 1 (0 points)

    David Grigg1:

     

    Please take screen shots as you enter an event on your iPhone and post them to this blog. There is no way I can assist you further without seeing what's going on with your device.

     

    You should have two screens to show: (1) "Add Event" and (2) "Calendar" screens.

     

    Scroll down past "Invitees" and "Alert" and the next is "Calendar" take screen shot of this.

     

    Select "Calendar" and you should get another screen and take a screen shot of it.

     

    FYR, to capture the screen on an iPhone or iPad press the home and the off button at the same time. Go to the photos app and you will find the images there. Email it to yourself and then open your mail client on your Mac and move the images to the desktop and then embed them in a reply post.

  • David Grigg1 Level 1 Level 1 (0 points)

    Here you go:

     

    photo1.PNG

     

    photo2.PNG

  • tobyiii Level 1 Level 1 (0 points)

    I am having the same problem as David with my wife's iPhone. Our shared icloud calender works fine with my iPhone & Mac, and my wife's iPad and Mac but on her iPhone the only events she can create are on he iCloud calender, she can view and edit events on her iPhone but not create them.

    I have tried doing a restore on her phone and deleting and re sharing the calender but nothing seems to work.

    Very frustrating as it works fine on her iPad and all the iCloud account settings are the same.

  • URBAN_GENIUS Level 1 Level 1 (0 points)

    David Grigg1 & Tobyiii:


     

    I looked at the screen shots of David's phone and I noticed something. It appears that David is in Australia and on the Telstra network. Imust first say that I don't know anything about this cellular carrier and it's infrastructure so what I'm about to say may not make sense. But before I do, Ihave some questions.


     

    (1) Are you on a data plan with the carrier?

    (2) Have you always had this issue or is it new?

    (3) Is it an intermittent issue or it has never worked?

    (4) Is this a jailbreak iPhone or was it purchased from thecarrier?

    (5) Have you had any other technical issues with the iPhone -hardware or software related?

    (6) Are your friends on the same network having similar issues?

     

     

    Here goes my analysis. One reason you can't see calendar optionson the phone is because of hardware or software, or both conflicting with the carrier's cellular signals. What I mean by this is that for some reason yourphone thinks that it does not have a data push/pull function enabled on yourdevice. This function is turned on by the carrier to your iPhone via a signal to the device.

     

     

    How did I come to this conclusion? I did some basic tests withan iPhone 4 and iPhone 3G and iPhone 3GS. I found that when I simulated adisconnection from the carrier's signal I noticed the Calendar optiondisappeared as a feature to adjust on all three phones. In another word, theoption was totally gone from the screen.

     

     

    There are only three ways this can happen:

    (a) A hardware defect causing intermittent receiving of data push/pull signal

    (b) A software malfunction is causing the absence of hardware/software receipt of the data push/pull signal

    (c) The SIM chip has a defect.

     

     

    I would recommend going back to the carrier and showingthem your phone. Compare the screen of the display unit next with yours. If the display unit has the calendar function then your phone should as well.  I would recommend them replace the SIM chip first. If that doesn’t take care of it, then it is an internal hardware/software conflict and can only be addressed by a technician. You willhave to send it in for repairs or replace it with a new one.

     

    Let me know if this helps...

  • David Grigg1 Level 1 Level 1 (0 points)

    Thank you for all of this, but I don't think you can be correct.

     

    Yes, I'm in Australia.  My iPhone is not jailbroken, but it is unlocked, which is how I bought it from the Apple store here.

     

    But I also don't see the fields you mention when I add an event through my iPad, nor through iCloud on the web.  The image below shows the New Event box in iCloud, and I've opened up the Calendar field to show that there is only one entry - Calendar.  However, the good news is that for some reason it has all sorted itself out and events are syncing again.  Don't ask me why!

     

    Capture.PNG

  • Thomas E. Delaney Level 1 Level 1 (0 points)

    Well I am glad to hear it worked out for you, but that is more of the same with this functionality.  I *paid* for MobileMe for two years, and it never worked very well, and it appears to me that although it is certainly better that I do not have to shell out $59.95 annually to use iCloud, the functionality has not improved and is dicey.  What I found is that if I enter everything into the web side (iCloud now, formerly MobileMe), all of it, contacts, calendar events, then these little packets of data will make it down to my iPhone, iPad, MacBook Pro eventually.  Yesterday I added a bookmark in Safari on my MacBook Pro.  Did not see the bookmark on the iPad until several hours later.  I am also using the Photo Stream, which from iPhone to iPad works very well, but on the MacBook Pro it may be a day before I see the photo in iPhoto.  Not sure why that is, but that is what I have observed.  And don't even talk to me about Notes.  I have lost all my notes several times - just gone, all of them. Yesterday I came up with a new strategy: create the note in Mac Mail under Notes, and sync up through iTunes, and this seems to be working with no losses - at least so far.  It seems to me it should either work, and not delete your notes, or not sync, but what it was doing deleting every darn one of them from all devices is something I cannot fathom. You have to believe someone else is going to come along and get this right and clean Apple's clock in the process.  I would gladly pay for such a reliable service.

  • David Grigg1 Level 1 Level 1 (0 points)

    Yes, that vanishing trick happened with my Contacts.  Thank goodness I had them backed up!

     

    I also was a Mobile Me subscriber, and for me it generally worked pretty well.  Surely Apple can get their act together with this eventually, and then it will be great.  I'm loving using Siri, by the way, and part of my disappointment with the iCloud syncing was just that I could create events and reminders so easily on my iPhone, but then they weren't getting up to the cloud.

  • sgw2003 Level 1 Level 1 (0 points)

    I've been frustrated as well by the same problem. I was using MobileMe. When I updated to IOS5 on my iphone, my contacts were duplicated and calendar went crazy as well. I have not upgraded to Lion on my Mac and don't intend to yet. What I did to fix the problem was to change the sync settings on my Mac so that Mobile Me was no longer automatic - manual. Then I turned off Mobile Me on my iphone (I was afraid to delete it off Mac & iPhone quite yet). Then I went in and deleted the double contacts off my phone manually that had been duplicated. However, my calendar entries were still not showing up on icloud when I checked. So - the fix to that problem was to delete the icloud account off of my phone and saving all info to phone when asked. Then I added it back and all of my calendar entries were there!

  • theresecloos Level 1 Level 1 (0 points)

    My icloud is syncing with my iphone 4g, but the time is not correct!  When i put in my work-time from 6.45 till 15.45 on my computer, my iphone says i have to work from 15.45 till 0.45 ....   i've tryed everything, but when i change my time one the iphone, my agenda on the computer isn't correct anymore!!

     

    Im getting realy frustrated allready.... Can somebody help me please????? 

     

    (sorry, my englisch isn't so well...  im living in the Netherlands (Groningen) ...

  • 42N8Leigh Level 1 Level 1 (0 points)

    The suggestion to delete iCloud from iPhone under Settings / iCloud, then set it up a second time worked for me!  Thanks! 

     

    I'd already confirmed Mac, iPad and iPhone were on the right software versions, I had selected the same calendars on each device, etc.  Somehow iCloud, iCal on my Mac, and Calendar on my iPad all sync'd just fine, but Calendar on the (3GS) iPhone was the hold-out.  No calendar updates in either direction.  I deleted the iCloud account as per your suggestion, then proceeded to compare, line item by line item, settings on my iPad (which worked) against those on my iPhone (which did not work.)  During that process, I was in Settings / Mail, Contacts & Calendars going over the Calendars section when I noticed that my iPad had the field "Default Calendar" while my iPhone did not.  I made some minor changes to "Default Alert Times" on my iPhone screen and actually saw "Default Calendar" line added to the screen as I watched.  (?!)  I made sure the Default Calendar set on my iPhone matched that on my iPad and was the same one I use on my Mac, and now everything works great.  Guess my point is that 1)this Default Calendar field appears to be very important and 2)it didn't immediately appear after I deleted and set up iCloud on my iPhone a second time.  It only appeared after I updated another field in the Calendar section of Settings / Mail, Contacts & Calendars.  (Could also have just been a function of time?) 

     

    At any rate, thanks for posting your response about deleting/re-adding iCloud earlier!

  • howard86 Level 1 Level 1 (0 points)

    I was also having a similar problem.  Rebooting the icloud on my iphone fixed it. Thanks for the assistance.

  • jess_b Level 1 Level 1 (0 points)

    I have had the same problem and due to the mixed reviews of Lion I was not interested in taking that bait and wanted to find a fix around downloading Lion to make iCloud and iCal sync. I actually turned off the iCloud sync for iCal (you can do this from the iCloud menu in settings on the iPhone).  Then I opened iTunes and clicked to sync iCal as I used to with my old iTouch.  Now I do have all of my calendars on my iPhone and they will be synced over WiFi to my mac.  Now this does mean that I am not using iCloud for my calendars so that is a drawback but it is at least a way around the issue of updating to Lion for now.

  • davidfrommalahide Level 1 Level 1 (0 points)

    This may sound silly, but check the email accounts associated with your devices.  After burning a few brain cells on this, and setting up my iCloud on my iPad and iPhone, there was still a sync issue, even though the iClouds were set up under the same apple id.  My iPad comes from work, and the default calendar is set up under my work email.  If I want to input something to share from my iPad to the Iphone, I just have to adjust the Calendar type (Home, Work, Outlook, etc...), and this has fixed my problem.  Thank you to all for your help!

Previous 1 2 3 4 Next