Previous 1 2 Next 16 Replies Latest reply: Jun 3, 2014 11:06 PM by srikanth046
kcouvillion Level 1 Level 1 (0 points)

How to resolve error code 3004. Anybody dealt with this yet


iPhone 4
  • Dunstonlads Level 1 Level 1 (0 points)

    I'm in exactly the same position... Downloaded iOS 5 then went to do a clean install then to restore from m backup. Now phones stuckin recovery mode showing error 3004 help anyone ?

  • Pupicek Level 1 Level 1 (0 points)

    I am having the same problem. My Iphone 3gs is stuck in recovery mode. 

  • James D.3 Level 1 Level 1 (35 points)

    My iPhone 3GS failed to upgrade with error code 3004, and when I retried it bricked and got stuck in recovery mode. I did a hard reset of the phone (home + lock buttons) and plugged it into iTunes and it restored and recovered from backup.

     

    I *think* the problem was that Apple's servers were getting hammered, because it always seemed to fail when iTunes was phoning home. Give it some time, take a deep breath, and keep trying. Four hours later my 3GS is up and running with iOS 5 and all my apps and settings.

  • Pupicek Level 1 Level 1 (0 points)

    Yep that is what I have discovered as well. Mine is currently restoring the apps....all is looking better.

  • bhaskar21 Level 1 Level 1 (10 points)

    Same problem. Have been on recovery mode for the past 5 hours.

     

    I called Apple, they told me tough luck. I don't know what happened to Apple and their customer service. Only if Jobs was still alive.

  • Michael Pitogo Level 1 Level 1 (35 points)

    Does their system not scale to terrabits?  This has been on going with Apple and iOS updates since my first iPhone in 2007.  Why don't they learn?  Spend some of that cash an pay for capacityyyy.

     

    My iPhone 4 is in essence bricked until I get out of this cycle.  I tried two machines with iOS 5.0 and every time I get error 3004, it goes through the extracting, contacting, preparing, restoring, verifying then the progress bar gets to 3/4 on the iPhone and it kicks out the error 3004.  Been like 7 times, 4 on my desktop and 3 on my mbp.  I won't even bother upgrading our 3 iPad's and my wife's iPhone 4 till this is sorted.

  • harrisonfrommoultrie Level 1 Level 1 (0 points)

    Same problem here.

  • zuggiinc Level 1 Level 1 (0 points)

    When I tried typing what they say on the Apple Support website, everything worked like a charm

     

    http://support.apple.com/kb/TS3694#error3004

  • loyal customer Level 1 Level 1 (0 points)

    i am also getting the same error 3004.... retried many times.... i have since upgraded to 10.7.2 and itunes 10.5 and the 3004 error keeps popping up when "restoring iphone firmare"and the progress bar goes zebra-scroll...

     

    i have also launched terminal and typed in: dscacheutil -flushcache... still doesn't work!

     

    ....AND OMG.... AS I WAS TYPING THIS ANOTHER RESTORE ATTEMPT SEEMED TO WORK!!.

     

    I GUESS THE MORAL IS - JUST KEEP TRYING.... and good luck!

     

    -AMG

  • Michael Pitogo Level 1 Level 1 (35 points)

    Well mine finally worked.  The must have known Apple servers were going to get crushed. 

  • vetlix Level 1 Level 1 (0 points)

    I have tried for 12 hours, over a period of two days to get this resolved. None of the solutions posted on the apple support forums have worked. I was about to give up when I found the following solution and it has worked for me.

     

    1- Close iTunes if it is already open


    2- Open Internet Explorer


    3- Click Tools, then Internet Options


    4- Click the "Advanced" tab


    5- Scroll down to the security section. Make sure "Check for server certificate revocation (requires restart)" is UNCHECKED


    6- Then click Apply AND/OR OK


    7- Restart the computer BUT PLEASE FIRST BOOKMARK (add to favorites) THIS PAGE SO YOU CAN COME BACK WITH ME AFTER THE RESTART, and click Accept if the issue is solved (that's the only way I can get paid for my effort. Thank you)


    8- Open iTunes. Please let me know if the issue is solved or not, so we can continue troubleshooting.

     

    Source: http://www.justanswer.com/mac-computers/424u2-need-help-getting-itunes-work-lapt op-it-s-running.html

  • StoreThomas Level 1 Level 1 (0 points)

    OMG.

     

    Have you ever been kissed by a man over 40 with a full beard? If not then please come to Denmark so I can kiss you

     

    Been pulling out my hair with this problem for 5-6 hours, and finally fell over your answer.

     

    Thanks is a poor word for what I'm feeling at the moment

  • vetlix Level 1 Level 1 (0 points)

    I'm glad it helped you too!!! I just had to post this solution when it worked for me, as it was driving me nuts.

     

    If I ever find myself in Denmark I'll let you buy me a beer instead

     

    Cheers.

  • cryptdweller Level 1 Level 1 (0 points)

    I can't thank you enough mate...Amazing trick..God bless you..

     

    I tried everything that google came up with and this trick worked at last...

Previous 1 2 Next