Previous 1 2 3 4 5 6 Next 79 Replies Latest reply: Mar 26, 2013 10:50 PM by benbischoff Go to original post
  • eileenc813 Level 1 Level 1 (0 points)

    You might be overthinking this, which I can't because I have a simple mind, but this worked for me...make sure your Apple ID on Photostream and iTunes are the same...

  • chickiejcr Level 1 Level 1 (0 points)

    So the solution is that I had to turn photostream in iPhoto.

  • Scripty Level 1 Level 1 (5 points)

    Ok so I have had issues with this since I bought an iPad 2 last week and installed Lion on my MacBook pro last week.  I took a photo with my iPhone 4 and it showed up on my iPad but not my laptop.  I had Photo Stream enabled on each of the 3 devices.  WHY wouldn't it work.  I have spent a few hours on line on this board and others trying to find a solution but couldn't find a thing.  Then I read something here today that sparked a thought.


    When I set up my iPad, for some reason it changed my Apple ID email address from a .me account to one of my gmail accounts.  I have no idea how it did this but it took me several hours to figure out that is what happened - I was trying and trying to sign in to my account on my iPhone to buy an app and it kept saying I had the wrong password.  But I had not changed anything on the iPhone.  Like I said it took me a few hours but I finally figured out the issue and, lo and behold, the same old password worked fine with the new gmail account.  So I just went with it. 

    What I realized today is, my Apple ID had changed and was working fine on iTunes but I had not changed it for my iCloud account on any device.  So I checked it out by going to and clicked on my name on the top right corner and up came the window with my Apple ID in it and, yep, it was my .me ID.  So I changed it to my gmail ID.  I then did the same thing on my iPhone and my iPad.  I had to go into Settings - iCloud and then delete the old account.  It asked me if I wanted to save the content and I said yes.  Then the new ID automatically replaced the old one and all I had to do was sign in.  This was on both the iPad and the iPhone. 


    I took a photo with my iPhone and had the iPad Photo Stream open and iPhoto photo streams open on my laptop.  I waited, holding my breath.  After about 30 seconds, the photo popped up on both my laptop and my iPad.



  • 00606361m Level 1 Level 1 (0 points)

    Thanks drazan.  This solved my problem.

  • Gwydo Level 1 Level 1 (0 points)



    I have another weird issue with photostream and iPhoto that exists ever since iCloud was released. Although photostream is  correctly activated for iPhoto it does not display any photo but says that my photostream is empty. I know that Photostream is activated, since I can drag photos on iPhotos fotostream icon and they will show up when I view the photostream with my iPhone (which correctly displays the photostream). I have tried several things, like reinstalling iPhoto and so on, but nothing helped ... I thought that the bug would be fixed with an iPhoto update or (latest) with Mountain Lion. However, since neither this is the case nor somebody else reported this problem, I hope somebody here can help me.




  • stevencarpenter Level 1 Level 1 (5 points)

    Hello All,


    I thought you might be interested in my experiences. And the most oddest of fixes.


    The best summary I located for the actions to follow from the web was via helpdeskgeek (sorry Apple but your support articles are not as concise) the article is here BTW,


    However this isn't the problem, after hours of investigation, rebots, restes, etc.


    Oddly I could always see photostream photo's on the Apple TV so this naturally this pointed to iPhoto running under Lion (on a system with all patches applied),


    So were was the fault?


    Photos running under iOS! (On a patched iPhone running iOS5)


    A simple double press of the home button, then hold down the iPhotos app, wait for it to wiggle and press the red minus button. Then relaunch it.


    I am still not clear why photostream photos did not show up under iPhoto but they did appear under the Apple TV, however once completed all functionality is restored and I could use this for the first time.


    For those of you trying to get it the photostream function to work the first time (like me) I might add that the following steps are required,

    1, Take the picture with the camera,

    2, Get your iDevice on to a Wi-Fi network

    3, Open the Photos app on the iPhone and soon you see the sync occur to iCloud (top bar).

    4, With iPhoto running on the Mac there is an agent (Utilities > Activity Monitor) called PhotoStreamAgent that waits in the background and kicks off a 'get' from the users iCloud account.

    ...and voila, all is now working!


    A bit rubbish these not so clearly documented steps are missing IMHO.

    (Clearly like the TV ads state in subscript, the marketing sequences were shortened).


    However there obviously is a nasty bug in there somewhere and lets hope its in the iOS6 bug fix list, else please remember to reset Photos on the iDevice before syncing.



  • stevencarpenter Level 1 Level 1 (5 points)

    Sadly I now have to eat my earlier words and must report that after a few hours PhotoStream has defaulted back to its usual behaviour under iPhoto in not showing any content. Very bored of trying to use this feature now so going to give up until the next round of software updates arrive from Apple.

  • Gwydo Level 1 Level 1 (0 points)

    For all those who encounter the same problem as I did:

    Method 1 from Steven's helpdeskgeek link finally solved my problem!

    Thanks a lot Steven!!!!

  • benbischoff Level 1 Level 1 (10 points)


    Method 1 on stevencarpenterfirst link (helpdeskgeek) sorted me out!

    2 mins and it was sorted!


    Thanks a million.

  • stevencarpenter Level 1 Level 1 (5 points)

    Thought you all might like to be aware that following an upgrade to 10.7.5, iPhoto 9.4.1 and iOS 6 all my problems have been solved too.


    I'm not quite sure which one did the trick, but now I can take a photo in Camera on the iPhone, open Photos on the iPhone and then a few seconds later the pictures is in iPhoto's photo stream on the Mac.

  • chickiejcr Level 1 Level 1 (0 points)

    So now that that is solved, is there any way to download photos from the photo stream to a PC. iPhoto does not exist there.

  • stephenfromhalifax Level 1 Level 1 (0 points)

    I wish this would work for me.  I'm running Mountain Lion (10.8.2) and iPhoto '11 (9.4.1). have a few problems with method 1 and method 2.  First of all, I don't have a Library folder in my user directory, only on the root of my hard drive, secondly, niether  \Application Support\iLifeAssetManagement nor Preferences\* exist in the Library folder. 


    I wonder if this articel is referencing an earlier version of iPhoto, becasause the option+command startup of iPhoto gives me:

    Screen Shot 2012-10-12 at 10.29.17 PM.png

    Which is significantly different than what is shown in the article . . . . .

  • benbischoff Level 1 Level 1 (10 points)

    Hi, if you open finder then along the top of the screen click on 'GO' then hold down the 'Option' key and then the 'Library' folder will appear.

    Hope this helps.


  • stephenfromhalifax Level 1 Level 1 (0 points)

    Thanks benbischoff!  I totally forgot about that!  Method two wroked for me, I hope it keeps working!



  • jorkata Level 1 Level 1 (0 points)

    Thanks a lot Ken. That worked perfect for me. Now I can see the photo stream in iPhoto on my Mac but for not the pictures from the other devices (iPod,iPhone and iPad) which work ok between but not on the laptop.