Previous 1 2 3 Next 39 Replies Latest reply: May 9, 2012 3:40 AM by adalie.g Go to original post
  • jonespita Level 1 Level 1 (0 points)

    I had started a similar thread, and got a solution from there, reposted here...

     

     

    "I get the following error when attempting to enable Calendars & Tasks on my PC:

     

    "Restart outlook with mail enabled before turning on calendars & tasks or contacts.

     

    You need to add your iCloud Mail account before Calendars & Tasks or Contacts can be set up."

     

    Although I was just able to get Contacts to set up, no joy on calendars. Originally, it wouldn't work for both, but I checked Contacts, that worked, and now it still doesn't for Calendars.

     

    Any thoughts?

     

    Vista Ultimate x64

    Outlook 2007

                                                                               

                                                iCloud, Windows Vista                                       

                                                                       

    Correct Answer by robertfrompearl city  on Oct 14, 2011 3:01 AM

    robertfrompearl city

    go to FILE > INFO > ACCOUNT SETTINGS.  Then, on E-MAIL tab, select you @me.com address and "set as default".

     

    This worked for me.  It was SO refreshing!  After hours of struggling with it!"

     

     

     

    "This one finally worked for me. It took 2 restarts of Outlook, as well as setting iCloud as the Default data file (which prevented outlook from starting), changing the default back to my other, then restarting again, and now it works. Totally and completely, including creating a test event on outlook, seeing it on icloud, deleting it on icloud, and it going away on outlook.

     

    Great find robertfrompearlcity, you fixed it, but it shouldn't be some random setting to change, and then change back and it still works..."

  • Eniluap Level 1 Level 1 (0 points)

    Same problem, ended up with duplicate entries, after several restore's of my iphone, i managed to log in to icloud.com log in and delete all icloud calendar before re-syncing from my PC to iphone, but I know have to enter event in both as it won't sync unless I plug into PC and sync as used to through itunes.

     

    Contacts seem to be fine no duplications, haven't checked if they've updated though (iphone to PC).

     

    Have googled answer and found talk of an "add-in" for Outlook, but haven't been able to find this or enable it, anyone any ideas?  Hopefully early days of IOS 5 and icloud, and Apple will sort it out quickly.

     

    Iphone 4S

    PC Windows 7

    Outlook 2007

  • ricsteinberger Level 1 Level 1 (0 points)

    I am having the same issues. [Pretty clear iCloud is a very beta release.]

     

    On my Mac (Lion 10.7.2), I select System Preferences->iCloud, and then uncheck Contacts, then recheck it.  It appears to sync to the cloud (thumnper spinning).  But on my iPhone, Contacts do *not* get updated.  Yes, I have enabled Contact sync on the iPhone 4S.  What else can I do? 

     

    Looks like the missing step is: Turn off Contacts in iCloud on the iPhone (and let it delete Contacts).  Stop the Contacts App.  Re-enter iCloud, and re-enable sync for Contacts.  Then restart Contacts.  Then it will sync.

     

    Wouldm't it be great is Siri could help people figure this out?

  • thebassman78 Level 1 Level 1 (0 points)

    I can confirm that ricsteinberger's solution is the one that works. This is also confirmed here.

  • MrCharles Level 1 Level 1 (0 points)

    I realised that from iPad to iCloud to Mac it worked fine, same if I created from iCloud it would push to both my iPad and Mac, my problem was when I created an event on Mac, it wouldn't push to either.

     

    It only started syncing after I edited the type of event from a "Work, Personal... - In my Mac" to "Work, Personal - iCloud" (Do that by using the "Get Info" option from right clicking an event, and then clicking on that colored square besides the "calendar"). Seems to me it lets you choose what you wanna push to iCloud and what you don't, given that it requires some of the 5GB free iCloud service in order to push to the cloud and then to your devices.

  • geridh Level 1 Level 1 (0 points)

    I have tried all of the checking / unchecking etc. I finally got it to work by going into a random contact on my iphone, deleting one digit in a phone number. Re entering the number, then everything sync'd. Not sure why but it worked

  • lefrank Level 1 Level 1 (0 points)

    I agree. Ricsteinberger's solution worked for me too.  Another note is to simply make sure your phone is in wireless mode, and not 3G.  It will not update if on 3G.

  • ricsteinberger Level 1 Level 1 (0 points)

    ANother point: If you modify Contacts on your Mac, and you have the Contacts App open on your iPhone, the Contacts App may not immediately sync.  What you can do to "tickle" a sync is tap on the Groups button, upper left, then when you're back in the Groups area, tap on the group you just left.  Contacts seems to need a minor change to get it to sync.

  • Josiah Battaglia Level 1 Level 1 (0 points)

    Adding the icloud account in ical worked.  Thanks for the info, I'be been having trouble with several of these little items.  I love Apple and all the tricks that the new stuff can do, but "It just works" seems a little unhelpful if you don't tell folks how to make it "just work".

  • Choupinette Level 1 Level 1 (0 points)

    I agree with you duzie

  • AGDMM Level 1 Level 1 (0 points)

    Unfortunatelly, in the beginning icloud was working for contacts (all others fine) now for quite sometime is not working anymore. I tried everything above and nothing is working. My system preferences - icloud - contacts freezes when setting off and the only way is to reboot the MBP and then comes back to system preferences with contacts on. A nightmare. Looks like Apple is dropping the ball in every single area. I'm one of the people who had problems with HD - smart errors and had to replace HD.  I just hope a huge Class Action comes after Apple as no one from Apple comes to these forums to help us. I'm extremely upset. Let's hope something changes in the future. Best !

  • celtdkey Level 1 Level 1 (0 points)

    On your Mac, you may have to go to Preferences of Address Book, then on the Accounts tab check the box Enable this account for your iCloud account. 

  • AGDMM Level 1 Level 1 (0 points)

    Thanks Celtdkey, but I had done that and is on. Not sure why. Besides the problem with synching I have the one of the computer slowing down tremendously.  I believe I found the problem with slowind down, but still trying to resolve the synch issue as the path suggested I can't find. Checked this out as I think this is good to know https://discussions.apple.com/thread/3355782?start=30&tstart=0  Thanks again for taking the time to reply.  Regards !!

  • AGDMM Level 1 Level 1 (0 points)

    Just to finish the speed is ok now due to link above, however after doing all unfortunatelly the contacts still not synchronizing. Hope they fix it in the future.

  • AGDMM Level 1 Level 1 (0 points)

    For future reference please check https://discussions.apple.com/thread/3430342?start=0&tstart=0  about sync contacts. at the end worked it out.