4 Replies Latest reply: Oct 13, 2011 5:02 AM by Jago Taylor
jayman720 Level 1 (75 points)

Just completed the iOS update on my ATV2. It installed, restarted, and then a big connect to iTunes screen appeared with a micro USB cable & the iTunes logo... Now what? I've restarted it, unplugged it, and even swore at it a few times. No go.  Anyone?.

MBP C2D 17", MacMini, G4 Blu/Wht, SE/30, iPhone, iPod(s), Newton, QuickTake 100, Mac OS X (10.6.5), I don't do windows...
  • Pantss Level 1 (0 points)

    Mine has done the exact same thing...now what?! anyone?

  • rawland Level 1 (0 points)

    same here ((

  • jayman720 Level 1 (75 points)

    Bad news. You have to go to an apple store if you don't have a micro USB cable did it last night, and everything is fine.

  • Jago Taylor Level 1 (10 points)



    I have the same issue with the restore/flash failing and now I have the USB image and rapid flashing LED.


    I have a micro USB cable and tried a restore via itunes (10.5) this morning. The update file downloaded and attempted to install but failed with an unknown error.


    I think the issue might be a corrupt update file. Anyway, I will try again this evening (now at work for the day) to see if this helps. I read an earlier post in another thread saying that the restore worked after 3 attempts so hopefully i can sort it if i keep attempting the restore.


    Any other ppl have any ideas?


    Also, just checked when i bought my ATV and it was 15th October 2010. I think that means that I am still under 12mth warrantee. Is this correct? Do I need to get this sorted by 15th October or get it replaced before?







    Hi All,


    As an update to this post. I have just found this possible solution on the interweb. Will try this tonight and let you know the result. One reason I am quite confident this could work is that I know that my computer (dell laptop) has low power on the USB port.


    So I really hope the instructions below work...





    Hey, I just brought my Apple TV 2 back from the living dead. After a botched firmware update all it did was flashing the white LED fast (about 3 times a second).
    I followed the official reset instructions using the Apple remote but that didn’t help at all. Then I came across a few posts that said that by hooking up Apple TV 2 to a Mac using just a micro USB cable, you could actually restore it in iTunes. Those posts explicitly said that you have to disconnect HDMI and power and just plug in the USB cable.

    I dug out a micro USB cable and connected it to my Mac. Shortly after, iTunes showed up with the restore screen for Apple TV 2. So far, so good.

    But every time during the early stages of the update process, one of those error messages appeared.

    The Apple TV could not be restored. An unknown error ocurred (2006)

    The Apple TV could not be restored. An unknown error ocurred (1611)

    The Apple TV could not be restored. An unknown error ocurred (1602)

    The Apple TV could not be restored. An unknown error ocurred (2009)

    It just didn’t work. I was already thinking about returning it back to Apple, when I had an idea. Maybe the power delivered by the Mac’s USB port isn’t enough for whatever goes on during the restore process? So I connected a power cable after Apple TV 2 showed up as being restorable in iTunes and voilà, the restore went through without a hitch!

    If your Apple TV 2 is stuck with a fast flashing LED and iTunes fails to restore it using a micro USB cable, just connect the power cable as well and the restore might get through.


    Message was edited by: Jago Taylor