14 Replies Latest reply: Nov 1, 2011 4:01 PM by helen65
att *** Level 1 Level 1 (0 points)

I have turned on led flash notification on and nothing happens when I get phone calls, text, e-mail etc. I have turned off the led setting and then turned it off the phone. I then restarted it and turned the setting back on and nothing happens. The light never goes off. I checked the light and it works fine. Any ideas on how to fix this?


iOS 5
  • TJRubicon Level 1 Level 1 (5 points)

    I'm sorry, where is this feature located? I'll try it and let you know what I get.

  • att *** Level 1 Level 1 (0 points)

    It's located in the settings under general then under accessibility it's LED flash alerts. thanks for checking.

  • TJRubicon Level 1 Level 1 (5 points)

    Turned it on last night, haven't had any LED flashes since, sorry. Let me know if you get it worked out, good luck.

  • Fulya Level 1 Level 1 (0 points)

    It's same with me, nothing happens when I get phone calls, text, e-mail etc.. I tried many many times but sorry.. By the way I can use my flash when I use the camera.. I dont know why it is happening and why it is not happening..

  • Bhutta Level 1 Level 1 (0 points)

    hi

    i have just checked it. it works very well but i keeps blinking when a call is coming. as soon as the call is missed it goes off.

  • meemster Level 1 Level 1 (0 points)

    I can also confirm that this does not work for incoming calls, or other notifications (SMS, VM, etc)

  • baz1536 Level 1 Level 1 (0 points)

    Hi Guys,

     

    I just noticed this problem although I think I have found a fix for it.

    Go in to Camera and makesure the flash is set to Auto or On.

    Weird as to why they have built it into the Camera.app

  • meemster Level 1 Level 1 (0 points)

    Mm, nope this didn't fix it for me.

  • Frank Malloy Level 2 Level 2 (350 points)

    Reboot the phone. (Hold down power/sleep switch, then Slide to Power Off. Do NOT do a "hard reset" by continuously holding down power/sleep, which just yanks power)

     

    Note the following:

     

    - Phone must be asleep/locked for the LED to flash.

     

    - LED flashes a couple of times when an alert first comes in. It was NOT designed to flash continuously. Yes, it would be nice if it would flash every 5 secs. or so, but that's now how it's spec'ed, unfortunately.

     

    - LED does NOT flash for email notifications for some reason. All others seem to work.

  • RockyMtnCop Level 1 Level 1 (0 points)

       For Everybody Who's Having Issues With The LED FLASHING ALERT On The iPhone 4S, I May Have Promising News For You.

     

       I Just Spent The Last Hour Or So With An Apple Support Tech, Who Then Forwarded Me To A Senior Support Person. I E-Mailed Her This Link So That She Could Research This Issue.

     

       Long Story Short, We Eventually Went Into The Settings - General - Reset - & Reset All Settings. 3 Minutes Later Tops, I Went Back Into The Settings - General - Accessibility, & Then Turned The LED FLASH FOR ALERTS Option ON.  Tested It, & IT WORKED!!!!!!!!

     

       Tested It A Couple of More Times & It Still Works!

     

       I WANT TO THANK THE INCREDIBLY PATIENT APPLE SUPPORT STAFF, FOR AN AWESOME JOB!!!!

     

       The Senior Support Tech Also Requested That I Relay To All Apple Product User That Their Techs Do NOT Monitor Their Support Discussions. Sooooo, If Your Having Issues With Your Apple Product, Call 1-800-MYAPPLE, & They Will Do Their Best To Assist You With Your Problem.  AND I Am Not Affiliated With Apple In Any Way.  I'm In Law Enforcement!

  • Frank Malloy Level 2 Level 2 (350 points)

    Resetting all settings is drastic, and you'll have to set up a LOT to get everything back to the way you had it before. Resetting stuff to workaround a bug is not optimal.

     

    I hope this isn't something that is getting corrupted often - you do not want to Reset All Settings on a regular basis.

     

    That said, hope it is more robust in the next iOS update.

     

    Thanks RockMtnCop for posting the workaround.

  • fsacc350 Level 1 Level 1 (0 points)

    I am having this problem as well, however mine worked for about a full day.  Then I told a few friends and family about the LED alert.  Some of theirs worked for a little bit, and some never got it to work at all.  Very strange.  I've done a few internet searches and it seems as if a lot of people say that it works occasionally but there is no consistency.  Sounds like a bug of some sort to me. 

  • justjesse Level 1 Level 1 (0 points)

    RockyMtnCop

     

    Is your LED still working?  Have you rebooted or turned your device on and off at all since?

     

    Whenever I re-start my iPhone 4 the LED stops working.  Then I must turn the LED off exit to home screen, go back and turn the LED back on.  

  • helen65 Level 1 Level 1 (0 points)

    I've reset all settings as suggested by RockyMtnCop and this worked for me; however if I turn off my device the LED stops working. The solution to getting it to work again, is to turn off the LED exit to home screen, then go back to turn it on, as suggested by justjesse.